These are chat archives for angular/angular-2-ionic-2

7th
Nov 2016
zfireear
@zfireear
Nov 07 2016 04:55
Who can give me a form tutorial plz?
Rodrigo Rubio
@rrubio
Nov 07 2016 05:54

Hi Guys, trying to do a http.get to flickr (see url below) but i keep getting invalid single quote coming back. I've tried replacing the single quote also "JSON.stringify" then "JSON.parse" and still the same error. Does anyone know how i could clean this?

Here's the url https://crossorigin.me/https://api.flickr.com/services/feeds/photos_public.gne?tags=${query}&per_page=10&format=json&nojsoncallback=1

Rohit Kumar Vinay
@rohitkumarvinay
Nov 07 2016 08:39
can anybody let me know on how i can get started on aws lambda ionic2 and dynamodb
Alexey Rubinchyk
@rubinchyk
Nov 07 2016 09:08
Hi. Anybody here?
Merel Staal
@Merel1988_twitter
Nov 07 2016 09:21
Hi, is there anybody who can tell me how to get tabs on the bottom AND on top of my screen. Or is it impossible to use 2 sets of tabs?
they seem to be overriding each other
Frederik Prijck
@frederikprijck
Nov 07 2016 11:48
@tblasig Sorry, I had to go. Any chance you fixed it already ?
Kyle Roach
@iRoachie
Nov 07 2016 11:51
@frederikprijck He’s trying to use angular 2.1 with ionic 2.0
Frederik Prijck
@frederikprijck
Nov 07 2016 11:51
@iRoachie Ye that makes sense looking at the latest errors he showed.
Kyle Roach
@iRoachie
Nov 07 2016 11:52
Current ionic version only works with Angular 2.0.0
Frederik Prijck
@frederikprijck
Nov 07 2016 11:52
But I was more trying to figure out his Promise issue.
Kyle Roach
@iRoachie
Nov 07 2016 11:55
@zjhiphop What you’re looking is the ionic deeplinker http://ionicframework.com/docs/v2/api/navigation/DeepLinker/
Alexandre Almeida
@Vacalexis
Nov 07 2016 17:59
Is anyone else having flickering problems when pushing new pages? Also, is it impossible to have a <router-outlet> placeholder similar to Angular 2, in order to develop single page apps using Ionic 2?
matthayzon
@matthayzon
Nov 07 2016 18:05
anyone able to load google maps?
Thomas B.
@tblazz
Nov 07 2016 19:43
Hello @frederikprijck & @iRoachie , it seems even with "dependencies": {
"@ionic/storage": "^1.0.3",
"angularfire2": "^2.0.0-beta.5",
"firebase": "^3.4.1",
"ionic-angular": "^2.0.0-rc.0",
"ionic-native": "^2.0.3",
"ionicons": "^3.0.0"
},
"devDependencies": {
"@ionic/app-scripts": "latest",
"cz-conventional-changelog": "^1.2.0",
"@types/request": "0.0.30",
"typescript": "^2.0.3"
},
so angular 2 i got the error
Thomas B.
@tblazz
Nov 07 2016 19:52
Even if I just clone https://github.com/rodrigoreal/ionic2-angularfire-login, i get errors after npm install > ionic serve
Stephan Kristyn
@nottinhill
Nov 07 2016 21:08
Ok upgrade so far went ok-ok. Just 2 errors
Thans for above package json btw
I am getting this:
Class 'LanguageMissingHandler' incorrectly implements interface 'MissingTranslationHandler'.
[22:06:23]  Types of property 'handle' are incompatible.
and this:
 copy: Error copying "/Users/tyrion/devel/saveup-front/src/service-worker.js" to

            "/Users/tyrion/devel/saveup-front/www/service-worker.js": File not found
Anybody hitting any of those?
Stephan Kristyn
@nottinhill
Nov 07 2016 21:51
Ok fixed all errors and reported as answers in ionic2 forums
one error remaining
Cannot find module number_value_accessor in angular-forms has been fixed in ng2-2.2.0-rc0, but ionic 2 rc2 needs ng2-2.1.1
Stephan Kristyn
@nottinhill
Nov 07 2016 22:06
got rid by removing type=number in input fields
Stephan Kristyn
@nottinhill
Nov 07 2016 22:31
This is my seemingly last error. Overall RC2 upgrade already did cost me 2 hours...