These are chat archives for angular/angular-2-ionic-2

15th
Feb 2019
Chris NatDiv
@chrismwamba9_gitlab
Feb 15 09:17

@amirensit I also encounter the same problem when I execute:
$ ionic cordova run android

my sdk is up to date is my build-tools minimal is at version 19.0.0

What went wrong:
A problem occurred evaluating project ':CordovaLib'.

No installed build tools found. Install the Android build tools version 19.1.0 or higher.

Jorrit
@jorrit-wehelp
Feb 15 09:23
well, 19.1.0, and you said you had 19.0.0....?
Chris NatDiv
@chrismwamba9_gitlab
Feb 15 09:24
Ohhhh sorry, it was a mistake on my part
Jorrit
@jorrit-wehelp
Feb 15 09:24
also why the ancient versions.... they are at ~28 or something. It's just the verion of the build tool, can still use it to build for older targets
Chris NatDiv
@chrismwamba9_gitlab
Feb 15 09:29

I have the higher versions installed, ... from 19.1.0 to 28.0.3
but the following error still remains: * What went wrong:
A problem occurred evaluating project ':CordovaLib'.

No installed build tools found. Install the Android build tools version 19.1.0 or higher.

Jorrit
@jorrit-wehelp
Feb 15 09:34
hmm, is ANDROID_HOME env variable set. I think having the tools/bin directory in the PATH might also be required
Chris NatDiv
@chrismwamba9_gitlab
Feb 15 09:39
yeah! ANDROID_HOME env variable is set to tools/bin but the same error message still remain
Jorrit
@jorrit-wehelp
Feb 15 09:48
dunno then... at this point I would poke around in the actual .gradle file to see where it's looking and checking for the tools :/
choubani amir
@amirensit
Feb 15 13:34
@chrismwamba9_gitlab with andoird_home variable pointing to \bin folder, you need to download the build-tools with the version you want
You will get a new folder download called build-tools
then, you need to modify your android_home again
take a look here. It helped me to fix it