These are chat archives for angular/material

4th
May 2015
demetriusnunes
@demetriusnunes
May 04 2015 13:55
hi guys, i'm desperatelly looking for help about this issue related do 0.9rc3: angular/material#2439
anybody know anything about it? it's basically a performance issue with phatomjs. already tried with phatomjs 2, with no luck.
Ed Pelc
@epelc
May 04 2015 13:57
@demetriusnunes I'd start looking at the commits between rc2 and rc3
demetriusnunes
@demetriusnunes
May 04 2015 13:58
@epelc the problem started with rc1.
Ed Pelc
@epelc
May 04 2015 13:59
check between rc1 and 2 then. Even if you just browse the summaries it should give you a general direction
Also think outside the box it may be something totatly unrelated. For example #2543 caused google maps to constantly crash firefox because it made the maps somehow think it needed to render 99999px wide but you didn't see it onscreen
@demetriusnunes ^
I spent afew days figuring that out
demetriusnunes
@demetriusnunes
May 04 2015 14:18
@epelc it's impossible by looking at the commit log or the diff. it's just too many changes.
demetriusnunes
@demetriusnunes
May 04 2015 15:43
@epelc We've just found out that is related to some weird interaction with ui-router.
Ed Pelc
@epelc
May 04 2015 15:48
thats good you found it
demetriusnunes
@demetriusnunes
May 04 2015 16:21
@epelc actually, it was a false positive.
@epelc not a clue yet.
Ed Pelc
@epelc
May 04 2015 16:22
I had several of those with my maps issue just takes time
Dave Ackerman
@dmackerman
May 04 2015 16:26
chips are totally broken in RC3, can’t get them working
lots of Error: [$interpolate:interr] Can't interpolate: {{$mdChipsCtrl.getPlaceholder()}} TypeError: Cannot read property 'length' of undefined
Ed Pelc
@epelc
May 04 2015 16:27
I think they need a lot of work. They weren't even supposed to be in until 0.10.0
Dave Ackerman
@dmackerman
May 04 2015 16:28
yeah, but even the most basic ones work in the docs. not sure why they don’t work in our project
Ed Pelc
@epelc
May 04 2015 16:28
check what they initialize values to. There were issues with autocomplete if you didn't initialize things a certain way
Dave Ackerman
@dmackerman
May 04 2015 16:29
ok, thanks
yeah, works when I initialize the value ;)
Ed Pelc
@epelc
May 04 2015 16:31
thats good would you mind filing an issue so it gets fixed?
Dave Ackerman
@dmackerman
May 04 2015 16:42
yeah
is there anyway to validate chip input?
Ed Pelc
@epelc
May 04 2015 16:42
md-on-append?
Dave Ackerman
@dmackerman
May 04 2015 16:43
hmm
yeah. you can build them using inputs, was hoping I could just throw type=“email” and be done with it
Dave Ackerman
@dmackerman
May 04 2015 17:06
how do you prevent a chip being created when you use md-on-append anyway?
Yaniv Efraim
@yanivefraim
May 04 2015 17:09
This message was deleted
Miloš Stanić
@MilosStanic
May 04 2015 18:36
wow, okay, 0.9.0 is out!
Cosmin Ronnin
@kosz
May 04 2015 19:38
does it have a Datepicker ? :D
Dave Ackerman
@dmackerman
May 04 2015 19:55
noppppe.
:)
Ed Pelc
@epelc
May 04 2015 20:03
Has anyone tried running the docs locally?
Miloš Stanić
@MilosStanic
May 04 2015 20:35
yeah, I've been waiting for a datepicker since November :/