These are chat archives for angular/material

4th
Jun 2016
Dominic Watson
@intellix
Jun 04 2016 10:27
so basically use BS3 for that grid? ;D ended up refactoring everything to use VW/VH. I guess I just need to use media queries now to do a mobile/tablet version
Aldo Panetta
@ContePanetta_twitter
Jun 04 2016 18:45
Hello guys, anyone of you would suggest an IDE for angularjs that offers code's navigation between modules? Thank's in advance. .. bye
Aleksandar B.
@aleksandar-b
Jun 04 2016 20:26
guys, is there a way to set beckground color of a button? I tried everything - setting themeProvider in config, then setting different theme on parent container, and background is still white...
Manuel Pacheco
@ShadowManu
Jun 04 2016 21:03
@ContePanetta_twitter an angular + typescript project could have more intellisense about the app pieces.
@samosale depends on your problem. If its just setting the background color, use the md-raised class on the md-button. If its changing the theme background color: use the themeProvider. If its using a color different from the theme, the angular-material@1.1.0-RC5 version has md-colors directive.
Aleksandar B.
@aleksandar-b
Jun 04 2016 21:16
@ShadowManu I used theme provider, it doesn't change the background- just a color. I just used md-raisedand it works but changes color to black and add a whiteframe, and I don't won't that. md-colorsseems interesting but link doesn't work.
Manuel Pacheco
@ShadowManu
Jun 04 2016 21:18
didn't notice gitter transformed it to link (it was because of the 'at' symbol). If you want a link, take this, and this ;)
Aleksandar B.
@aleksandar-b
Jun 04 2016 21:20
@ShadowManu tnx
Aleksandar B.
@aleksandar-b
Jun 04 2016 21:51
@ShadowManu md-colors doesn't work at all
I am using 1.5.5
although i have some errors in console
Manuel Pacheco
@ShadowManu
Jun 04 2016 21:59
check your angular material version, which at least should be angular material 1.1.0-RC4.
Aleksandar B.
@aleksandar-b
Jun 04 2016 22:05
@ShadowManu it works, tnx! I am getting the same error again but everything is ok... Do you know anything about this eror https://docs.angularjs.org/error/$injector/unpr?p0=falseFilterProvider%20%3C-
Manuel Pacheco
@ShadowManu
Jun 04 2016 22:13
do you have a binding somewhere saying {{ somethng | false }} ?
Aleksandar B.
@aleksandar-b
Jun 04 2016 22:13
probably, i used snippets
Manuel Pacheco
@ShadowManu
Jun 04 2016 22:14
seems like someplace there's a false filter, and angular is not finding that filter provider.
do some ctrl+f search on | false. Good chance on finding something
Aleksandar B.
@aleksandar-b
Jun 04 2016 22:15
it is good now! :D
This message was deleted
@ShadowManu
This message was deleted