Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 31 2019 19:00
    tfaron commented #5133
  • Jan 31 2019 07:28
    cnishina closed #5135
  • Jan 31 2019 07:28
    cnishina commented #5135
  • Jan 30 2019 16:23
    ThabisoGithub closed #5136
  • Jan 30 2019 16:23
    ThabisoGithub edited #5136
  • Jan 30 2019 16:23
    ThabisoGithub edited #5136
  • Jan 30 2019 16:21
    ThabisoGithub opened #5136
  • Jan 30 2019 16:18
    IgorSasovets commented #4177
  • Jan 30 2019 15:05
    andrewchan-clover commented #4177
  • Jan 30 2019 13:43
    IgorSasovets commented #5135
  • Jan 30 2019 12:37
    EnzDev edited #5125
  • Jan 30 2019 11:47
    akshaymondal opened #5135
  • Jan 29 2019 14:33
    uinest commented #4822
  • Jan 28 2019 21:38
    cnishina commented #5132
  • Jan 28 2019 21:37
    cnishina commented #5134
  • Jan 28 2019 21:37
    cnishina closed #5134
  • Jan 28 2019 21:36

    cnishina on selenium4

    chore(release): bumpb version t… (compare)

  • Jan 28 2019 11:30
    think4ideas opened #5134
  • Jan 28 2019 11:01
    toniedzwiedz commented #2735
  • Jan 28 2019 09:42
    azorrozua commented #4786
jedwantstocode
@jedwantstocode
hi @Harsha509 , Im sorry, to encrypt I still have the push my code with my actual username and password?
Sri Harsha
@harsha509
hi @jedwantstocode, No Need to, you can first encrypt credentials in your local machine and provide pass the encrypted passphrase and secret-key in your scripts. Which you can decrypt in your scripts where ever required
jedwantstocode
@jedwantstocode
with the encrypted string, I can use that in place of the password in my normal json file where I usually store my password?
@Harsha509
Sri Harsha
@harsha509
Yes, you can use encrypted string and decrypt when you want to use original password
Aasim Anwar
@aasimali
image.png
image.png

Dear All,

Can someone check my code and tell me, please, why isSelected returning 'false'?

it("Filter Test", function(){
browser.get("https://www.osianama.com/indian-asian-antiquities-arts/armour-helmets");
let artwork = element(by.xpath("//div[@class='c-btn form-control'][span[text()='Artwork Title']]")).click();
browser.sleep(3000);

let checkbox = element(by.xpath("//label[text()='Akoda-Nari Kabuto (2)']"));
checkbox.click();
expect(checkbox.isSelected()).toBe(true);

    }); // end of it
jedwantstocode
@jedwantstocode
@Harsha509 will they be able to decrypt my password, using the same tool, since they will see it once I upload in git?
Sri Harsha
@harsha509
Yes then can, if they only know the secret code used for encryption
barret-p
@barret-p
Hello, what is the purpose of this line? https://github.com/angular/protractor/blob/cc501f71bc1f995a83c1041e1aa489ea0f105679/lib/launcher.ts#L210 What is the purpose of forking only when totalTasks > 1? In my case, I would like to fork even when running only a single spec file. The output format of the logs is different whether forkProcess is true or not. I would like it have consistent output format regardless of tests or suites run.
Star Yznaga
@wyznaga
Is there support existing or planned for running Protractor specs/parts of specs only for components that actually changed in the current commit, sort of like when using the Jest CLI with --changedSince or --onlyChanged?
Lorenzo Urbini
@siteriaitaliana
i'm building a docker image but after migrating to protractor@6.0.0 I've started to get:
E/launcher - Error: WebDriverError: unknown error: Chrome failed to start: exited abnormally
(unknown error: DevToolsActivePort file doesn't exist)
any idea of the reason? also why is 6.0.0 not marked as stable yet?
nbuso
@nbuso
Hi everyone, I'm in a strange situation where protractor seem not updating the update-config.json files. What's happening is my version of Chrome is newer and in chrome-response.xml there are newer versions of chromedriver, but update-config.json is poiting to an older version. Why webdriver-manager is no updating update-config.json? Below the tipical error running ng e2e:
[13:54:05] I/config_source - curl -o/home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/protractor/node_modules/webdriver-manager/selenium/chrome-response.xml https://chromedriver.storage.googleapis.com/
ℹ 「wdm」: Compiled successfully.
[13:54:05] I/update - chromedriver: file exists /home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/protractor/node_modules/webdriver-manager/selenium/chromedriver_74.0.3729.6.zip
[13:54:05] I/update - chromedriver: unzipping chromedriver_74.0.3729.6.zip
[13:54:05] I/update - chromedriver: setting permissions to 0755 for /home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/protractor/node_modules/webdriver-manager/selenium/chromedriver_74.0.3729.6
[13:54:05] I/update - chromedriver: chromedriver_74.0.3729.6 up to date
[13:54:06] I/launcher - Running 1 instances of WebDriver
[13:54:06] I/direct - Using ChromeDriver directly...
[13:54:06] E/launcher - session not created: This version of ChromeDriver only supports Chrome version 74
  (Driver info: chromedriver=74.0.3729.6 (255758eccf3d244491b8a1317aa76e1ce10d57e9-refs/branch-heads/3729@{#29}),platform=Linux 5.2.7-200.fc30.x86_64 x86_64)
[13:54:06] E/launcher - SessionNotCreatedError: session not created: This version of ChromeDriver only supports Chrome version 74
  (Driver info: chromedriver=74.0.3729.6 (255758eccf3d244491b8a1317aa76e1ce10d57e9-refs/branch-heads/3729@{#29}),platform=Linux 5.2.7-200.fc30.x86_64 x86_64)
    at Object.checkLegacyResponse (/home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/selenium-webdriver/lib/error.js:546:15)
    at parseHttpResponse (/home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/selenium-webdriver/lib/http.js:509:13)
    at doSend.then.response (/home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/selenium-webdriver/lib/http.js:441:30)
    at process._tickCallback (internal/process/next_tick.js:68:7)
From: Task: WebDriver.createSession()
    at Function.createSession (/home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/selenium-webdriver/lib/webdriver.js:769:24)
    at Function.createSession (/home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/selenium-webdriver/chrome.js:761:15)
    at Direct.getNewDriver (/home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/protractor/built/driverProviders/direct.js:77:33)
    at Runner.createBrowser (/home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/protractor/built/runner.js:195:43)
    at q.then.then (/home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/protractor/built/runner.js:339:29)
    at _fulfilled (/home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/q/q.js:834:54)
    at /home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/q/q.js:863:30
    at Promise.promise.promiseDispatch (/home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/q/q.js:796:13)
    at /home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/q/q.js:556:49
    at runSingle (/home/nbuso/projects/ebeye-local/src/ebinocle-webjs/node_modules/q/q.js:137:13)
[13:54:06] E/launcher - Process exited with error code 199
nbuso
@nbuso
chromedriver is available also for version 77, but protractor stick with 74! any idea?
Tedi Roca
@tedi.roca_gitlab
@nbuso upgrading webdriver-manager manually should allow you to use the latest chromedriver
nbuso
@nbuso
@tedi.roca_gitlab no if run webdriver-manager update it keep dowloading version 74
Tedi Roca
@tedi.roca_gitlab
running this command will update chromedriver, but not the wedriver-manager itself
there was a bug with the webdriver-manager not including the latest version of the chromedriver
running npm install -g webdriver-manager@lates and then wedriver-manager update should fix it
nbuso
@nbuso
I'm version on 5.4.2 that is the latest if I'm not wrong
Tedi Roca
@tedi.roca_gitlab
protractor installs webdriver-manager as dependency, and in that case the webdriver-manager that is installed does not allow installing the lastest chromedriver
the webdriver-manager itself can be installed and updated manually to get the latest version
nbuso
@nbuso
alright, I will try and this mean I need to change my CI/CD pipeline... let's see
Tedi Roca
@tedi.roca_gitlab
yep - not ideal, but it seems this is the only solution until the dependency is updated
here you have more info: angular/webdriver-manager#404
nbuso
@nbuso
uhm! how do you make protractor pointing to the global installed webdriver in standalone mode? do I need to set the chromedriver and geckodriver path manually?
Tedi
@tediroca
in my case protractor directly uses the globally installed version, but if this does not work you can always navigate to the node_modules directory where the webdriver-manager dependency was installed when installing protractor and update that local version
nbuso
@nbuso
yes I updated the local version to test for now, the global version was not picked
nbuso
@nbuso
@tediroca thanks for pointing out the ticket
Pedro Hyvo
@pedrohyvo
Hey guys, I'm facing with the following issue: [09:52:05] E/launcher - session not created: This version of ChromeDriver only supports Chrome version 74 (Driver info: chromedriver=74.0.3729.6 (255758eccf3d244491b8a1317aa76e1ce10d57e9-refs/branch-heads/3729@{#29}),platform=Windows NT 10.0.18362 x86_64) [09:52:05] E/launcher - SessionNotCreatedError: session not created: This version of ChromeDriver only supports Chrome version 74 (Driver info: chromedriver=74.0.3729.6 (255758eccf3d244491b8a1317aa76e1ce10d57e9-refs/branch-heads/3729@{#29}),platform=Windows NT 10.0.18362 x86_64)
Does anyone here has any thoughts?
Tedi
@tediroca
Hi @pedrohyvo . Latest versions of Chrome are not supported through the chromedriver versions installed via the webdriver-manager version that Protractor 5.4 installs. There is more info and a workaround in angular/webdriver-manager#404
Pedro Hyvo
@pedrohyvo
@tediroca thanks
Tedi
@tediroca
you are welcome!
Julian Didier
@theredfish
Hello o/
I'm trying to undestand why I can't use the webDriverProxy with the http protocol and seleniumAddress with the https one? Is there someone who know it works by any chance? I'm getting an EPROTO error.
Julian Didier
@theredfish
how it works *
abhijeetman235
@abhijeetman235

How to execute feature files in sequence in cucumber for visual studio code,
Eg- if I am having two feature files i.e customerconf.feature & usercreation.feature and I want to execute one after other
I have tried the below in my config file
specs: ['..features/customerconf.feature','..features/usercreation.feature'],

Please help

I have tried this but
image.png
But non of tags executed got following reponse
image.png
James Scharett
@jscharett
anyone know how to use resolveJsonModule : true with protractor e2e tests?
KiT
@KiT-Maverik

Hey guys!
In Chrome 76 they disabled 'disable-infobars' flag.
I found and replacement for this,

https://cloud.google.com/docs/chrome-enterprise/policies/?policy=CommandLineFlagSecurityWarningsEnabled

...but can't get how can I pass this in chrome args. Can anybody advise?

Yehuda Miller
@pittgoose
@KiT-Maverik looks like your answer is already on stack overflow. https://stackoverflow.com/a/57304986/2907654
Jon Wallsten
@JonWallsten
Hi! Is it possible to use different args for each instance of Chrome when running with shardTestFiles: true? I need to set the debug port to a specific value for each instance so I can access DevTools protocol during our tests.
Jon Wallsten
@JonWallsten
Has anyone ever had issues with shardTestFiles: true causing "No specs found" error? It only happens in our CI where we run Jenkins on RedHat machines. Locally on Windows it has never happened.
Jon Wallsten
@JonWallsten
Is it possible to enable more debug-info to see why I can't find any specs?
jedwantstocode
@jedwantstocode
has anyone encountered this on jenkins when trying to run protractor tests?
[06:19:21] I/launcher - Running 1 instances of WebDriver
[06:19:21] I/local - Starting selenium standalone server...
[06:19:22] I/local - Selenium standalone server started at http://1XX.30.31.XXX:XXXXX/wd/hub
[06:19:23] E/launcher - unknown error: Chrome failed to start: exited abnormally
(unknown error: DevToolsActivePort file doesn't exist)
I've already tried so many fixes from net and my capabilities look like this now