Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Aug 11 04:15
    jasonm23 commented #725
  • Aug 10 22:25
    mattmc3 commented #725
  • Aug 05 04:14
    jasonm23 commented #725
  • Aug 05 03:02
    jasonm23 commented #725
  • Aug 05 02:50
    mattmc3 commented #725
  • Aug 05 02:39
    mattmc3 commented #725
  • Aug 05 02:38
    jasonm23 commented #725
  • Aug 05 02:37
    mattmc3 commented #725
  • Aug 05 02:32
    jasonm23 commented #725
  • Aug 05 02:13
    jasonm23 commented #725
  • Aug 05 02:09
    mattmc3 commented #725
  • Aug 02 01:29
    singh-narender commented #736
  • Aug 02 01:27
    singh-narender commented #737
  • Aug 01 05:25
    vladdoster opened #740
  • Jul 28 22:04
    dylan-chong commented #717
  • Jul 05 01:03
    bencoullie commented #655
  • Jun 30 15:49
    voltechs commented #725
  • Jun 29 03:54
    0xdevalias commented #673
  • Jun 28 03:01
    bluebambu commented #721
  • Jun 27 10:15
    marlonrichert commented #725
Tim
@TCastelein
Can anyone help?
DC*
@desyncr
@TCastelein IIRC the debian package leaves it at /usr/share/zsh-antigen
I'll check that out now
Tim
@TCastelein
Yup there it is
Weird that my locate wouldnt find it
th
x
DC*
@desyncr
:+1: Cool have fun with it! :sparkles:
If you find any issue or have any trouble using it let us know!
BTW I was testing on debian 8 and it ships with antigen version 1 (we're currently 2.2.3)
So beware the documentation is based on latest version, so it may differ greatly
Chang
@chhuang
Does anyone know why this doesn't work: antigen bundle zsh-users/zsh-autosuggestions?
I have to do this instead: source /usr/local/share/zsh-autosuggestions/zsh-autosuggestions.zsh
MindFocus
@mindfocus
antigen apply cannot save settings to .zshrc
i dont know how to fix this
somebody can help me?
DC*
@desyncr
@mindfocus Antigen doesn't automatically modifies .zshrc, if you want to persist your bundles your need to modify it yourself.
See the examples on the wiki page, they're quite helpful to get you started!
cduong13
@chrisduong
Hi guys, how would we debug how the plugin is loaded
I run antigen bundle aws
then antigen apply
I had set set -x to turn on debug
but I cannot use aws shell completion
hadn’t found any error
DC*
@desyncr
@chrisduong Currently there isn't any debug information really helpful for this, but you can take a look at ~/.antigen/debug.log
cduong13
@chrisduong
Thanks @desyncr, had able to produce the debug log
DC*
@desyncr
Great! If you need any help just ping me
cduong13
@chrisduong
It was compinit problem between omz and zsh-completion
DC*
@desyncr
oh, yeah, compinit can be messed up if using omz and other frameworks interchangably
cduong13
@chrisduong
I had to run ‘compinit’ again in my zshrc so that aws completion can work
DC*
@desyncr
antigen reset should also work to clear up compinits
cduong13
@chrisduong
I would try it. Thanks
chewblacka
@chewblacka
Hi Ive just installed antigen and it's working well, except everytime I make a change to .zshrc (even a trivial one) I get the errof "Antigen: Must provide a bundle url or name." on startup
DC*
@desyncr
Can you share your .zshrc file?
It seems it's an error with how antigen bundle is used.
You need to pass it a plugin/bundle name such as antigen bundle zsh-users/zsh-autosuggestions
chewblacka
@chewblacka
ok many thanks! do I just paste my .zshrc into here?
DC*
@desyncr
Yeah, be sure to use backticks to format to code
like this
Or use gist.github.com
chewblacka
@chewblacka

source $HOME/antigen/antigen.zsh

`# Load the oh-my-zsh's library
antigen use oh-my-zsh

antigen bundle <<EOBUNDLES

# Bundles from the default repo (robbyrussell's oh-my-zsh)
git

# Syntax highlighting bundle.
zsh-users/zsh-syntax-highlighting

# Fish-like auto suggestions
zsh-users/zsh-autosuggestions

# Extra zsh completions
zsh-users/zsh-completions

EOBUNDLES

Load the theme

antigen theme robbyrussell
antigen apply`

DC*
@desyncr
It must be antigen bundles <<EOBUNDLES
bundles instead of bundle
chewblacka
@chewblacka
doh!
Many thanks! Much appreciated!
DC*
@desyncr
haha, it's tricky
Sure, no problem! :) Happy to help!
chewblacka
@chewblacka
typos are the tricky to spot! Many thanks - it worked a charm!
chewblacka
@chewblacka
I'm getting a strange error - I can't seem to load bundles from the command line any more. They work fine in my .zshrc, and themes are working, but when I attempt to load bundles I get e.g. "Installing github.com/lein... Error! Activate logging and try again."
chewblacka
@chewblacka
ok I've enabled logging and it seems to be an issue finding the correct git repository. E.g. when I try to load the bundle fasd I get the error: "fatal: repository 'https://github.com/fasd.git/' not found"
chewblacka
@chewblacka
ok managed to fix the problem thanks to the logging!