Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    john
    @clverhack
    期待那个 binlog 同步功能呢
    htyoung
    @htyoung
    apache doris发布周期太长了,0.15到现在都还没有发布
    King0513
    @King0513
    搞了这么多年还没到1.0,影响用户信心啊
    htyoung
    @htyoung
    确实有点,毕竟还有个竞争对手,网上一搜技术方案之类的,全是另外一个
    wanghaininggg
    @wanghaininggg
    @songzhifei arse json data for JsonDoc failed. code = 2, error-info:The document root must not be followed by other values.. doris版本是0.14 请问这个问题解决了吗
    zhuang.tang
    @zt317
    @S59592 请问在 AppleM1 上编译成功了吗?
    ggavin
    @ggavin
    我这边装了odbc 准备连5.7.17的MySQL,建完表be节点就查询数据就直接be节点崩了。。有遇到这样情况吗?
    我看了下coredump文件,没看出啥问题

    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/lib64/libthread_db.so.1".
    Core was generated by `/home/BE/lib/palo_be'.
    Program terminated with signal 11, Segmentation fault.

    #0 __strcmp_sse42 () at ../sysdeps/x86_64/multiarch/strcmp-sse42.S:164

    164 movdqu (%rdi), %xmm1
    (gdb)
    (gdb)
    (gdb)
    (gdb) \q
    Undefined command: "". Try "help".
    (gdb) quit

    James601232
    @James601232
    doris只能编译源码安装是吗?
    a.zhua
    @YunOooO22_twitter
    doris 目前支持mysql的所有函数么,例如any_value,目前看好像是不支持的
    G-Pride
    @G-Pride
    我们打算把项目从mysql迁到Doris,但是项目用到太多any_value函数,请问Doris有什么替换方案吗?
    James601232
    @James601232
    Error: flex version (2.5.37) must be greater than or equal to 2.6.0 我用docker镜像编译也报这个错误,是因为基础镜像太老了吗?
    haocean
    @Wahno
    image.png
    这个用Spark写doris的功能有人用过吗?
    Spark2.4不能写入
    DarvenDuan
    @DarvenDuan
    我看doris spark load 还是需要使用broker,感觉和broker load没有太大的区别啊,有大佬能麻烦解答一下吗?
    James601232
    @James601232
    怎么感觉这个开源项目没人支持
    caiconghui
    @caiconghui

    doris 目前支持mysql的所有函数么,例如any_value,目前看好像是不支持的

    目前没有,但目标是尽量兼容

    Error: flex version (2.5.37) must be greater than or equal to 2.6.0 我用docker镜像编译也报这个错误,是因为基础镜像太老了吗?

    可以看官网的提示,不同的版本需要不同的编译镜像,有些代码和第三方库都做了升级了

    Doris有需求的话可以到github的论坛上寻求帮助
    俗话曰(yuē)
    @swq-github
    image.png
    image.png
    fe的8030启动连接没有为,但是9030提示ERROR 2013 (HY000): Lost connection to MySQL server at 'reading initial communication packet', system error: 0
    日志没有报错,请问是什么原因
    qazjiangchuan
    @qazjiangchuan
    NoSuchMethodError: java.nio.ByteBuffer.limit
    xu20160924
    @xu20160924
    ODBC external table 是不支持建一个external doris的表吧?
    还是可以通过建一个MySQL的来兼容Doris表?
    luzhijing
    @luzhijing
    可以建成MySQL的外表
    Gitter使用得比较少,大家有问题可以在GitHub Discussion专区提问或者直接提交Issue
    Tgyhxy
    @Tgyhxy
    scala> mockDataDF1.write.format("doris"
    | ).option("doris.table.identifier", "xy.odbc_table3"
    | ).option("doris.fenodes", "192.168.0.152:8030"
    | ).option("user", "root"
    | ).option("password", "root123"
    | ).option("doris.write.fields","id"
    | ).save()
    java.lang.RuntimeException: org.apache.doris.spark.sql.DorisSourceProvider does not allow create table as select.
    at scala.sys.package$.error(package.scala:27)
    at org.apache.spark.sql.execution.datasources.DataSource.planForWriting(DataSource.scala:526)
    at org.apache.spark.sql.DataFrameWriter.saveToV1Source(DataFrameWriter.scala:281)
    at org.apache.spark.sql.DataFrameWriter.save(DataFrameWriter.scala:270)
    ... 57 elided
    大佬们好,我在Doris中建好表了,为什么一直写入写不进去呢?
    hilo
    @zhouhoo
    log4j漏洞问题,最近威胁很大,官方怎么还不发布修复版本呢
    1 reply
    log4j,我直接用2.15替换了2.14,fe报错跑不起来
    junweishiwo
    @junweishiwo
    各位好,有个问题请教大家:我最近在使用debezium结合routine load同步mysql数据到doris中,为了减少topic数量,我使用debezium将多个表的更新信息放到一个topic里了(json中有一个属性table,可以区分数据属于哪张表)。这种情况如何使用routine load将数据同步到doris中对应的表里呢,各位这样操作过吗?
    我看文档里说的都是一个topic一张表的情况
    CrazyDY
    @CrazyDY
    image.png
    2 replies
    请教一下各位大佬,在编译spark-connector的时候报这个错
    这个需要怎么解决呢
    CrazyDY
    @CrazyDY

    scala> mockDataDF1.write.format("doris"
    | ).option("doris.table.identifier", "xy.odbc_table3"
    | ).option("doris.fenodes", "192.168.0.152:8030"
    | ).option("user", "root"
    | ).option("password", "root123"
    | ).option("doris.write.fields","id"
    | ).save()
    java.lang.RuntimeException: org.apache.doris.spark.sql.DorisSourceProvider does not allow create table as select.
    at scala.sys.package$.error(package.scala:27)
    at org.apache.spark.sql.execution.datasources.DataSource.planForWriting(DataSource.scala:526)
    at org.apache.spark.sql.DataFrameWriter.saveToV1Source(DataFrameWriter.scala:281)
    at org.apache.spark.sql.DataFrameWriter.save(DataFrameWriter.scala:270)
    ... 57 elided
    大佬们好,我在Doris中建好表了,为什么一直写入写不进去呢?

    同问

    1 reply
    westgatepark
    @westgatepark
    有没有升级到doris 0.15 的大佬 稳定吗
    JiangJungle
    @JiangJungle
    doris缺少一个管理界面工具
    lin9long
    @lin9long
    doris 0.15 ,在已有的hadoop集群中,使用spark load,一直提示 configs/jobconfig.json文件不存在,观察etl执行过程这个文件是有生成的;yarn使用的是集群部署的客户端, 执行也一致报Error: JAVA_HOME is not set and could not be found.请问是什么原因导致的?
    1 reply
    panlijie
    @xiaoxiaopan118
    @JiangJungle 可以在ambari中管理,可以参考https://github.com/xiaoxiaopan118/Ambari-Doris-Service
    iMom0
    @imom0
    我有个疑惑,为什么官方提供了docker编译的镜像,不提供编译好的be和fe的镜像呢,是出于什么考虑
    sky
    @skymilong
    和楼上一样,自己编译很久
    luzhijing
    @luzhijing
    可以在palo.baidu.com 下载预编译好的palo发行版
    wanbaococ
    @winatox

    我有个疑惑,为什么官方提供了docker编译的镜像,不提供编译好的be和fe的镜像呢,是出于什么考虑

    因为编译和运行的环境指令集不同,我在自己的电脑上编译通过放到服务器上运行提示找不到指令,上网查了才知道两个的指令集不同,在服务器上再编译就通过了

    luzhijing
    @luzhijing
    Welcome to talk about some performance optimization tips of Apache Doris!
    luzhijing
    @luzhijing
    Click it and join the slack of Apache Doris Community!