These are chat archives for apparatus/fuge

3rd
Apr 2016
Timo Weiß
@timoweiss
Apr 03 2016 10:58
I'm unable to install fuge currently. it looks like simple-grep@0.0.2 has been unpublished?
https://github.com/apparatus/fuge-runner/blob/master/package.json#L29
Adrian Rossouw
@AdrianRossouw
Apr 03 2016 14:41
weird
try 0.0.1?
the github repo is gone too
Rocky Assad
@CodisRedding
Apr 03 2016 14:41
I added a PR to add the simple-grep code to a lib module for now if you want
sine it breaks fuge and huge-runner
no it’s gone from npm
I mean github
Adrian Rossouw
@AdrianRossouw
Apr 03 2016 14:42
yeah. if you make the PR , i will commit it
so fscking werird
Rocky Assad
@CodisRedding
Apr 03 2016 14:42
i did
yesterday
Adrian Rossouw
@AdrianRossouw
Apr 03 2016 14:43
there’s 2 competing patches
i think i will accept the other one, if that’s ok
Rocky Assad
@CodisRedding
Apr 03 2016 14:44
ah, no worries to me
Adrian Rossouw
@AdrianRossouw
Apr 03 2016 14:44
(only uses 0.0.1)
Rocky Assad
@CodisRedding
Apr 03 2016 14:44
sure
the code in simple-grep wasn’t that great, might want to review 1.0.0
also if you go with 1.0.0 it could possibly go away again considering the github repo is gone for it too (out of nowhere)
I wish there was an automatic deprecation warning when packages/versions are removed, before being del'd
in npm that is
Adrian Rossouw
@AdrianRossouw
Apr 03 2016 14:48
@channel 0.6.1 is released, should be installable again
ciao all .and thanks
Rocky Assad
@CodisRedding
Apr 03 2016 14:49
sweet
Timo Weiß
@timoweiss
Apr 03 2016 14:51
thanks!
Rocky Assad
@CodisRedding
Apr 03 2016 14:55
hmm, seems that ordinal@1.0.0 is missing as well now?
I’ll check
Rocky Assad
@CodisRedding
Apr 03 2016 15:11
actually no, it’s fine. I killed my fork cloned again, but I see ordinal 0.0.4 now instead of 1.0.0, so odd. anyway, all seems well
Dean McDonnell
@mcdonnelldean
Apr 03 2016 15:26
Yaaaaaaaaaaaa! 💅
Adrian Rossouw
@AdrianRossouw
Apr 03 2016 15:58
is that a pokemon emoji ?
Rocky Assad
@CodisRedding
Apr 03 2016 16:03
ha, pretty sure that’s a hand getting polished
Dean McDonnell
@mcdonnelldean
Apr 03 2016 16:04
Its my all in a days work emoji
Rocky Assad
@CodisRedding
Apr 03 2016 16:05
updtr is a neat little tool for updating outdated npm modules https://github.com/peerigon/updtr
Dean McDonnell
@mcdonnelldean
Apr 03 2016 16:05
An interesting repercussion of this was having to modify the nodezoo app to allow single running outside mesh so I could keep testing in isolation. Alls well that ends well
Adrian Rossouw
@AdrianRossouw
Apr 03 2016 17:44
i wonder what the likelihood of 2 dependencies being unpublished like that
about npm packages
Dean McDonnell
@mcdonnelldean
Apr 03 2016 18:25
@fourq pretty much how I view it
Rocky Assad
@CodisRedding
Apr 03 2016 18:25
:thumbsup:
Peter Elger
@pelger
Apr 03 2016 19:28
@fourq - nailed it!