Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Dean McDonnell
    @mcdonnelldean
    We are just moving bodies around to make this happen so give me. Week 😉
    RB
    @BhaskaranR
    i am not able to get fuge work with windows. looks like issue has been raised
    apparatus/fuge#81. Has any one tried it out with windows?
    Khánh Trần
    @rualatngua
    hi all, how can I use dotenv in a service?
    or should I use it?
    Dustin Deus
    @StarpTech
    Hey @all anybody who run into an issue with whitespaces in paths like "program files" on windows see apparatus/fuge#95
    Khánh Trần
    @rualatngua
    @StarpTech I think you should find a way to install NodeJS and NPM outside of C:\Program Files
    there is permission problem also
    Adrian Rossouw
    @AdrianRossouw
    @rualatngua you can specify env_file: in the docker compose config
    that will actually use dotenv to preload the config for you
    Khánh Trần
    @rualatngua
    thank @AdrianRossouw
    Stuart Fenton
    @grandmore
    Do you have any preferred method for debugging? I'm on OS X and have done some experiments with Webstorm, VSCode and node-debug but cannot find an ideal setup. What do you use to develop and debug with?
    chris-gpc
    @chris-gpc
    Is there anyway to change the font color selections when tailing a process? Every now and again I get black font on my default black background in my shell.
    Christian Rijke
    @crijke
    i cannot get 'fuge build' to run on a new system i generated when running "fuge build ./fuge", the error is "Cannot read property 'topology' of undefined". i found that 'system' should be generated by the "xeno" module, but it's undefined. what am i missing here? is this the correct way to run fuge build in the first place?
    Adrian Rossouw
    @AdrianRossouw
    you need to run fuge build fuge/system.yml
    or the direct path to the file
    Christian Rijke
    @crijke
    ah ok, thanks. but there is no system.yml.. i tried "fuge build fuge/compose-dev.yml" but then i get ‘no build script'
    Adrian Rossouw
    @AdrianRossouw
    that is right
    you will need to add a build script, i think
    check how it’s done in nodezoo
    Christian Rijke
    @crijke
    ah, this works. great, thanks! would probably be a good idea to include this in the system generator, or make it fall back to the default build command if it’s not defined
    but then i found this issue: apparatus/fuge#90 so there are plans to change this it seems?
    Drew Simmons
    @timsim00
    Any tips on swapping out the site folder for a boilerplate like React-Redux-Hot-Example? It's saying frontend is missing an execute statement.
    Khánh Trần
    @rualatngua
    @AdrianRossouw could you help me how to config fuge and seneca logging?
    Kevin Madhu
    @kevin-madhu
    i create a third service in the “template system” generated by fuge using the command “fuge generate service"
    I came across 2 issues:
    1) When I name the service user, it doesn’t come up on ps in the fuge shell. But that’s somthing to do with name I guess, but I dunno what.
    2) I allow the name suggested by fuge and then the service comes up when “start all” is run. But in the meanwhile an error gets thrown even though at the end the status of the third service is marked as started. Here’s the error: https://gist.github.com/kevin-madhu/0771062421b6e551ad2fee932c504477
    Dean McDonnell
    @mcdonnelldean
    @timsim00 Check out nodezoo, nodezoo-web is done in that style. Nodezoo-system is the fuge config for Nodezoo
    @kevin-madhu We have taken generators out. They are causing problems unrelated to fuge so we want to remove them and figure out the best way forward with such a feature
    Timo Weiß
    @timoweiss
    @kevin-madhu check apparatus/fuge#70 for the user service name thing
    Dean McDonnell
    @mcdonnelldean
    @timoweiss I also responded and added more context :thumbsup:
    Timo Weiß
    @timoweiss
    @mcdonnelldean muchas gracias :smile:
    Kevin Madhu
    @kevin-madhu
    How do I check if a a function in a microservice gets invoked as a result of series of message passing?
    I’m using fuge, and the the logs, especially the message IN, OUT logs are not being printed.
    @timoweiss got it… :)
    Bernard Ojengwa
    @ojengwa
    This message was deleted
    fuge generate system as described by the docs does not work!!!
    Instead, this error is thrown [Error: could not parse github url: system]
    My understanding is that I have to specify the git repo (found it on online...)
    Dean McDonnell
    @mcdonnelldean
    @ojengwa Hey, so we took out the generation because it was broken. It is due to be replaced by something soon shortly, in the next month or so
    Bernard Ojengwa
    @ojengwa
    :(
    I am looking to integrate fuge as a critical part of our architecture... Anyway I can help?
    btw, what command(s) do I have to run to bootstrap the system?
    Dean McDonnell
    @mcdonnelldean
    I’d say having a look over the open issues for now would be the best way to help. There is work planned soon to simplify and make it easy to use.
    Define bootstrap? Right now there is no generation so hand crafted is the way. Take a look at nodezoo/nodezoo-system on github for a full fuge config done right
    Bernard Ojengwa
    @ojengwa
    yeah. That's I am currently depending on the nodezoo-system project for guidance... By bootstrap, I meant generating base project assete/configurations. Much like the way yeoman works.
    I will take a look at the issues.
    Dean McDonnell
    @mcdonnelldean
    Right now, we don’t have it. We tried it but found it didn’t work great. I suggest taking one of the nodezoo repos as a base and clearing it out to your liking
    Bernard Ojengwa
    @ojengwa
    :)
    Thanks, man