Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Juri Strumpflohner
    @juristr
    :)
    Juri Strumpflohner
    @juristr
    I think I have to use apparatus/service as URL. Now I don't get any error, but also nothing happens :)
    image.png
    parth-intel
    @parth-intel
    I am also facing issue as @juristr . What is the way to generate basic project template and run a simple Seneca service?
    Also, once we have project structure ready, what is the command to add new service?
    Leo Furze-Waddock
    @lfurzewaddock
    Having trouble starting ramanujan project with fuge in dev environment VM VirtualBox - HOST: Windows 10 Pro (Bash on Windows/WSL) / GUEST: Ubuntu 16.04. After all services start, all services begin to timeout and crash with errors like: "Error: seneca: Action name:mesh,plugin:define,role:seneca,seq:3,tag:undefined failed: [TIMEOUT]. " . However it starts ok running locally on the host Windows 10 Pro (Bash on Windows/WSL).
    Stanley Zheng
    @stanzheng

    hmm abandoned chat.

    Environment variables don't seem to be working how I expect with fuge but it doesn't seme like anyone is around?

    Stanley Zheng
    @stanzheng

    ok i think i was looking at it wrong

    fuge shell
    fuge info <process>

    shows only the env in the file but doing

    apply env

    I saw my env variables were being set. just some place in my code

    Stanley Zheng
    @stanzheng
    i found having the autogenerating ports enabled, it was overriding one of the ports in my config so I had to manually define ports but it was a gotcha
    Stanley Zheng
    @stanzheng

    Yeah theres a bunch of gotcha's I can't seem to figure out with using fuge in conjunction with seneca timing out a bunch

    1) https://github.com/senecajs/seneca-mesh
    2) https://github.com/senecajs/seneca-consul-registry

    If anyone is enlightened to have insight about special gotchas, I'm just gonna go with bash scripts :laughing:

    Vladimir Djukic
    @vforv
    There is some bug...
    sending SIGKILL to parent process: 4871
    sending SIGKILL to child process: 4881
    sending SIGKILL to parent process: 4871
    sending SIGKILL to child process: 4881
    sending SIGKILL to parent process: 4871
    sending SIGKILL to parent process: 4871
    John Cole
    @johnwebbcole
    Is there a way to pipe the output of one process through pino for formatting?
    Ilyes512
    @Ilyes512
    hey
    what does watch (watching a process) mean?
    it will not restart it when it dies? or ...?
    Ilyes512
    @Ilyes512
    oh I think I get it. It's actually a watcher and it will restart the node service when it sees file changes. Got it
    Felipe Barros Cruz
    @FelipeBarrosCruz
    Hello guys
    I did a 'pull request' to added a handler on exit command to execute a shell script command. I did a commit but the tests has failed
    And I don't know why
    The func does't have coverage
    Look at github page project
    apparatus/fuge#169
    apparatus/fuge-config#11
    davetennant17
    @davetennant17
    I'm trying to figure out how to use "build" in the fuge.yml file... when using "start xyz" (xyz is service name) it doesn't seem to kick off the build first. Is it meant to run the build script or am I using it wrong?
    I saw "build" referenced in this read me file: https://github.com/apparatus/fuge-config/blob/master/README.md
    adam-gpc
    @adam-gpc
    I can’t exeucte commands on fuge all of the sudden
    adam-gpc
    @adam-gpc
    Never mind, issue has been fixed
    Daniel Rodríguez Rivero
    @danielo515
    Hello
    I am looking for fuge docs but the link on the page just points to the readme
    Daniel Rodríguez Rivero
    @danielo515
    Dam, this room is as dead as the project
    Ravi Tuvar
    @ravituvar
    Hello all, I have my nodejs services and running through fuge.yml, everything is working, i just want to debug the code in VS Code, any idea how can i do that?
    Daniel Rodríguez Rivero
    @danielo515
    You need to activate the debug on the service and connect using the VSC debugger
    Khánh Trần
    @rualatngua
    @danielo515 I can't start two debug processes
    because fuge can open new port for inspector
    is there any config for inspector port?
    Daniel Rodríguez Rivero
    @danielo515
    I ended with a smart solution to this problem, but I can't remember where I stored it
    I'll look for it
    Tyler Waters
    @tswaters
    Getting a lot of npm audit warnings from this project. Any chance the maintainers could update their dependencies and publish a new version? fuge-runner is referencing lodash 3, chokidar@1.2 - there are 5 vulns here that can't be fixed automagically by npm. chokidar-child looks like it's referencing 1.2 as well... : (