Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    jshinn6788
    @jshinn6788
    Hey Guys,
    I can't seem to use "sendKeys"for my desktop application. I'm using the winapp driver with appium. The error I get is: Unable to locate search parameters. Any thoughts on this anyone?
    Mike Salvia
    @mikesalvia
    Hey all. I know this is probably bad practice but I wanted to post an issue here... The reason is because I don't know if it is in UIAutomator2, Appium, or Android iteself, either way it is a pretty bad bug IMHO. However, it also could be a "do this". appium/appium#13045
    Skaviyarasan
    @Skaviyarasan
    I got stuck up with one more issue when I try to launch the iOS app from Appium Desktop. The Observation is, app gets installed but the Webdriveragentrunner is getting uninstalled when its trying launch the app. Below is the attached Appium logs
    ] Got an unexpected response: {"errno":"ECONNREFUSED","code":"ECONNREFUSED","syscall":"connect","address":"127.0.0.1","port":8100}
    [XCUITest] WDA is not listening at 'http://localhost:8100/'
    [XCUITest] WDA is currently not running. There is nothing to cache
    [XCUITest] Trying to start WebDriverAgent 1 times with 10000ms interval
    [XCUITest] These values can be customized by changing wdaStartupRetries/wdaStartupRetryInterval capabilities
    [BaseDriver] Event 'wdaStartAttempted' logged at 1565204858155 (20:07:38 GMT+0100 (BST))
    [XCUITest] Launching WebDriverAgent on the device
    [XCUITest] Carthage found: '/usr/local/bin/carthage'
    [XCUITest] Killing running processes 'xcodebuild.e6209b317ed6cb5aa3fa8f1e0fc7bf0e2ff06ada, iproxy 8100' for the device e6209b317ed6cb5aa3fa8f1e0fc7bf0e2ff06ada...
    [XCUITest] 'pgrep -nif xcodebuild.
    e6209b317ed6cb5aa3fa8f1e0fc7bf0e2ff06ada' didn't detect any matching processes. Return code: 1
    [XCUITest] 'pgrep -nif iproxy 8100' didn't detect any matching processes. Return code: 1
    [XCUITest] Starting iproxy to forward traffic from local port 8100 to device port 8100 over USB for the device e6209b317ed6cb5aa3fa8f1e0fc7bf0e2ff06ada
    [XCUITest] iProxy is running and is listening on port #8100
    [XCUITest] Generating xcode config file for orgId 'M7QX4W45W5' and signingId 'iPhone Developer'
    [XCUITest] Writing xcode config file to /var/folders/j3/pssq14hs0wg2_x638bdml04c0000gp/T/201977-38779-1tlfh0u.tv9h/appium-temp.xcconfig
    [XCUITest] Cannot parse major and minor version numbers from platformVersion "10". Will build for the default platform instead
    [XCUITest] Using Xcode configuration file: '/var/folders/j3/pssq14hs0wg2_x638bdml04c0000gp/T/201977-38779-1tlfh0u.tv9h/appium-temp.xcconfig'
    [XCUITest] Beginning test with command 'xcodebuild test-without-building -project /Applications/Appium.app/Contents/Resources/app/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/WebDriverAgent.xcodeproj -scheme WebDriverAgentRunner -derivedDataPath /Users/jishnubhadra/Library/Developer/Xcode/DerivedData/WebDriverAgent-dikkwtrisltbeobjmfvpthwwekvs -destination id=e6209b317ed6cb5aa3fa8f1e0fc7bf0e2ff06ada -xcconfig /var/folders/j3/pssq14hs0wg2_x638bdml04c0000gp/T/201977-38779-1tlfh0u.tv9h/appium-temp.xcconfig GCC_TREAT_WARNINGS_AS_ERRORS=0 COMPILER_INDEX_STORE_ENABLE=NO' in directory '/Applications/Appium.app/Contents/Resources/app/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent'
    [XCUITest] Output from xcodebuild will only be logged if any errors are present there. To change this, use 'showXcodeLog' desired capability
    [XCUITest] Waiting up to 60000ms for WebDriverAgent to start
    [WD Proxy] Matched '/status' to command name 'getStatus'
    [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
    [WD Proxy] Got an unexpected response: {"errno":"ECONNRESET","code":"ECONNRESET","syscall":"read"}
    [WD Proxy] Matched '/status' to command name 'getStatus'
    [WD Proxy] Proxying [GET /status] to [GET http://localhost:8100/status] with no body
    [WD Proxy] Got an unexpected response: {"errno":"ECONNRESET","code":"ECONNRESET","syscall":"read"}
    [XCUITest] Log file for xcodebuild test: /Users/jishnubhadra/Library/Developer/Xcode/DerivedData/WebDriverAgent-dikkwtrisltbeobjmfvpthwwekvs/Logs/Test/Test-WebDriverAgentRunner-2019.08.07_20-07-41-+0100.xcresult/1_Test/Diagnostics/WebDriverAgentRunner-3DC5AF52-E27A-43BC-9C27-70333138BC24/WebDriverAgentRunner-50B2467C-6CB8-4B08-B68A-C6BD63BA1A04/Session-WebDriverAgentRunner-2019-08-07_200741-DuFz7j.log
    [Xcode] 2019-08-07 20:07:41.282 xcodebuild[43501:664102] Error Domain=NSCocoaErrorDomain Code=260 "The file “WebDriverAgentRunner-Runner.app” couldn’t be opened because there is no such file." UserInfo={NSFilePath=/Users/jishnubhadra/Library/Developer/Xcode/DerivedData/WebDriverAgent-dikkwtrisltbeobjmfvpthwwekvs/Build/Products/Debug-iphoneos/WebDriverAgentRunner-Runner.app, NSUnderlyingError=0x7fb8fd86ec40 {Error Domain=NSPOSIXErrorDomain Code=2 "No such file or directory"}}
    [Xcode]
    [Xcode]
    [Xcode] Testing failed:
    [Xcode]
    [Xcode] WebDriver
    srisudhi
    @srisudhi
    Hi
    How to check the radio button is visible or not by appium?
    PavlikVasil
    @PavlikVasil
    Hello
    I ran into problem: Trying to proxy a session command without session id
    Tried different versions of Appium and emulators
    Creating new AndroidUiautomator2Driver (v1.19.0) session
    [Appium] Capabilities:
    [Appium] adbPort: 5037
    [Appium] automationName: UIAutomator2
    [Appium] browserName: Browser
    [Appium] deviceName: Pixel2
    [Appium] language: en
    [Appium] locale: US
    [Appium] platformName: Android
    [Appium] platformVersion: 7.1.1
    [Appium] skipServerInstallation: true
    [Appium] systemPort: 8201
    [Appium] newCommandTimeout: 0
    [Appium] connectHardwareKeyboard: true
    [BaseDriver] Creating session with MJSONWP desired capabilities: {"adbPort":"5037","automati...
    [BaseDriver] Capability 'systemPort' changed from string ('8201') to integer (8201). This may cause unexpected behavior
    [BaseDriver] Capability 'adbPort' changed from string ('5037') to integer (5037). This may cause unexpected behavior
    [BaseDriver] The following capabilities were provided, but are not recognized by appium: skipServerInstallation, connectHardwareKeyboard.
    [BaseDriver] Session created with session id: 8ced98cc-21e3-46af-b8d4-80f4269d1c57
    [UiAutomator2] We're going to run a Chrome-based session
    [UiAutomator2] Chrome-type package and activity are com.android.browser and com.android.browser.BrowserActivity
    [AndroidDriver] Java version is: 1.8.0_201
    [AndroidDriver] Retrieving device list
    [ADB] Trying to find a connected android device
    [ADB] Getting connected devices...
    [ADB] 1 device(s) connected
    [AndroidDriver] Looking for a device with Android '7.1.1'
    [ADB] Setting device id to emulator-5554
    [ADB] Getting device platform version
    [ADB] Running 'C:\Users\HP2\android-sdk-windows\platform-tools\adb.exe -P 5037 -s emulator-5554 shell getprop ro.build.version.release'
    [ADB] Current device property 'ro.build.version.release': 7.1.1
    [AndroidDriver] Using device: emulator-5554
    [ADB] Setting device id to emulator-5554
    [ADB] Running 'C:\Users\HP2\android-sdk-windows\platform-tools\adb.exe -P 5037 -s emulator-5554 shell getprop ro.build.version.sdk'
    [ADB] Current device property 'ro.build.version.sdk': 25
    [ADB] Device API level: 25
    [AndroidDriver] No app sent in, not parsing package/activity
    [ADB] Getting device platform version
    [ADB] Running 'C:\Users\HP2\android-sdk-windows\platform-tools\adb.exe -P 5037 -s emulator-5554 shell getprop ro.build.version.release'
    [ADB] Current device property 'ro.build.version.release': 7.1.1
    [ADB] Running 'C:\Users\HP2\android-sdk-windows\platform-tools\adb.exe -P 5037 -s emulator-5554 shell wm size'
    [ADB] Running 'C:\Users\HP2\android-sdk-windows\platform-tools\adb.exe -P 5037 -s emulator-5554 shell wm density'
    [ADB] Running 'C:\Users\HP2\android-sdk-windows\platform-tools\adb.exe -P 5037 -s emulator-5554 shell getprop ro.product.model'
    [ADB] Current device property 'ro.product.model': Android SDK built for x86
    [ADB] Running 'C:\Users\HP2\android-sdk-windows\platform-tools\adb.exe -P 5037 -s emulator-5554 shell getprop ro.product.manufacturer'
    [ADB] Current device property 'ro.product.manufacturer': Google
    [ADB] Device API level: 25
    [ADB] Running 'C:\Users\HP2\android-sdk-windows\platform-tools\adb.exe -P 5037 -s emulator-5554 shell am force-stop io.appium.uiautomator2.server'
    [ADB] Checking app cert for C:\Program Files (x86)\Appium\resources\app\node_modules\appium\node_modules\appium-uiautomator2-server\apks\appium-uiautomator2-server-v1.18.0.apk
    [ADB] Starting 'C:\Users\HP2\android-sdk-windows\build-tools\29.0.1\apksigner.bat' with args '["verify","--print-certs","C:\Program Files (x86)\Appium\resources\app\node_modules\appium\node_modules\appium-uiautomator2-server\apks\appium-uiautomator2-server-v1.18.0.apk"]'
    [ADB] apksigner stdout: Signer #1 certificate DN: EMAILADDRESS=android@android.com, CN=Android, OU=Android, O=Android, L=Mountain View, ST=California, C=US
    [ADB] Signer #1 certificate SHA-256 digest: a40da80a59d170caa950cf15c18c454d47a39b26989d8b640ecd745ba71bf5dc
    [ADB] Signer #1 certificate SHA-1 digest: 61ed377e85d386a8dfee6b864bd85b0bfaa5af81
    [ADB] Signer #1 certificate MD5 digest: e89b158e4bcf988ebd09eb83f5378e87
    [ADB] WARNING: META-INF/INDEX.LIST not protected by signature. Unauthorized modifications to this JAR
    Roc Itxart Alba
    @ritxart
    Hello All!
    did someone tried to open appium with iOS 13?
    I'm trying to run the inspector, simulator and app are launched
    but the view never loads
    Roc Itxart Alba
    @ritxart
    did someone manage to run it?
    Salhi Aissam
    @sam-viz
    Hi,
    I've run into exactly the same problem using appium with iOS 13.
    App launches but inspector doesn't see anything in the view hierarchy of the app
    Roc Itxart Alba
    @ritxart
    Also I've managed to run the test
    but doesn't find some of the elements
    PavlikVasil
    @PavlikVasil
    [Chromedriver] Cannot retrieve version number from 'chromedriver.exe' Chromedriver binary. Make sure it returns a valid version string in response to '--version' command line argument. Cannot parse the version string
    Anybody meet with it?
    anuragmp
    @anuragmp
    Hi I tried using Appium with desktop application and appium is not updating the main window after splash screen goes off. I want want inspect the elements after splash screen has gone.
    anuragmp
    @anuragmp
    I am trying to automate a desktop application. It has html elements inside wpf container. I tried using inspect.exe and it is not able to inspect the element inside the html wpf panel. Could some let me know if its automate able using appium?
    Preeti Sharma
    @preeti13456
    This message was deleted
    Razvan Creanga
    @razvanu_twitter
    I managed to run iOS tests after installing appium beta 'npm install -g appium@beta'
    iOS13
    some tests are failing though, I'm still investigating the cause
    Roc Itxart Alba
    @ritxart
    @razvanu_twitter I did same
    But 90% of my test cases fail traying to click on a button
    so they never log in
    Razvan Creanga
    @razvanu_twitter
    I have similar issues
    also switching to from native view to webview doesn't seem to be working
    selenium.common.exceptions.WebDriverException: Message: An unknown server-side error occurred while processing the command. Original error: No targets found, unable to communicate with device
    this is the error I get
    seems like is switching to webview but I cannot inspect anything
    contexts = driver.contexts
        print(contexts)
        webview = driver.contexts[1]
        print('Current view ' + webview) # it prints WEBVIEW_66846.1
        driver.switch_to.context(webview) - here is failing
    this used to work for months, I'll try to debug it
    Roc Itxart Alba
    @ritxart
    So far then.. iOS 13 is not working
    Raz
    @raz__gitlab
    I don't even know what's the best thing to do: wait for a newer version of iOS version to be released (a new beta) or a new appium version. On my end it's okish, 30% of tests are failing and apart from the webview context switch all tests are fairly easy to fix.
    Wim Selles
    @wswebcreation

    @ritxart

    Appium doesn't officially support iOS 13 yet, meaning the current versions will not work 100%

    When iOS 13 will come out a new version will be released, but keep in mind it is open source, meaning it can take some time

    Níkolas Escobar
    @NikoEscobar

    Hey guys,

    [RemoteDebugger] Executing atom 'execute_script'
    [W3C (2d1b2b68)] Encountered internal error running command: Error: Unable to load Atom 'execute_script' from file 'C:\Program Files\Mobile Center Server\server\appium113\node_modules\appium-remote-debugger\build\atoms\execute_script.js'
    [W3C (2d1b2b68)] at getAtoms (C:\Program Files\Mobile Center Server\server\appium113\node_modules\appium-remote-debugger\lib\atoms.js:17:13)
    [W3C (2d1b2b68)] at <anonymous>

    Anyone had this error? I dont really know what to do =/

    Raz
    @raz__gitlab
    Thank you @wswebcreation, very useful. I think its a good approach, rely on ios12 tests until ios 13 gets fully supported by appium.
    Roc Itxart Alba
    @ritxart
    @wswebcreation Yes Yes I know! I was trying to get a first look to see if our app looked ok! But 90% of my TC are failing, we will do it from the functional side! Thanks anyway for the help! If we can help somehow for it let me know!
    Wim Selles
    @wswebcreation
    👍🏻
    PavlikVasil
    @PavlikVasil
    Finally I've launch Appium, but unfortunately, always get error "unable to locate element..." using any selectors, when activate Python script. Tap by coordinates works, then trouble not in configuration. Please help me.
    anuragmp
    @anuragmp
    Hi I tried using Appium with desktop application and Appium session is losing connection after the splash screen goes off. I want to inspect the elements after splash screen has gone.
    Raz
    @raz__gitlab
    iOS or Android?
    I had the same behaviour when the app wasn't build for the right architecture
    (on iOS)
    Deift
    @Deift
    Hello, I would like to to distribute the execution of X cucumber tests among 2 Android devices, I have tried many times but... any idea that could help?
    Roc Itxart Alba
    @ritxart
    Selenium Grid?
    Deift
    @Deift
    Will that allow me to run tests on different devices? (not the same test on all devices)