Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Ghost
    @ghost~5ddff7a3d73408ce4fd26b22
    @davidtophat You're welcome David. I think the usual right-click is named ContextClick: https://static.javadoc.io/org.seleniumhq.selenium/selenium-api/2.50.1/org/openqa/selenium/interactions/ContextClickAction.html
    @davidtophat Yep it is, JS binding reference but ContextClick is supposed to be a right-click https://github.com/SeleniumHQ/selenium/blob/master/javascript/node/selenium-webdriver/lib/input.js#L878
    davidtophat
    @davidtophat
    https://selenium.dev/selenium/docs/api/java/org/openqa/selenium/Keys.html
    import org.openqa.selenium.Keys
    I am trying to import the above for pycharm but it doesn't recognize it
    nghiahuynht05
    @nghiahuynht05

    Hello,

    I need help,

    I test case open webview in app android.
    but show error https://paste.ofcode.org/7D5xakm3iK2CHA2bX9tKuJ

    someone has used appium webdriverIO. help me

    Ghost
    @ghost~5ddff7a3d73408ce4fd26b22
    @nghiahuynht05 check http://appium.io/docs/en/drivers/android-uiautomator2/#real-device-setup, and please don't use var in your code, use const (or let), and get rid of things like var self = this; you're shooting yourself in the foot
    zarashima
    @zarashima

    Hi all

    Is it possible to attach to the existing Appium session? My scenario is I want to re-use the same Appium session for mobile browser from a native app context, not want to create two separate drivers instance to handle this

    Ryan McIntyre
    @ryanoasis_gitlab

    Hey all. Having a hard time getting a React input component value to set and trigger an on change event, I can get the value just fine with getValue. It is set visually - as in the input has the value but as far as the form goes it is not 'set'. Methods tried: addValue, setValue and sendKeys.

    alternatives tried:
    https://github.com/facebook/react/issues/11488#issuecomment-470623779
    https://github.com/appium/appium/issues/9002#issuecomment-479032180
    https://github.com/facebook/react/issues/11488#issuecomment-347775628

      const input = await browser.$('input');
      await input.addValue(email); // doesn't trigger change event. workaround?
      await input.setValue(email); // doesn't trigger change event. workaround?
    
      browser.execute(() => {
        let input = document.querySelector('input');
        let lastValue = input.value;
        let event = new Event('change', { bubbles: true });
        event.simulated = true;
        let tracker = input._valueTracker;
        if (tracker) {
          tracker.setValue(lastValue);
        }
        input.dispatchEvent(event);
      });

    Any ideas here? :( Thanks

    Sven Murat
    @sven14_gitlab
    currently I'm having this issue when trying to switch context to webview: Request failed due to unknown error: An unknown server-side error occurred while processing the command. Original error: No Chromedriver found that can automate Chrome '78.0.3904'... but have installed latest chromedriver?
    can anyone help? I'm trying to inspect hybrid app in chrome
    Shawn Edge
    @Edge_Man_twitter
    @sven14_gitlab : run this when starting appium... "appium --allow-insecure chromedriver_autodownload"
    bobbyislam
    @bobbyislam
    any place I can find detailed instruction on how to set up a Mac for iOs / Appium / c# setup. I am very new into mobile testing world
    my goal is to start writing some c# tests which will be hooked to the Mac machine and eventually test using SauceLabs
    Shawn Edge
    @Edge_Man_twitter
    Rahul Jaisinghani
    @rahul-bs
    @sven14_gitlab pass 'recreateChromeDriverSessions' capability as true
    bobbyislam
    @bobbyislam
    @bobbyislam Thanks @Edge_Man_twitter
    walternolak
    @walternolak
    Hello! Does anyone have encountered this error while running tests: "Unable to remove port forward 'Error executing adbExec. Original error: ‘Command Android/sdk/platform-tools/adb -P 5037 -s 83e54f3051575844 forward --remove tcp\:8200' exited with code 1'; Stderr: 'error: listener 'tcp:8200' not found'; Code: '1’'
    I’m using appium 1.15.1, node v10.15.3, npm 6.13.2
    This always happens to me when tests are finished executing. Thanks for the help!
    mohit12705
    @mohit12705
    Ios simulator is taking long time to load URL first time in saucelabs . Any idea how to solve this issue or make sure page is loaded and then execute rest steps
    Ivan Chernov
    @iChernov
    Hello guys. Weird thing - our tests are running way faster on old iPhones (6s/7), than on the new ones (like 8 Plus). Does anybody have a hint - what could be the reason, or with whom I can discuss it?
    Mugilan K
    @Mugilanmca
    Hi Every one , am unable to clear the text field value in iOS realdevices.Not getting any issues while use the clear() command but the value also no cleared.
    Appium Vesrion -1.15
    Xcode version 11.2
    Appium java client -7.3.0
    Could any one please help
    Vadym Morozov
    @flexin777

    Hello
    I am runninng mobile e2e tests useing Appium for native app.
    I have in spec pleace, where I want to close and then open this app.
    Using

    browser.closeApp();
    browser.launchApp();

    Issue. When I start run spec - it first executes those commands, even if they are located in the end of suite. Why?

    HemanathanGama
    @HemanathanGama
    Hi Guys,
    i am struck in my projrect, need your help. I am working on QR payment Android application
    i need to scan QR code when my mobile cam opens
    any suggestion or idea, i am wokring on Appium with java
    i am struck in this for 3 days
    sridharreddysuram123
    @sridharreddysuram123
    Do you have the QR CODE Image?
    if yes, then keep the device camera in a position to scan the QR Image.
    HemanathanGama
    @HemanathanGama
    i want to in automation
    do in automation
    aizaztoppa
    @aizaztoppa
    has anyone ever run into an issue with calling browser.getWindowHandles() throwing 'command not supported' error?
    Im testing using android 9 device via browserstack with appium version 1.15.0
    AbhijitPaithane
    @AbhijitPaithane
    @Mugilanmca I also face same but I did
    Workaround as long press will give you menu to clear . Not good answer but we can unlock temporary for solutions
    vinaynalla1401
    @vinaynalla1401
    Hi , any one can help me, i am facing below issue
    An unknown server-side error occurred while processing the command. Original error: App with bundle identifier 'com.xxxx.xxxx.xxx.xxxxx' unknown
    Using below software version
    Appium Version 1.15.1
    XCode Version 11.1
    OS Version Mojave 10.14.6
    iPHOne simulator 13.1
    HemanathanGama
    @HemanathanGama
    may be you have given invalid bundle id
    @vinaynalla1401
    vinaynalla1401
    @vinaynalla1401
    @HemanathanGama i have cross checked , i have used the correct bundle id, because old version app is working , could you please provide another clue
    Thanks for responding my request issue
    HemanathanGama
    @HemanathanGama
    is your xcode is updated one
    and check your developer certificate ?
    vinaynalla1401
    @vinaynalla1401
    @HemanathanGama xcode is updated one (xcode version 11.1) & certificate is provided by dev team(it is also working for previous version app)
    HemanathanGama
    @HemanathanGama
    are you running in real device or simulator
    vinaynalla1401
    @vinaynalla1401
    @HemanathanGama simulator(using .app file)
    HemanathanGama
    @HemanathanGama
    is that .app is simulator compiled build ?
    vinaynalla1401
    @vinaynalla1401
    @HemanathanGama we have to cross check with dev team, we do not know
    HemanathanGama
    @HemanathanGama
    if its simulator compiled than only you can run in simultor
    ptmhpp
    @ptmhpp

    Hi
    i am trying to execute my IOS feature file in saucelabs containing a scenario of 2 steps
    but when it launches the ios app,for 4 5 minutes,it continuously launches tha app and finally finishes the execution without executing a single step with error

    Error:
    Test did not see a new command for 90 seconds. Timing out.

    Please help me in resolving the issue

    vinaynalla1401
    @vinaynalla1401
    @HemanathanGama thanks for updating information