Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Mugilan K
    @Mugilanmca
    Appium Vesrion -1.15
    Xcode version 11.2
    Appium java client -7.3.0
    Could any one please help
    Vadym Morozov
    @flexin777

    Hello
    I am runninng mobile e2e tests useing Appium for native app.
    I have in spec pleace, where I want to close and then open this app.
    Using

    browser.closeApp();
    browser.launchApp();

    Issue. When I start run spec - it first executes those commands, even if they are located in the end of suite. Why?

    HemanathanGama
    @HemanathanGama
    Hi Guys,
    i am struck in my projrect, need your help. I am working on QR payment Android application
    i need to scan QR code when my mobile cam opens
    any suggestion or idea, i am wokring on Appium with java
    i am struck in this for 3 days
    sridharreddysuram123
    @sridharreddysuram123
    Do you have the QR CODE Image?
    if yes, then keep the device camera in a position to scan the QR Image.
    HemanathanGama
    @HemanathanGama
    i want to in automation
    do in automation
    aizaztoppa
    @aizaztoppa
    has anyone ever run into an issue with calling browser.getWindowHandles() throwing 'command not supported' error?
    Im testing using android 9 device via browserstack with appium version 1.15.0
    AbhijitPaithane
    @AbhijitPaithane
    @Mugilanmca I also face same but I did
    Workaround as long press will give you menu to clear . Not good answer but we can unlock temporary for solutions
    vinaynalla1401
    @vinaynalla1401
    Hi , any one can help me, i am facing below issue
    An unknown server-side error occurred while processing the command. Original error: App with bundle identifier 'com.xxxx.xxxx.xxx.xxxxx' unknown
    Using below software version
    Appium Version 1.15.1
    XCode Version 11.1
    OS Version Mojave 10.14.6
    iPHOne simulator 13.1
    HemanathanGama
    @HemanathanGama
    may be you have given invalid bundle id
    @vinaynalla1401
    vinaynalla1401
    @vinaynalla1401
    @HemanathanGama i have cross checked , i have used the correct bundle id, because old version app is working , could you please provide another clue
    Thanks for responding my request issue
    HemanathanGama
    @HemanathanGama
    is your xcode is updated one
    and check your developer certificate ?
    vinaynalla1401
    @vinaynalla1401
    @HemanathanGama xcode is updated one (xcode version 11.1) & certificate is provided by dev team(it is also working for previous version app)
    HemanathanGama
    @HemanathanGama
    are you running in real device or simulator
    vinaynalla1401
    @vinaynalla1401
    @HemanathanGama simulator(using .app file)
    HemanathanGama
    @HemanathanGama
    is that .app is simulator compiled build ?
    vinaynalla1401
    @vinaynalla1401
    @HemanathanGama we have to cross check with dev team, we do not know
    HemanathanGama
    @HemanathanGama
    if its simulator compiled than only you can run in simultor
    ptmhpp
    @ptmhpp

    Hi
    i am trying to execute my IOS feature file in saucelabs containing a scenario of 2 steps
    but when it launches the ios app,for 4 5 minutes,it continuously launches tha app and finally finishes the execution without executing a single step with error

    Error:
    Test did not see a new command for 90 seconds. Timing out.

    Please help me in resolving the issue

    vinaynalla1401
    @vinaynalla1401
    @HemanathanGama thanks for updating information
    davidtophat
    @davidtophat
    whats the latest chrome version that can work with appium?
    i haven't changed anything on my end but its saying that the element couldn't be found in chrome anymore :S
    HemanathanGama
    @HemanathanGama
    guys do any one have idea on the path od virtual scene image in android emulator
    ptmhpp
    @ptmhpp

    Hi
    when i am running scenarios on sauce labs for iOS environment
    But the emulator is not rotating in landscape mode.

    Capabilities are as follows:
    appiumVersion: '',
    browserName: '',
    platformName: 'iOS',
    deviceOrientation: 'landscape',
    rotatable: true,
    platformVersion: '12.2',
    name: jobName,
    deviceName: 'iPad Air 2 Simulator',
    waitforTimeout: 60000,
    newCommandTimeout: 30 * 60000,
    recordVideo: true,
    recordScreenshots: true,
    fullReset: true,
    noReset: false,
    autoAcceptAlerts: true,
    count: 100,
    sharedTestFiles: true,
    rotatable: true,
    tunnelIdentifier: envConfig.username,

    yashkabra143
    @yashkabra143
    Hello
    Anyone have any idea about Katalon Mobile automation
    Because I am facing some issues with this
    Xionghu
    @XH888
    hello~~~
    yashkabra143
    @yashkabra143
    Do you know about the error "Unable to create a new remote session"
    Mugilan K
    @Mugilanmca
    Hi @AbhijitPaithane - Thanks for the help.
    Dai Pham Ngoc
    @daipn-1859
    I'm calling driver.getContexts() but sometime it throws only NATIVE_APP context
    That's why I can't switch to WEBVIEW on my hybrid app.
    Have any one can give me some ideas why there is only NATIVE_APP context thrown?
    Sven Murat
    @sven14_gitlab
    @daipn1859 we had a similar problem, in the end, we can see webview context only if the app is installed through the android studio on a real device, not with the playstore...
    shivam1747
    @shivam1747
    I am unable to access elements by id, I tried multiple approaches. But the same can be accessed by xpath. Can anybody tell where I am lacking behind?
    I am testing it on web app!!
    Dai Pham Ngoc
    @daipn-1859
    @sven14_gitlab my issue cause I'm using getContexts() before WEBVIEW is displayed
    I resolve this problem my waitUntil command of wdio v5
    Thibaut Theret
    @ThibautTheret_twitter
    Hi. I want to automatize tests on a mobile app, I can navigate on it, but I can't use IDs which are put on a ion-tabs
    Does anyone know how to do please ?
    RnanSoares
    @RnanSoares
    Hi guys, in the capabilities of my project, putting "noReset: true", when automation tries to start, a crash occurs. What may be happening?
    Manchiken
    @Manchiken
    Hi, guys. Tell me how to use appium on ios to find the shadow element. This issue says that in version 1.16 this was fixed by appium/appium#9733, but it doesn’t work for me. Can you confirm that this problem is really resolved? I use java
    Vadym Morozov
    @flexin777
    @daipn1859 Hello
    It can be because of you have some Alert - it is native alert
    Níko Escobar
    @NikoEscobar

    Hi how you guys are doing,

    Quick question:

    There is a way of getting the current sessionsID? from any appium endpoint maybe?