These are chat archives for appsforartists/ambidex

10th
Feb 2015
Brenton Simpson
@appsforartists
Feb 10 2015 00:16
@mclouvem Thanks. I'm running it on iojs now. It works the same, I just removed SASS (and switched to inline styles on the project I'm building on io)
I expect this will be 0.2.0 eventually, but I wanted to play with it on a branch before committing
since other people might be using it now :grinning:
Brenton Simpson
@appsforartists
Feb 10 2015 07:09
@captainill I'll look at your repo when I have time.
Brenton Simpson
@appsforartists
Feb 10 2015 19:16
@captainill I can't run your demo because your restify server won't install on my mac
10 error palette-restify@0.0.0 seed-db: make seed
however, you don't have a paletteID parameter in any of your routes, so CurrentPalette will never load
what version of node are you running?
Jonathan Thomas
@captainill
Feb 10 2015 20:33
@appsforartists I actually removed theCurrentPalette file and paletteID reference from refluxActionsForRouterState’ in branchv2` to simplify things further and thats where I’m seeing the connection hang
not sure whats up with the restify server. I added notes in the readme to make sure mongodb is running
node -v is v0.10.21
v0.10.21
Brenton Simpson
@appsforartists
Feb 10 2015 20:34
@captainill I don't have mongo. is there a public server that i can point your API at to test the react code?
Ambidex has been tested on node 0.11.13 and (without sass-loader) on io.js
You should try upgrading and see if that helps
Jonathan Thomas
@captainill
Feb 10 2015 20:35
no public server right now. I can try setting that up tho
cool I’ll upgrade and see
Brenton Simpson
@appsforartists
Feb 10 2015 20:35
ok. lmk.
Jonathan Thomas
@captainill
Feb 10 2015 20:36
will do. thanks
Brenton Simpson
@appsforartists
Feb 10 2015 20:36
i'd hate for you to take the time to try Ambidex and have a bad experience. :smiley:
Jonathan Thomas
@captainill
Feb 10 2015 20:37
ya know I haven’t used reflux either so there’s just a bit of a learning curve but I’m keen to get up and running with something
Brenton Simpson
@appsforartists
Feb 10 2015 20:37
:)
Jonathan Thomas
@captainill
Feb 10 2015 21:15
@appsforartists I’ve updated node to 0.11.13 and still have an issue. I deployed my rest service tho https://palette-restify.herokuapp.com/api/v1/palettes You’ll get back an array of objects
right now this is the only url that will return anything
i updated the path to the service in branch v2 of my ambidex app