by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Karthik Srivatsa
    @ksrivatsa
    @frankh Hey
    The newly added acknowledge button in the slack messages doesnt seem to work
    Any suggestions?
    Error : Darn – that didn't work. Only Slack Apps can add interactive elements to messages
    Karthik Srivatsa
    @ksrivatsa
    I have tried everything. It just doesnt work.
    Please help me
    Karthik Srivatsa
    @ksrivatsa
    What do i configure the callback url to in the slack app?
    Frank Hamand
    @frankh
    yeah unfortunately it requires the slack app to be set up, so i actually removed it by default in the latest version
    you need to create an app and enable interactive messages and set the callback url to <domain>/plugins/cabot_alert_slack/messages
    I couldn't get @mentions and the button working at the same time so we stopped using the button
    Karthik Srivatsa
    @ksrivatsa
    After doing all that I get this that didn't work (error message: Failure when receiving data from the peer)
    Error : that didn't work (error message: Failure when receiving data from the peer)
    Or this that didn't work (error message: 502_service_error)
    Karthik Srivatsa
    @ksrivatsa
    Thank you. The Acknowledge button doesnt work on the plugin test. Though it shows a button there.
    It works fine on actual services.
    :)
    Thank you @frankh
    Ian L.
    @MrSaints
    ksrivatsa: @frank is going to be away until next month
    Just a heads up.
    Karthik Srivatsa
    @ksrivatsa
    Haha.. alright
    Punita Ojha
    @punitaojha
    This message was deleted
    Brandon H.
    @tuxdapenguin
    How do I add a custom status check plugin to cabot?
    Wilgert Velinga
    @wilgert
    Hello all i have installed Cabot on our MacMini and it was running fine for over a week performing several checks every minute
    after a reboot of the MacMini scheduled checks stopped working
    i can manually run checks from the Web Interface
    never mind, found it
    ERROR: Pidfile (celerybeat.pid) already exists.
    Seems we're already running? (pid: 1)
    log of celerybeat is filled with this
    so i need to reset the container
    Wilgert Velinga
    @wilgert
    new question: how to do that?
    Karthik Srivatsa
    @ksrivatsa
    @tuxdapenguin Create the plugin, test it, add it to pypi. Add it to the plugin apps in production.env and the plugin specific confs. Start all the containers with docker-compose except that the web container should run tail -f /dev/null. Do the migrations for the plugin. Now stop the containers and restart as ususal with the gunicorn command. This should work.
    Obviously install the pypi package before making the migrations.
    Karthik Srivatsa
    @ksrivatsa
    Oh.. I'm sorry. After the migrations, create a new image with the plugin installed using pypi. Now change the docker-compose to use this image and run the same gunicorn command.
    Frank Hamand
    @frankh
    @wilgert doing docker-compose down and then docker-compose up should fix that issue
    Karthik Srivatsa
    @ksrivatsa
    @frankh The calendar doesnt seem to update
    How can I check?
    Is there some way I can trigger it manually?
    Karthik Srivatsa
    @ksrivatsa
    It worked. Nevermind.
    Jean-Frédéric
    @JeanFred
    Glad it worked out @ksrivatsa :)
    Moritz Heiber
    @moritzheiber
    hey
    Is the Docker setup working for anybody else?
    For me it fails to initialize/migrate the database
    LOG:  database system was interrupted; last known up at 2017-09-05 21:16:50 UTC
    LOG:  database system was not properly shut down; automatic recovery in progress
    LOG:  redo starts at 0/1687B48
    LOG:  invalid record length at 0/1715D40: wanted 24, got 0
    LOG:  redo done at 0/1715CC0
    LOG:  last completed transaction was at log time 2017-09-05 21:17:28.757131+00
    LOG:  MultiXact member wraparound protections are now enabled
    LOG:  database system is ready to accept connections
    LOG:  autovacuum launcher started
    ERROR:  null value in column "jenkins_api" violates not-null constraint
    DETAIL:  Failing row contains (1, Default Jenkins, null, null, null).
    STATEMENT:  INSERT INTO "cabotapp_jenkinsconfig" ("name", "jenkins_api", "jenkins_user", "jenkins_pass") VALUES ('Default Jenkins', NULL, NULL, NULL) RETURNING "cabotapp_jenkinsconfig"."id"
    Moritz Heiber
    @moritzheiber
    Okay, I've reverted back to 0.10.8, and at least now I was able to get it to run
    But that's a standing issue with the latest Docker images then
    Jean-Frédéric
    @JeanFred
    @moritzheiber Thanks for reporting this. Is this hitting you when migrating an existing install or making a fresh install ?
    (This sounds related to arachnys/cabot#546 )
    Moritz Heiber
    @moritzheiber
    @JeanFred Completely fresh install, i.e. docker-compose up -d
    And yes, it sounds to me like #546 is the right angle