These are chat archives for arnaud-lb/php-rdkafka

1st
Jul 2016
Ferran Caellas Puig
@FerCa
Jul 01 2016 09:04
Hi everyone!
I'm having a issue trying to use the high level consumer
I think somehow its a installation problem: I cannot instantiate RdKafka\KafkaConsumer
I have librdkafka version 0.9.1
Ferrans-iMac-2:opt ferrancaellas$ brew info librdkafka
librdkafka: stable 0.9.1 (bottled)
The Apache Kafka C/C++ library
https://github.com/edenhill/librdkafka
/usr/local/Cellar/librdkafka/0.9.1 (13 files, 1.3M) *
Poured from bottle on 2016-07-01 at 10:24:28
From: https://github.com/Homebrew/homebrew-core/blob/master/Formula/librdkafka.rb
==> Dependencies
Build: pkg-config ✘
Required: lzlib ✔, openssl ✔
and 0.9.1 of the php extension also:

Ferrans-iMac-2:opt ferrancaellas$ pecl info rdkafka

About pecl.php.net/rdkafka-0.9.1

Release Type PECL-style PHP extension (source code)
Name rdkafka
Channel pecl.php.net
Summary Kafka client based on librdkafka
Description This extension is a librdkafka binding providing
a working client for Kafka 0.8 and 0.9.
Maintainers Arnaud Le Blanc arnaud.lb@gmail.com (lead)
Release Date 2016-01-11 09:30:44
Release Version 0.9.1 (beta)
API Version 0.9.0 (beta)
License MIT License
(http://opensource.org/licenses/mit-license.php)
Release Notes * Allow to build against librdkafka master/0.9.x
Required Dependencies PHP version 5.3.0
PEAR installer version 1.4.8 or newer
package.xml version 2.0
Last Modified 2016-06-30 16:06
Previous Installed - None -
Version

Any suggestion?
the extension is correctly installed, I can use other rdkafka clases, but not the ones for the high level consumer
Ferran Caellas Puig
@FerCa
Jul 01 2016 11:03
Ok, I just realised the high level consumer is not released right?
its on master
There is any way to get automatic partition assignment/revocation with the low level?
Magnus Edenhill
@edenhill
Jul 01 2016 21:44
Nope