Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jun 03 2019 12:11
    dotnet-maestro[bot] commented #1813
  • Jun 03 2019 12:11

    dotnet-maestro[bot] on darc-master-a926ae60-afdc-46d8-aabc-bb225655c15e

    (compare)

  • Jun 03 2019 12:11

    dotnet-maestro[bot] on master

    Update dependencies from https:… (compare)

  • Jun 03 2019 12:11
    dotnet-maestro[bot] closed #1813
  • Jun 03 2019 12:06
    dotnet-maestro[bot] opened #1813
  • Jun 03 2019 12:06

    dotnet-maestro[bot] on darc-master-a926ae60-afdc-46d8-aabc-bb225655c15e

    Update dependencies from https:… (compare)

  • Jun 03 2019 12:05

    dotnet-maestro[bot] on darc-master-a926ae60-afdc-46d8-aabc-bb225655c15e

    (compare)

  • May 30 2019 11:54
    jenergm commented #279
  • May 29 2019 14:59
    tmenier commented #1492
  • May 29 2019 04:58
    danroth27 updated the wiki
  • May 28 2019 14:25
    lewing commented #1807
  • May 27 2019 19:13
    matheusjulio96 commented #1652
  • May 27 2019 13:30
    springy76 commented #306
  • May 27 2019 13:13
    SQL-MisterMagoo commented #306
  • May 27 2019 13:07
    springy76 commented #306
  • May 27 2019 13:06
    springy76 commented #306
  • May 27 2019 12:24
    SQL-MisterMagoo commented #306
  • May 27 2019 12:20
    springy76 commented #306
  • May 27 2019 12:10
    dotnet-maestro[bot] commented #1812
  • May 27 2019 12:10

    dotnet-maestro[bot] on darc-master-e3474f54-f92f-4c3f-b116-ed9bdfe9754d

    (compare)

Alberto Passalacqua
@AlbertoPa
it seems not to use the connection string I put in secrets.json and the UserSecretId is set :-?
Alberto Passalacqua
@AlbertoPa
fixed by adding this to Program.cs but
var builder = WebApplication.CreateBuilder(args);

// Enable user secrets in development
builder.WebHost.ConfigureAppConfiguration((hostContext, builder) =>
{
    if (hostContext.HostingEnvironment.IsDevelopment())
    {
        builder.AddUserSecrets<Program>();
    }
});
but I definitely did not need that in .net 5 :-?
SQL-MisterMagoo
@SQL-MisterMagoo
@tag5 I haven't read all your policy requirements, but maybe this conversation will point you towards passing resource values to a policy. Check out @optimizasean posts before and after as they added some claims code as well.
:point_up: July 18, 2021 1:58 AM
Alberto Passalacqua
@AlbertoPa
I think the challenge is that he wants to pass the resource to the attribute 🤔
Mario van Zeist
@MariovanZeist
wvmstr
@wvmstr
@AlbertoPa I had user secrets setup when this app was still at net 5. Since it has been migrated to net 6. Moved my connection string from appsetting.json to user secrets . That seems to work. I do not have anything builder.AddUserSecrets anywhere.
Haytam Zanid
@zHaytam
I wonder if some day we can see Blazor rendering in a Canvas (even a C# one) instead of the DOM
The same as what Google did in their Google Docs app
Ivan Josipovic
@IvanJosipovic
Haytam Zanid
@zHaytam
Indeed
Ivan Josipovic
@IvanJosipovic
I think we'll be lucky if MS even lets us use Canvas without 3rd party packages.
Alberto Passalacqua
@AlbertoPa
@MariovanZeist @wvmstr odd indeed. If I port an old app it works. If I create a new template and then I try to add an EF migration, it always uses the connection string in appsettings.json rather than using the correct one in secrets.json. :-?
Alberto Passalacqua
@AlbertoPa
@MariovanZeist the "Program-only" templates only call CreateBuilder(args) right before reading the connection string.
Alberto Passalacqua
@AlbertoPa
hmm this says resolved dotnet/aspnetcore#33335
Mario van Zeist
@MariovanZeist
@AlbertoPa Don't think it is. (resolved)
Looking through the code quickly it never seems to hit the part where it should add secrets.
It does eventually call ConfigureWebHostDefaults, which does configure a lot of defaults... Except, it's not adding secrets, as that is added somewhere.
Haytam Zanid
@zHaytam

I think we'll be lucky if MS even lets us use Canvas without 3rd party packages.

You can? Assuming you're talking about HTML's canvas

Mario van Zeist
@MariovanZeist
It smells like a bug by ommision.
Alberto Passalacqua
@AlbertoPa
@MariovanZeist I reported ;-)
it's not a big deal, but it is unexpected
Alberto Passalacqua
@AlbertoPa
@MariovanZeist well the templates wanted to be "minimal" right? ;-)
Mario van Zeist
@MariovanZeist
I agree, I mean it is a small thing, but still it's an annoyance if you would have to add those lines, as you said. it doesn't fit the "minimalist" aproach
Alberto Passalacqua
@AlbertoPa
minimal template: //Do it yourself! :laughing:
Haytam Zanid
@zHaytam
Alberto Passalacqua
@AlbertoPa
That is cool
Mario van Zeist
@MariovanZeist
@AlbertoPa David wanted a runnable example as he could not reproduce it. So I created one and Secrets do work in my minimal example.
So it seems that it does work, but why doesn't it work in your example.
Mario van Zeist
@MariovanZeist
Oooh, I missed this part. (Execute Add-Migration and Update-Database in the package manager console) that might be why it's not working for you,
This might be an issue that has to do with EFCore not AspNetCore
Alberto Passalacqua
@AlbertoPa
No, it doesn't work with any secret
Brett McDonald
@bfmsoft

I created a nuget package that has a script file in it. When I use it in a Blazor project it will build the first time. Then all the builds after I get the following error.

The file is in the following dir: C:\Users\brettmc.nuget\packages\bfmsoft.web.blazorutil\1.0.2-ci20210925142813\content\wwwroot\scripts

The system seems to be looking for it in: C:\Users\brettmc.nuget\packages\bfmsoft.web.blazorutil\1.0.2-ci20210925142813\staticwebassets\scripts\bfmInputFile.js

\Microsoft.NET.Sdk.BlazorWebAssembly.ServiceWorkerAssetsManifest.targets(138,5): error MSB4018: The "GenerateServiceWorkerAssetsManifest" task failed unexpectedly.
\Microsoft.NET.Sdk.BlazorWebAssembly.ServiceWorkerAssetsManifest.targets(138,5): error MSB4018: System.AggregateException: One or more errors occurred. ---> System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\Users\brettmc.nuget\packages\bfmsoft.web.blazorutil\1.0.2-ci20210925142813\staticwebassets\scripts\bfmInputFile.js'.

Alberto Passalacqua
@AlbertoPa
@MariovanZeist let me try again
EF core does read from the same Configuration, so ehm...
Alberto Passalacqua
@AlbertoPa
hmm
indeed it is specific to EF
or better to the package manager :-?
the connection string is read correctly, passed correctly to UseWhateverDB(connString), but not used
Mario van Zeist
@MariovanZeist
If I remember correctly, is that Add migration loads in the program assembly, but does a bit of his own magic to run things.
Alberto Passalacqua
@AlbertoPa
I replied
probably to be reported to the EF team? :-?
let's see what David says
Alberto Passalacqua
@AlbertoPa
@MariovanZeist David replied and identified the issue :-)
Alberto Passalacqua
@AlbertoPa
so quiet... more :coffee: needed :-)
Alberto Passalacqua
@AlbertoPa
any news onValidateComplexType? It seems the package still has 3.2-rc...
Mario van Zeist
@MariovanZeist
Morning...
@AlbertoPa David is on the case I see. Issue moved to Efcore repo
Alberto Passalacqua
@AlbertoPa
oh ok