Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Aaron Sumner
    @ruralocity
    @atbaker I'm tethered to my phone and the push seems to work, but is slow. It's currently pushing a 128.2 MB image ... does that seem right?
    Andrew Tork Baker
    @atbaker
    @ruralocity - for the first push of a repo that’s not a crazy size. If that’s slowing you down you can skip that step
    Aaron Sumner
    @ruralocity
    @atbaker cool, thanks.
    djdrisco
    @djdrisco
    apt-get install -y mongodb-10gen , return error unable to locate package mongdb-10gen , thoughts? Should I just use latest and greatest mongodb, using apt-get install -y mongodb-org ?
    Andrew Tork Baker
    @atbaker
    @djdrisco - I put that MongoDB Dockerfile in there as an example, but you don’t need to run it (and it might be out of date!)
    georgecook-cbt
    @georgecook-cbt
    Usually if you're installing mongo on ubuntu you need to add a mongo repo to your apt list if I recall
    Ilya Lipnitskiy
    @lipnitsk
    The EXPOSE keyword doesn't really seem to affect what port is exposed. ie the app.py server listens on 5000, and if I forward 8000 to 5000 with docker run -p 8000:5000, the app still runs. Is EXPOSE really needed in our Dockerfile?
    Andrew Tork Baker
    @atbaker
    @lipnitsk You’re right - most of the time you’ll set port forwarding settings with docker run. But if you pass the -P flag to docker run, it will map the exposed port from the Dockerfile to the first available port on the host, which is handy
    @lipnitsk - I mostly put EXPOSE in my Dockerfiles to help me remember which port is important for that app
    djdrisco
    @djdrisco
    thanks. I ended add mongodb to my apt list using this:http://docs.mongodb.org/v2.2/tutorial/install-mongodb-on-ubuntu/
    Ilya Lipnitskiy
    @lipnitsk
    @atbaker thanks, makes sense.
    skymix
    @skymix
    at final of the build i get some strange errors:
    Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', gaierror(-2, 'Name or service not known'))': /simple/flask/
    But in my local pc with fedora i could make the pip install correctly.
    Network problems?
    Andrew Tork Baker
    @atbaker
    @skymix - Can’t say that error seems recognizable. Maybe network funkiness
    skymix
    @skymix
    It's safe to CTRL+C and restart the build?
    It started from the first stage or start from the build triggers?
    Andrew Tork Baker
    @atbaker
    @skymix - definitely safe to CTRL+C
    skymix
    @skymix
    I make it but same error :(
    Collecting Flask==0.10.1 (from -r requirements.txt (line 1))
    Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', gaierror(-2, 'Name or service not known'))': /simple/flask/
    absolutejoe
    @absolutejoe
    @atbaker My build command appears to have run without any errors, but I'm getting an error:
    @atbaker /bin/sh: 1: [python: not found
    Andrew Tork Baker
    @atbaker
    @absolutejoe - Hmm. That makes me think there’s an issue with your CMD
    @absolutejoe - want to bring your laptop up front and we’ll check it out together?
    absolutejoe
    @absolutejoe
    @atbaker ... I get that when I run my docker run command
    Silly comma's. Works much better with all of them in the right place.
    honzo0481
    @honzo0481
    if any one else tries this tutorial using boot2docker for windows and cant input their credentials after doing docker login, try adding the flags -upe. it worked for me. from: docker/docker#14336
    Charles Chen
    @charleschen
    is anyone gettin 503 Service Unavailable from https://registry.hub.docker.com/?
    Charles Chen
    @charleschen
    nm http://status.docker.com/ says the register web is down
    mrkbutty
    @mrkbutty
    Docker Login from windows command line freezes at login: prompt - bug still open on docker site since July. Need to use the --username prompt etc,also need to change the server as the windows default is incorrect. I used https://index.docker.io/v1/
    m2developer
    @m2developer
    hi
    denied: requested access to the resource is denied
    while Pushing to the Docker Hub
    any hint >
    ?
    omaemaru
    @omaemaru
    You need to push it harder