Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    audubon
    @audubon
    hello world
    AlexBaranosky
    @AlexBaranosky
    Hi I was linked to the monarch wiki https://github.com/audubon/monarchsys/wiki from EliteTrader. I am wondering if there is somewhere I can see some documentation for Monarch?
    The "wiki" has almost no information. I'd love to try out Monarch though
    Maybe you guys could help me in deciding if Monarch serves my coding purposes? I asked on EliteTrader, and was suggested to try Monarch but I cannot tell if Monarch fits the bill. My question is here: http://www.elitetrader.com/et/index.php?threads/backtesting-auto-trade-software-for-experience-jvm-programmer-to-extend.298231/
    AlexBaranosky
    @AlexBaranosky
    ├── README.txt
    ├── gui
    │ ├── NetMQ.dll
    │ ├── ServiceStack.Text.dll
    │ ├── ServiceStack.Text.xml
    │ ├── conf
    │ │ └── zeromq.json
    │ ├── monarchui.exe
    │ ├── monarchui.exe.config
    │ ├── monarchui.pdb
    │ ├── monarchui.vshost.exe
    │ ├── monarchui.vshost.exe.config
    │ └── monarchui.vshost.exe.manifest
    └── monarch
    ├── bin
    │ ├── monarch
    │ └── monarch.bat
    ├── docs
    │ └── VERSION
    └── lib
    ├── akka-actor_2.11-2.3.7.jar
    ├── akka-slf4j_2.11-2.3.7.jar
    ├── akka-testkit_2.11-2.3.7.jar
    ├── antlr4-runtime-4.1.jar
    ├── cglib-nodep-3.1.jar
    ├── client.jar
    ├── commons-logging-1.1.3.jar
    ├── config-1.2.1.jar
    ├── esper-5.1.0.jar
    ├── jackson-core-asl-1.9.9.jar
    ├── jackson-jaxrs-1.9.9.jar
    ├── jackson-mapper-asl-1.9.9.jar
    ├── jeromq-0.3.4.jar
    ├── log4j-1.2.17.jar
    ├── logback-classic-1.1.2.jar
    ├── logback-core-1.1.2.jar
    ├── monarch-1.001280952.jar
    ├── org.abego.treelayout.core-1.0.1.jar
    ├── scala-library-2.11.4.jar
    └── slf4j-api-1.7.6.jar
    ./bin/monarch
    Exception in thread "main" java.lang.UnsupportedClassVersionError: application/MonarchMain : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
    at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)
    I read somewhere that it requires java 8?
    AlexBaranosky
    @AlexBaranosky
    anyone around?