Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
  • Jan 22 16:51
    m-gallesio closed #770
  • Jan 18 13:20
    Rtalos commented #167
  • Jan 16 15:44
    dependabot[bot] edited #55
  • Jan 16 15:44
    dependabot[bot] labeled #55
  • Jan 16 15:44
    dependabot[bot] edited #59
  • Jan 16 15:44
    dependabot[bot] labeled #59
  • Jan 16 15:44
    dependabot[bot] edited #61
  • Jan 16 15:44
    dependabot[bot] labeled #61
  • Jan 16 15:44
    dependabot[bot] edited #65
  • Jan 16 15:44
    dependabot[bot] labeled #65
  • Jan 16 15:44
    dependabot[bot] edited #66
  • Jan 16 15:44
    dependabot[bot] labeled #66
  • Jan 16 15:44
    dependabot[bot] edited #67
  • Jan 16 15:44
    dependabot[bot] labeled #67
  • Jan 16 15:44
    dependabot[bot] edited #68
  • Jan 16 15:44
    dependabot[bot] labeled #68
  • Jan 16 15:44
    dependabot[bot] edited #69
  • Jan 16 15:44
    dependabot[bot] labeled #69
  • Jan 16 15:44
    dependabot[bot] edited #70
  • Jan 16 15:44
    dependabot[bot] labeled #70
Jamie Nelson
@CKanishka did you manage to get a working Webpack 5 config with aurelia? I'm also looking for one.
1 reply
Michael Beck
I have this external library, https://static.zdassets.com/zendesk_app_framework_sdk/2.0/zaf_sdk.js, and I need to be able to have access to the 'ZAFClient' object in the view-model, anyone know how I would go about doing that?
Michael Beck
I feel like I am overlooking something simple
Michael Beck
I did overlook something. Typescript is dumb.
When using the aurelia-fetch-client HttpClient, is there a way to change the params.withDefaults({credentials: 'same-origin'}) to 'include' on a per call request. Right now, it looks like you can only set this during configuration. In some cases, I want to set this to include. It just depends on where the call is being made to avoid CORS issues.
Monica Zhang
I am trying to use aurelia-web-components to export a simple custom element into web component in order to use by other framework. My project just has one component under src/resource/elements folder and I followed the instructions under https://www.npmjs.com/package/aurelia-web-components. After running "npm run build", the dist folder just contains a bunch of app and vendors chunk js files. Where are the "You will find the compiled code in the dist folder, available in module formats: UMD, AMD, CommonJS and ES6."? How do I distribute the exported web components to other framework?
Here is my main.js file:
import * as environment from "../config/environment.json";
import { PLATFORM } from "aurelia-pal";
import { CustomElementRegistry } from "aurelia-web-components";

export function configure(aurelia) {
  // .feature(PLATFORM.moduleName('resources/index'));

  aurelia.use.developmentLogging(environment.debug ? "debug" : "warn");

  if (environment.testing) {

    .then(() => {
      const registry = aurelia.container.get(CustomElementRegistry);
    .then(() => aurelia.setRoot(PLATFORM.moduleName("app")));

I am trying to upgrade aurelia-templating-resources from 1.6.0 -> 1.13.1 to get the fix for the race condition when composing a UI (PR: aurelia/templating-resources#345) - it is throwing an exception when it calls configure.globalResources (Invalid resource path [function Compose(element, container, compositionEngine, viewSlot, viewResources, taskQueue)). I am wondering if I need to upgrade other dependencies along with the aurelia-templating-resources upgrade.

This is the aurelia section of my package.json:

"aurelia-animator-css": "1.0.4",
"aurelia-bootstrapper-webpack": "1.1.0",
"aurelia-configuration": "1.0.17",
"aurelia-event-aggregator": "1.0.1",
"aurelia-fetch-client": "1.1.3",
"aurelia-framework": "1.3.1",
"aurelia-history-browser": "1.1.1",
"aurelia-http-client": "1.2.1",
"aurelia-i18n": "1.6.2",
"aurelia-loader-webpack": "2.1.0",
"aurelia-logging-console": "1.0.0",
"aurelia-pal-browser": "1.8.0",
"aurelia-polyfills": "1.3.4",
"aurelia-route-recognizer": "1.1.1",
"aurelia-router": "1.5.0",
"aurelia-templating-binding": "1.4.1",
"aurelia-templating-resources": "1.13.1",
"aurelia-templating-router": "1.3.1",

thank you

Philip Peitsch
@bigopon hello! :wave:
Just wanted to ask, is there a plan on the horizon to release the changes in the aurelia-web-components module on to NPM any time soon? I'd like to get use of the forcePrefix setting that's there :sweat_smile:
Mark Roeling
Quick question, there used to be a jobs.aurelia.io site. Is there an alternative somewhere, and/or is it to be re-set up after au2? Preferably for not just USA ;)
Avraham Essoudry
hi, there is a site that visualize aurelia binding expressions as you type them, but I can't find the link..
anyone here knows where i can find it?
(parsing the expressions into AST, and visualize them.)
Avraham Essoudry
Hello, I need help with a Jasmine unit test for an Aurelia dialog. I recently upgrade the aurelia dialog package and I had to replace the dialog.open.then() to dialog.open.whenClosed. Now there are about 6 unit test failing because dialog.whenClosed is not a function. This is the implementation:
and this is how is set up in the unit test as of now:
Has anyone encountered any similar problems? If so, how do you go about fixing it?
Paul R. De Buck
Hi guys, I'm trying to animate an img (simple translation) but not on page load, but rather on the moment the element becomes visible in the screen, what would be the most appropriate way to do so with Aurelia Animation plugin ? Thanks
Paul R. De Buck
can I like call a function whenever we reach a certain div ?
Esger Jellema
@Pauldb8 aurelia animator will add the au-enter and au-enter-active classes when your element enters the DOM and when it has finished entering. (For elements with the au-animate class) You just have to write the styling you want to happen as these classes are applied. See:
Paul R. De Buck
Yes but it this case, the elements are already in the dom, I just want the animation to take place when certain div is reached and show in the view
Paul R. De Buck

In the end I used an eventListener on the scroll of the page, https://ilikekillnerds.com/2016/02/using-event-listeners-in-aurelia/
together with adding a class to the element, whenever
elements[i].getBoundingClientRect().top - windowHeight <= 0

Also I tried using scrolltop.bind="scrolltop" but that never worked so.

Esger Jellema
@Pauldb8 I did not understand 'reaching a certain div' because you did not mention scrolling. The intersectionObserver API provides a better approach then a scroll listener. https://developer.mozilla.org/en-US/docs/Web/API/Intersection_Observer_API
Elliot Schep

Hi all, I would like to write agnostic js code for a design system components (e.g. dropdown) that could be used in Aurelia and VueJS. Example agnostic code:

element = document.createElement('div')
element.addEventListener('click', () => console.log('foo'))

Do you guys know if I can somehow use that in Aurelia?

NVM it seems you can use React in Aurelia, so I guess this is not so hard. I will figure it out :)
John Tomaselli
Perhaps use web components. Try using some developed web components before writing one, see https://shoelace.style/
Have multiple text inputs, only one of which is editable at a time. The input is visible only when being edited, otherwise it is replaced with styled text. I seem to be unable to set focus on the text input after it is first created. I have tried several suggestions I have found on the web, but none of them have seemed to work.
Just found https://discourse.aurelia.io/, so moving this there...
heya all! been using Aurelia for a few years now and love it, but we are trying to upgrade it to latest and Web Pack 5. works great until you run it i get No view model found in module "app". nothing in the typescript or html has changed at all, just updating the npm packages. anyone seen this yet?
Newbie question please! Basic DI is giving me "Unexpected character '@'" on inject. "import {inject} from 'aurelia-framework'" (or aurelia-dependency-injection) and then "@inject(ServiceName)" to decorate the class. "You may need an appropriate loader to handle this file type" - what could be wrong here? I used the CLI to create the project (using TS, webpack and Sass)
Dan Pettersson
I just ran into the existance of the "view-cache" attribute. If used on an element with if, is setting view-cache="0" the same thing as setting cache to false in the if attribute?
Hoang Cuong
is there any sample of au2 lifecyclehooks?
Hello, I noticed @EisenbergEffect no longer posts much in Aurelia. Is he official still the leader of the project or who is mostly in lead now? Just curious, thanks for the great product (started using AU 2 today)
Suu CE
Does gitter use signal for chat ?
1 reply
Vinay Chaudhary
Checking in to see if anyone else is having issues with the latest CLI (3.0.1)? Not able to run any of the au commands once a project is scaffolded and npm packages are installed. I get "invalid command: build" for example. npm start does the same thing.
Mathieu Schimmerling
Hello Aurelia community ! I'm Component Party main contributor
An Aurelia fan wants to add Aurelia to Component Party with a strange behavior by forcing me to add Aurelia. Can you help me answer my questions in the following Github issue ? matschik/component-party#101
Charles Lindsay
I'm running into a infinite loop problem using Value Converters in AUv1... The two just keep bouncing back and forth between the toView() and fromView() each setting the same value over and over again. Any ideas?
Hey all, got a question about some dynamic import I want to do. I've a load call which gives me the locations of loads I need to do for it. So it's for a reports page of my application, but the loads of those reports are on each area of my existing application. I've created a loose reports part but want to dynamically include the report calls from the other areas. I've managed to import the corresponding class where the load is, but the issue I've now, is that the injects on those pages are not working. So the imports there of the corresponding business service are always 'undefined'. Can someone get me on the right track or give me a best practive to handle those 'dynamic' loads? Thanks in advance. (got a topic open as well: https://discourse.aurelia.io/t/dynamic-import-webpack-injects/4881)
Haim Avni
In order to enable google search in my application, I am trying to use pushState rather than the hash method. This is Aurelia 1 requirejs app. My server is Web2py. index.html is not static but is read from the server. There are no errors and I see that the router is created correctly in app.ts. However, the screen remains blank and app.html is never displayed. Without the pushState configuration on the app works correctly. You can watch it here: https://tol.life/gbs__test. With pushState on the link is https://tol.life/gbs__master. In the console one can see that the router is defined correctly but there is nothing on the screen. Any idea what I am missing?
Roel Plieger
Hi all, I have a question about destruction/clean up of custom attributes: if a custom attribute stores data in a property (e.g. this.data), will this property be destroyed after the custom attribute is detached from the DOM and unbound? I experience a problem with memory leaks and am not sure if the reference to the custom attribute is cleaned up so it will be garbage collected (and the property along with it).
Hi All, I'm giving Aurelia 2 a serious go for a sales funnel micro app that will live on a statically served page (on a landing page somewhere).
It's either this or Vue3 and I'm giving Aurelia a shot before considering Vue.
Dennis Stephens

Hello @everyone!
As a web developer with 6 years of full stack experience, I would like to set up a new job opportunity for myself, who has led several projects to success and received good reviews from many clients.

This is my website: https://dennis-stephens.vercel.app
You can check my experiences, projects with my name in team section, several certifications and Linkedin recommendations here.

It can be said that the strengths that I can see are the simultaneous guarantee of project speed and quality, accurate time management, and sincerity.

If you are currently in need of a new developer for your team, want to bring up a new startup, or need a freelancer, please check my website and feel free to send me a message.

I love this game, I feel very relaxed. It's like I'm feeling very hard to describe. Snakes io try!
does anyone have any information on a new version of aurelia-ui-virtualization? (specifically, a 1.1.0 version that is rumored to exist with a neat "horizontal-scroll" attribute)
Kimber Martin
I have a question about destruction/clean up of custom attributes: if a custom attribute stores data in a property (e.g. this.data), will this property be destroyed after the custom attribute is detached from the DOM and unbound? https://www.dinarguru.onl/
Tom Aalbers
Hi All. I am trying to upgrade a plugin from Aurelia 1 to Aurelia 2. In my Aurelia 1 plugin I am using BindingEngine to observe specific property on a bound object (via bindable) but I can't find anything on that in Aurelia 2. Can anyone point me in the right direction?
Leonan Moreira Martins
Hi everyone! How are you ? I have a problem and would like help. I'm doing a selection process in a company that asked for a simple software. a .net Rest API and C# back and front asked for aurelia. Until then, everything was going well. Now it has some errors that I don't know how to solve. Can someone help me. I speak only Portuguese but a little English too