Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
  • Jul 31 11:52
    bigopon closed #60
  • Jul 31 11:52
    bigopon commented #60
  • Jul 31 11:51

    bigopon on 2.2.4


  • Jul 31 11:51

    bigopon on master

    chore(release): prepare release… (compare)

  • Jul 31 11:50

    bigopon on 2.2.4


  • Jul 31 11:49

    bigopon on master

    fix(typings): include typings i… chore(release): prepare release… (compare)

  • Jul 29 21:33
    googleoryx opened #60
  • Jul 26 20:47
    josundt commented #190
  • Jul 26 08:00
    elitastic commented #175
  • Jul 25 12:01
    bigopon commented #190
  • Jul 25 11:59

    bigopon on 5.0.1


  • Jul 25 11:58

    bigopon on master

    chore(release): prepare release… (compare)

  • Jul 25 11:32

    dependabot[bot] on npm_and_yarn


  • Jul 25 11:32

    dependabot[bot] on npm_and_yarn


  • Jul 25 11:32
    dependabot[bot] closed #58
  • Jul 25 11:32

    dependabot[bot] on npm_and_yarn


  • Jul 25 11:32
    dependabot[bot] closed #56
  • Jul 25 11:32
    dependabot[bot] edited #58
  • Jul 25 11:32
    dependabot[bot] edited #56
  • Jul 25 11:32
    dependabot[bot] closed #57

now that i have ajax working, i'm getting an error in the console:

GET http://[localhost]:8080/login.pl?username=[object%20HTMLInputElement]&password=[object%20HTMLInputElement] 404 (Not Found)

my directory structure is:


i have tried in the url field:


all give me the same 404 errors.

do i need to configure a route for this script? and if so, how do i go about doing that?

Khuzema Kanore

Hello guys,
I am trying to integrate aurelia app with Identityserver4. The issue arise with the redirecturi. I have simple page as callback as below -

  <h1>${'Hello redirector'}</h1>
export class Callback {
  // private _userManager: UserManager;

So after the login when Identityserver redirects to callback.html its give error : Cannot GET /callback.html.
I have also tried and defined route

        route: "child-router",
        name: "child-router",
        moduleId: "./child-router",
        nav: true,
        title: "Child Router",

anyone have some inputs please let me know

Hello all :) -- Am wondering if au CLI helps with Aurelia 2 apps?

:point_up: February 13, 2018 1:54 AM
@weoreference, and until we get scoped CSS in the browsers, we’ll have to continue doing what @MaximBalaganskiy does.
We use in the html the <require from=‘./custom.css’> approach though, keeping markup concerns in markup files.

@AStoker Thank you for letting me know

Arch Enemy
@rhys hey, I recommend you use python instead of perl (unless you have little choice).... Also I wouldn't recommend using jquery , aurelia has an http-client
What's the potential of Aurelia2 simplifying the whole router + router-child processes ?
Looking forward for the next blog post. Hopefully with good news about Aurelia 2!
We have been using Aurelia since alpha, and are very pleased with the result. We got some big apps ready to migrate to Aurelia 2. I believe Aurelia 2 will be a great upgrade, and am very excited about any progress :D
My biggest concern is @EisenbergEffect being too busy with fast-dna or other Microsoft projects, putting Aurelia 2 on a hold

@_ArchEnemy__gitlab yeah, i don't have a choice using perl, it's native to what i'm trying to move from an old perl/html mashup app to a new SPA.

i will try the http-client and see if that helps.


@_ArchEnemy__gitlab - i am trying the fetch-client, but i still get a 404 error on the login.pl

here's the code for the fetch client:

import {HttpClient, json} from 'aurelia-fetch-client';
//import { responseTypeTransformer } from 'aurelia-http-client';

let httpClient = new HttpClient();

export class Login {
    constructor() {
        this.loginResponse = null;

    heading = 'Login';

    username    = '';
    password = '';

    login() {

        if ( this.username && this.password )
            var params = '?username=' + this.username + '&password=' + this.password;
            var url = 'login.pl' + params;

                .then( response => response.json())
                .then(data => {

my dir structure:



i also tried to configure the httpClient as follows:

httpClient.configure(config => {
                credentials: 'same-origin',
                headers: {
                  'Accept': 'application/json',
                  'X-Requested-With': 'Fetch'

i've done the baseUrl with 'src/' and the '/' shown above. both give me the 404 error.


and configuring BaseUrl with the actual 'http://[localhost]:8080/' also gives the 404 error.

i feel like i am missing something basic that sets up where aurelia is looking for files?

@16oh4_gitlab hey at the moment, spread syntax is not supported in the template
1 reply
there was a PR to handlle it here aurelia/binding#647 though it was dismissed as we there were at least 2 downsides (perf, quirks) and only 1 upside (syntax)
@rhysshadow what is the error?
btw, we are trying to migrate the community over discord here https://discord.gg/RBtyM6u and discourse here https://discourse.aurelia.io/
so you will get answers a lot faster there

@bigopon the error i get is the basic 404 - file not found. and it gives the url as: http://[localhost]:8080/login.pl, which is accurate.

and which place is best to ask my question? the discord server or the discourse?

@rhysshadow both
it's just about how you would get an answer the fastest way
Andreas Bernard

Is there a way to bind to as-element? So frex instead of going:

<div as-element="title-listing" if.bind="type === 'title' && listing" listing.bind="listing"></div>
<div as-element="underlined-listing" if.bind="type === 'underlined' && listing" listing.bind="listing"></div>


<div as-element.bind="type" listing.bind="listing"></div> ?


In angular you can write

this.router.navigate(['/'], {replaceUrl: true});

how we write in Aurelia ?

Hi everyone, I'm looking for a part-time aurelia programmer to do occasional pair-programming with me, paid on a daily rate depending on experience and ability to achieve the objectives. I'm hoping for someone with experience to match the $100-$200/day rate. The aurelia programmer will work on the website front end whilst I take care of corresponding backend code (c#). We would work together on screenshare. The application we're building is a trading platform. If you know of anybody who would like to do this, please email me at bboyle1234@gmail.com. Thank you :)
1 reply
Arne Deruwe
@bboyle1234 what timezone/country?
Gerald Gayowsky
Is it possible to watch for changes on a specific item of an array?
e.g. computedFrom('array.0') or computedFrom('array[0]')
@ggayowsky not at the moment, though maybe i can create a plugin for it

This morning I have an error and can't run my app. So I updated node and also tried with a new app but get this error:

PS C:\DevTest\Aurelia\test13> au run
Local aurelia-cli v1.3.1
Starting 'readProjectConfiguration'...
INFO [Bundle] Manually adding package: 2.3.3 aurelia-bootstrapper
INFO [Bundle] Manually adding package: 1.2.1 aurelia-loader-default
INFO [Bundle] Manually adding package: 1.8.1 aurelia-pal-browser
INFO [Bundle] Manually adding package: 1.0.0 aurelia-testing
INFO [Bundle] Manually adding package: 2.0.16 text
Finished 'readProjectConfiguration'
Starting 'processMarkup'...
Starting 'processJson'...
Starting 'processCSS'...
Starting 'copyFiles'...
Starting 'configureEnvironment'...
Finished 'copyFiles'
Finished 'processJson'
Finished 'processCSS'
Finished 'processMarkup'
Finished 'configureEnvironment'
Starting 'buildTypeScript'...
Finished 'buildTypeScript'
Starting 'writeBundles'...
INFO [Bundler] Tracing files ...
INFO [Bundler] Auto tracing package: 1.0.3 aurelia-event-aggregator
INFO [Bundler] Auto tracing package: 1.3.1 aurelia-framework
INFO [Bundler] Auto tracing package: 1.4.0 aurelia-history-browser
INFO [Bundler] Auto tracing package: 1.0.2 aurelia-loader
INFO [Bundler] Auto tracing package: 1.1.1 aurelia-logging-console
INFO [Bundler] Auto tracing package: 1.0.6 aurelia-metadata
INFO [Bundler] Auto tracing package: 1.8.2 aurelia-pal
INFO [Bundler] Auto tracing package: 1.3.4 aurelia-polyfills
INFO [Bundler] Auto tracing package: 1.5.3 aurelia-templating-binding
INFO [Bundler] Auto tracing package: 1.13.0 aurelia-templating-resources
INFO [Bundler] Auto tracing package: 1.4.0 aurelia-templating-router
INFO [Bundler] Auto tracing package: 2.5.4 aurelia-binding
INFO [Bundler] Auto tracing package: 1.5.2 aurelia-dependency-injection
INFO [Bundler] Auto tracing package: 1.2.1 aurelia-history
INFO [Bundler] Auto tracing package: 1.5.2 aurelia-logging
INFO [Bundler] Auto tracing package: 1.1.5 aurelia-path
INFO [Bundler] Auto tracing package: 1.7.1 aurelia-router
INFO [Bundler] Auto tracing package: 1.3.3 aurelia-task-queue
INFO [Bundler] Auto tracing package: 1.10.3 aurelia-templating
INFO [Bundler] Auto tracing package: 1.3.2 aurelia-route-recognizer
INFO [Bundle] Writing app-bundle.js...
INFO [Bundle] Writing vendor-bundle.js...
Finished 'writeBundles'
Application Available At: http://localhost:9000
BrowserSync Available At: http://localhost:3001
throw er; // Unhandled 'error' event

Error: listen EACCES: permission denied
at Server.setupListenHandle [as _listen2] (net.js:1296:21)
at listenInCluster (net.js:1361:12)
at Server.listen (net.js:1449:7)
at Object.startServer [as fn] (C:\DevTest\Aurelia\test13\node_modules\browser-sync-ui\lib\async.js:123:39)
at C:\DevTest\Aurelia\test13\node_modules\browser-sync-ui\lib\UI.js:184:14
at iterate (C:\DevTest\Aurelia\test13\node_modules\async-each-series\index.js:8:5)
at C:\DevTest\Aurelia\test13\node_modules\async-each-series\index.js:16:16
at C:\DevTest\Aurelia\test13\node_modules\browser-sync-ui\lib\UI.js:192:13
at Object.setUrlOptions [as fn] (C:\DevTest\Aurelia\test13\node_modules\browser-sync-ui\lib\async.js:76:9)
at C:\DevTest\Aurelia\test13\node_modules\browser-sync-ui\lib\UI.js:184:14
Emitted 'error' event on Domain instance at:
at Server.EventEmitter.emit (domain.js:500:12)
at emitErrorNT (net.js:1340:8)
at processTicksAndRejections (internal/process/task_queues.js:84:21) {
code: 'EACCES',
errno: 'EACCES',
syscall: 'listen',
address: '',
port: 3001,
domainEmitter: Server {
insecureHTTPParser: undefined,
_events: [Object: null prototype] {
request: [Function],
connection: [Array]
_eventsCount: 2,
_maxListeners: undefined,
_connections: 0,
_handle: null,
_usingWorkers: false,
_workers: [],
_unref: false,
allowHalfOpen: true,
pauseOnConnect: false,

tpAllowHalfOpen: false,
timeout: 120000,
keepAliveTimeout: 5000,
maxHeadersCount: null,
headersTimeout: 40000,
destroy: [Function],
[Symbol(IncomingMessage)]: [Function: IncomingMessage],
[Symbol(ServerResponse)]: [Function: ServerResponse],

[Symbol(kCapture)]: false,
[Symbol(asyncId)]: -1

domainThrown: false

Arne Deruwe
@TonyLugg I gave up on finding the permission denied thing, something is preventing your 3001 port to be used
The -by far- easiest solution is to just change the browsersync UI port number to something else:
1: open run.ts in aurelia_projects/tasks
let serve = gulp.series(build, done => {
            ui: {                                    //  <===
                port: 8080,             // <=== your preference
            },                                        // <===
            online: false,
            open: CLIOptions.hasFlag("open") || project.platform.open,
most of the stuff you find online points to docker as the culprit, suggesting disabling it, but I need Docker, so.. :p
Is there a room for Aurelia2 questions? I want to try the new Aurelia2 but having some issues with configuring routers. Can't find a good example of how to do it.
@corneliutusnea you cna use both discord and discourse
we are trying to migrate the community over discord here https://discord.gg/RBtyM6u and discourse here https://discourse.aurelia.io/
Tom Longson
@bigopon trying to get my company to whitelist discord for this
Gary Kaganas

I'm using the App Store. I use selectors to break handle smaller pieces of state. So, say that I have a deeply nested object:

const state = { 
  stuff: {
    innerStuffArray: []

If I need to add an item to innerStuffArray I'd replace state with a state that has that item.

So, my selector basically does:


I subscribe to that selector like this:

store.state.pipe(pluck("stuff")).subscribe((stuff) => {
...do stuff...

But, when I'm replace state with a new item in innerStuffArray the subscription is not called.

@Seebiscuit we are trying to move to discord & discourse for Q/A community building. Asking there should give you faster response
for your Q, can you help post it on either of those place? many users of the store are active there
Jake Aitchison
Quick question when using @autoInject do instances get resolved as singleton or transient by default (without manually registering things in the IOC container)?
Arne Deruwe
@milkshakeuk from the docs:
Everything is an application-level singleton except for those things which are classified as "components", essentially custom elements, custom attributes and view-models created through the router or composition engine. You can change the lifetime of router and composition created components through explicit configuration.
Jake Aitchison
John Tomaselli
what html editor do you use in aurelia. Replacing kendo...
im testing froala
Arne Deruwe
We are in the midst of testing https://alex-d.github.io/Trumbowyg/
The editor used by VS Code can be used as a replacement for e.g. Kendo.
John Tomaselli
After testing froala, quill, pell, thumowyg I’ve finallly found one to rule them all, it workS out of the box With aurelia easy to bundle with au cli(system js) and has great documentation. Since I use aurelia slickgrid, the cost of adding jquert
John Tomaselli
Since I use aurelia with Slickgrid the cost of adding query and bootstrap was not an issue. Easy to place multiple controls on view and use two way binding, It just works!
Arne Deruwe
@johntom sooo.... which one is it? :p