Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Dec 01 10:37
    DanieleRosada commented #669
  • Dec 01 10:36
    DanieleRosada commented #668
  • Nov 29 19:28
    thomas-darling commented #30
  • Nov 29 15:17
    davismj commented #668
  • Nov 28 07:43
    bigopon commented #669
  • Nov 28 07:42
    bigopon commented #668
  • Nov 26 13:24
    DanieleRosada opened #670
  • Nov 26 13:24
    DanieleRosada opened #669
  • Nov 26 13:24
    DanieleRosada opened #668
  • Nov 25 03:06
    CLAassistant commented #9
  • Nov 25 03:05
    dependabot[bot] labeled #9
  • Nov 25 03:05
    dependabot[bot] opened #9
  • Nov 25 03:05

    dependabot[bot] on npm_and_yarn

    chore(deps): bump highlight.js … (compare)

  • Nov 24 23:48
    CLAassistant commented #54
  • Nov 24 23:48
    dependabot[bot] labeled #54
  • Nov 24 23:48
    dependabot[bot] opened #54
  • Nov 24 23:48

    dependabot[bot] on npm_and_yarn

    chore(deps): bump highlight.js … (compare)

  • Nov 24 23:42
    CLAassistant commented #37
  • Nov 24 23:42
    dependabot[bot] labeled #37
  • Nov 24 23:42
    dependabot[bot] opened #37
VagyokC4
@VagyokC4
Question regarding custom-attributes. Are there any examples of extending and/or an attribute managing the IF binding? For example, I want to wrap some custom logic around the if binding by just using a new attribute that will programmatically add the IF binding to the element, and manage the bool variable bound to the if binding?
James Gosbell
@jamesg1
You can do if bindings to functions within your class model.
@wbrian-onlineed thanks will see how I go!
VagyokC4
@VagyokC4
Yeah, it's more that I want to extend the if binding and have my own version of an if binding, where my custom attribute is actually controlling the condition logic of the if binding, so that the end result is an html tag with only my custom attribute on it, no actual if bindings
plarner30
@plarner30
Is there a way to denote recognised query string parameters in aurelia router route definitions? At the moment just putting in a comment i.e this route will respond to ?foo parameter
Edwin
@thinkbig1979

Practical question:

The webpack.config.js code for exposing the Bluebird promise library in my (Aurelia) webapp is as follows:

module.exports = {
  module: {
    rules: [
      {
        test: /[\/\\]node_modules[\/\\]bluebird[\/\\].+\.js$/,
        loader: 'expose-loader?Promise'
      },
    ],
  },
};

After updating webpack expose-loader to v1.0. I get this error in the browser console:

Error: Module build failed (from
./node_modules/expose-loader/dist/cjs.js): ValidationError: Invalid
options object. Expose Loader has been initialized using an options
object that does not match the API schema.

options misses the property 'exposes'. Should be: non-empty string |
object { globalName, moduleLocalName?, override? } | [non-empty string
| object { globalName, moduleLocalName?, override? }, ...] (should not
have fewer than 1 item)

It's not obvious to me how to change the config at this point. Any suggestions? Many thanks!

bigopon
@bigopon
@thinkbig1979 have you resolves that issue?
If not, maybe try our new forum discord for faster response time /help? As we sre trying to migrate the community there
Edwin
@thinkbig1979
@bigopon Not resolved it yet. Will try the discord forum. Thanks :thumbsup:
DarkMikey
@DarkMikey

My project gets stuck while npm install on a jenkins build server in 3/4 times. Locally it builds fine. While I know this issue can be caused by endless reasons it is the only project that uses Aurelia CLI.
When I run npm install --verbose I don't see anything specific - just that it gets stuck at no specific timeout or package (package varies from build to build)

Are there any known issues with Aurelia CLI on build servers? Should it be installed globally?

DarkMikey
@DarkMikey

My project gets stuck while npm install on a jenkins build server in 3/4 times. Locally it builds fine. While I know this issue can be caused by endless reasons it is the only project that uses Aurelia CLI.
When I run npm install --verbose I don't see anything specific - just that it gets stuck at no specific timeout or package (package varies from build to build)

Are there any known issues with Aurelia CLI on build servers? Should it be installed globally?

It was a problem with node dependencies. I replaced npm i with npm ci which I discovered today and it works perfectly.

Andrew Markwell
@ihorizon
has anyone been successful in getting the Apollo-Client, caching etc working with Aurelia?
Andrew Markwell
@ihorizon
never mind, I managed to get it to work
reinholdk
@reinholdk
anyone bundled aurelia-dialog + ux-dialog-renderer successfully using SystemJS? I'm getting Error: Module ./ux-dialog-renderer not declared as a System.registerDynamic dependency of.... Bundle includes aurelia-dialog + [aurelia-dialog/ux-dialog-renderer.js].
Pallavan
@Pallava73535577_twitter
Hi. I am new to Aurelia. Can we use spring boot in the backend with aurelia in the front-end?
bigopon
@bigopon
@Pallava73535577_twitter absolutely yes
Mitch Capper (he, him)
@mitchcapper
What UI libraries are recommended for aurelia?
jquery-ui and jquery-mobile are referenced places but are pretty dead.
Mitch Capper (he, him)
@mitchcapper
Looking for something that just have some nicely styled form and basic controls with mobile support ,preferably with a listbox / with filtering capabilities. I have read the forums primarily seeing a year or two ago the ones mentioned of: Syncfusion, bootstrap 4 with the bootstrap toolbelt, kendo, the au-office-ui (a bit outdated), the MDC from google from a few sources, bulma as well (no list-group/combo box/ or similar for filtering), aurelia-ui-framework looks quite good but mobile support is a bit lacking.
Guy
@y2k4life
@mitchcapper Something new and looks interesting and Rob is part of is FAST and documentation (Integration)[https://www.fast.design/docs/integrations/aurelia]
Mitch Capper (he, him)
@mitchcapper
@y2k4life Thanks that looks great, microsoft should get it added to the fluent design page itself.
Omkar Atluri
@omkarvijf41
Hi Everyone, Are there any aurelia specific events that will call before aurelia-started and aurelia-composed events.
bigopon
@bigopon
@omkarvijf41 before that you have app root custom element lifecycle
Omkar Atluri
@omkarvijf41
@bigopon Thanks for reaching out. If you have some example could you please provide me. I couldn't find any examples as such.
Andy
@weoreference
So lonely... this place is not what it used to be : ( Also, Discourse is pretty inactive too (relatively speaking)
bigopon
@bigopon
@weoreference cant help it, any moment this chat becomes active, it's destined to be inactive I think
too little room for threading/ specific conversation focus
2 replies
and discourse, maybe it's relatively ... active?
Andy
@weoreference
@bigopon thank you : ) Are you core team? just wondering
1 reply
Sean Nowotny
@seannowotny
image.png
Hello I'm new to Aurelia and just created a new project with typescript. Running npm run start works fine but opening the index.html in the dist folder shows a blank page with errors. I'm using Node 10.17.0.
How can I fix this problem?
Sean Nowotny
@seannowotny
I'm also on Windows fyi
I just made a new project with 12.18.3 'au new'. Same problem.
I also deleted the node_modules folder in the 10.17.0 project and ran 'npm i' again, same result.
matrixbot
@matrixbot

adan_geno Hi everybody,

check out the new platform:
https://nearventur.com/auth/signup

Mason Mize
@starr0stealer

I was trying to introduce some work colleges to Aurelia, using aurelia-cli v1.3.1, and ran into a problem with it using regenerator-runtime.

I used the following to generate the project:
au new test-app -u -s cli-bundler,htmlmin-max,sass,postcss-typical,scaffold-navigation

And then when loading the app in the brower it doesn't load and has the following in console:

Failed to load resource: the server responded with a status of 404 (Not Found)
Error: Script error for "regenerator-runtime/runtime", needed by: main

I reviewed main.js, aurelia.json, babel.config.js, & node_modules, everything looks good to me, matching what my latest personal project has, so unsure what could be wrong.

1 reply
The 404 error is on http://localhost:9000/src/regenerator-runtime/runtime.js
Mason Mize
@starr0stealer
Note, at work we have government used applications, so we will need to support older browsers that wont support async/await.
Dan Pettersson
@deap82
I'm trying to achieve this in an "enhance scenario"; https://stackoverflow.com/questions/36170130/can-aurelias-repeat-for-be-used-with-view-model-ref/36181339
But my code for enhancing is pretty general, so I tried to declare the array using a let element; <let box-view-models.bind="[]"></let> before the repeater. But it doesn't work... Should it?
Mark Roeling
@mroeling
Hi, question. There are a couple of example applications for different frameworks that all do something similar, but in their own way. Like the "todo app". Is there already something like that for aurelia 2? And if so where can I find it? And if not, I would like to give it a shot. But in that case, which of these real world examples to take as base?
Mark Roeling
@mroeling
(answered through Discord, working on it :) )
fati-pouk
@fati-pouk
Hi everyone
bigopon
@bigopon
@starr0stealer were you avle to resolve it?
@fati-pouk yo
IzabelEvo
@IzabelEvo

Hi all! I am new to aurelia and have the following problem - I would like to use accordion in one of my pages for FAQ.
The accordion is working fine, however I would like to add show/hide function when someone is looking for a particular string and show the card with
the particular information in it.
I am doing that with jQuery, however I would like to do that with aurelia. Could you please give me some recommendation which would be the best way?

Thank you!

Alexander Joyal
@JoyalToTheWorld

I am struggling to get Aurelia and Webpack working. I managed to get the build to complete successfully, however when I try to load the app using the generated bundle I see

"Error: Unable to find module with ID: app/my-module"

I read the AureliaPlugin wiki and checked the listed modules Webpack was including in the bundle.
The module in question is listed, however it (and most other modules - not all strangely enough) is in the form "app/my-module?####".
I can't find anyway to control the moduleId webpack generates, and its pretty ridiculous it would generate a new Id and then not use it..
Any suggestions are appreciated. Also I have ensured PLATFORM.moduleName is used everywhere in case that's a question.

Alexander Joyal
@JoyalToTheWorld
Seems it could be related to LESS/CSS, since its only my Aurelia components with CSS referenced that are being renamed to the form "app/my-module?####".