Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
  • Dec 01 10:37
    DanieleRosada commented #669
  • Dec 01 10:36
    DanieleRosada commented #668
  • Nov 29 19:28
    thomas-darling commented #30
  • Nov 29 15:17
    davismj commented #668
  • Nov 28 07:43
    bigopon commented #669
  • Nov 28 07:42
    bigopon commented #668
  • Nov 26 13:24
    DanieleRosada opened #670
  • Nov 26 13:24
    DanieleRosada opened #669
  • Nov 26 13:24
    DanieleRosada opened #668
  • Nov 25 03:06
    CLAassistant commented #9
  • Nov 25 03:05
    dependabot[bot] labeled #9
  • Nov 25 03:05
    dependabot[bot] opened #9
  • Nov 25 03:05

    dependabot[bot] on npm_and_yarn

    chore(deps): bump highlight.js … (compare)

  • Nov 24 23:48
    CLAassistant commented #54
  • Nov 24 23:48
    dependabot[bot] labeled #54
  • Nov 24 23:48
    dependabot[bot] opened #54
  • Nov 24 23:48

    dependabot[bot] on npm_and_yarn

    chore(deps): bump highlight.js … (compare)

  • Nov 24 23:42
    CLAassistant commented #37
  • Nov 24 23:42
    dependabot[bot] labeled #37
  • Nov 24 23:42
    dependabot[bot] opened #37
Sean Nowotny
I'm also on Windows fyi
I just made a new project with 12.18.3 'au new'. Same problem.
I also deleted the node_modules folder in the 10.17.0 project and ran 'npm i' again, same result.

adan_geno Hi everybody,

check out the new platform:

Mason Mize

I was trying to introduce some work colleges to Aurelia, using aurelia-cli v1.3.1, and ran into a problem with it using regenerator-runtime.

I used the following to generate the project:
au new test-app -u -s cli-bundler,htmlmin-max,sass,postcss-typical,scaffold-navigation

And then when loading the app in the brower it doesn't load and has the following in console:

Failed to load resource: the server responded with a status of 404 (Not Found)
Error: Script error for "regenerator-runtime/runtime", needed by: main

I reviewed main.js, aurelia.json, babel.config.js, & node_modules, everything looks good to me, matching what my latest personal project has, so unsure what could be wrong.

1 reply
The 404 error is on http://localhost:9000/src/regenerator-runtime/runtime.js
Mason Mize
Note, at work we have government used applications, so we will need to support older browsers that wont support async/await.
Dan Pettersson
I'm trying to achieve this in an "enhance scenario"; https://stackoverflow.com/questions/36170130/can-aurelias-repeat-for-be-used-with-view-model-ref/36181339
But my code for enhancing is pretty general, so I tried to declare the array using a let element; <let box-view-models.bind="[]"></let> before the repeater. But it doesn't work... Should it?
Mark Roeling
Hi, question. There are a couple of example applications for different frameworks that all do something similar, but in their own way. Like the "todo app". Is there already something like that for aurelia 2? And if so where can I find it? And if not, I would like to give it a shot. But in that case, which of these real world examples to take as base?
Mark Roeling
(answered through Discord, working on it :) )
Hi everyone
@starr0stealer were you avle to resolve it?
@fati-pouk yo

Hi all! I am new to aurelia and have the following problem - I would like to use accordion in one of my pages for FAQ.
The accordion is working fine, however I would like to add show/hide function when someone is looking for a particular string and show the card with
the particular information in it.
I am doing that with jQuery, however I would like to do that with aurelia. Could you please give me some recommendation which would be the best way?

Thank you!

Alexander Joyal

I am struggling to get Aurelia and Webpack working. I managed to get the build to complete successfully, however when I try to load the app using the generated bundle I see

"Error: Unable to find module with ID: app/my-module"

I read the AureliaPlugin wiki and checked the listed modules Webpack was including in the bundle.
The module in question is listed, however it (and most other modules - not all strangely enough) is in the form "app/my-module?####".
I can't find anyway to control the moduleId webpack generates, and its pretty ridiculous it would generate a new Id and then not use it..
Any suggestions are appreciated. Also I have ensured PLATFORM.moduleName is used everywhere in case that's a question.

Alexander Joyal
Seems it could be related to LESS/CSS, since its only my Aurelia components with CSS referenced that are being renamed to the form "app/my-module?####".
@IzabelEvo @JoyalToTheWorld can you help post on discourse foryour questions? It will get faster response, as we are trying to migrate the community over there. Or discord, if you prefer
we are trying to migrate the community over discord here https://discord.gg/RBtyM6u and discourse here https://discourse.aurelia.io/
Hi. Can we integrate ElasticSearch with Aurelia? While using Aurelia, I want to fetch some data from ElasticSearch datastore and display it using aurelia. Is it possible? Is there any sample project or code for the same? Please help!
@Pallava73535577_twitter how you fetch data from ES would be the same, probably with or without Aurelia. Are you able to fetch data from ES atm?
@bigopon : I am going to design a dashboard which will retrieve data from ES. I am planning to use Aurelia instead of Angular. So, Just wanted to confirm if aurelia can communicate with ES.
Its a simple network call, so ill just say whatever angular does, any other can. Sjouldnt be any issues
Mason Mize
@bigopon Yeah I had to use a slightly older version (like two patch numbers) of regenerator-runtime I never looked into why it was no longer loading
Hi, how is everyone handling authentication? Using third-party services (like Auth0) or connected to something like IdentityServer? I've done it several ways over the years just looking for some fresh ideas.
Arne Deruwe
@jasonhjohnson IdentityServer and Azure AD
OpenID Connect basically :p
A new decorator that is planned to be a core part of v2 https://discourse.aurelia.io/t/better-know-a-framework-27-using-watch-decorator/3762
Please have a try and give some feedback. Also join discord here https://discord.gg/RBtyM6u and discourse here https://discourse.aurelia.io/ for our new community chatroom and forum
@jasonhjohnson currently trying to setup firebase, rather for study than for production.
is there any way I can register a plugin after aurelia.start()?
  Hello Guys, I'm not an Aurelia expert and I see a strange issue when debugging a customer application:
  I see some long delay during a component refresh and it's like the browser is hangging.
  Some browser even prompt to wait or cancel the page
  After added lots of tracing log lines, I see a strange "nothing happenend" between the a dynamic route calculation and the actual route activation.

  My question is: does one of you already behavior like that ? AKA does dynamic routes may cause behavior like that ?
  Thanks in advance
"nothing happenend" is expression from me to indicate "no activity in the browser"
  It's like the browser needs 30 seconds to find his way to the dynamic page ;-)
Chunpeng Huo

browser even prompt to wait or cancel the page

That normally means you got some very expensive js code running very slow, browser think it's too long it took (before go back to js main runloop). You can just browser dev tool to find out what's running slow.

If you’ve got a plain old typescript dto with public readonly property of type string and said property is marked with @observable what will happen when said dto is serialised to json? The reason I’m asking that when the following code (from aurelia-api) requestOptions.body = /^application\/(.+\+)?json/.test(contentType.toLowerCase()) ? JSON.stringify(body) : (0, _aureliaPath.buildQueryString)(body); is executed then requestOptions.body doesn’t contain the property that was marked as observable. Before the above call body does contain said property.
@wuyahui hello
@norgie it seems the property was some how assigned undefined value
Stephen Edwards
Hi, I am trying out Aurelia 2 and am having some issues with styles. I started using bulma sass but found I couldn't access things globally so as a quick fix added the bulma.css link to index.ejs. This kinda worked but now certain classes get renamed and my selectors often fail to work. What is my best option here? Should I remove the sass and stick to the css file in index.ejs? Or is there some documentation somewhere that describes how to use bulma sass in AU2. Thanks.
@bigopon I chose to implement toJSON() for said dtos. A bit extra work, but it worked like a charm.
@bigopon Do you happen to know if @JeroenVinke has left Gitter?
@dackjaniels2001 in v2, by default shadowDom is used so global styles wont have an effect on inner template of a custom element
You can disable shadow fom or use shared style features(shadow CSS) to have easier time witg styling
Please join our discord for, we are migrating our community there
@norgie i think hes still around, just less acrive on gitter. Maybe try discord?
@bigopon Ok. Thanks.
Dmitriy Frolov
When will be support of Webpack 5?
@mydim not sure webpack 5 support is planned for au1 but it should already work in au2 (at least without conventions).