Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
  • Jun 25 22:42
    LetsZiggy edited #198
  • Jun 25 15:54
    LetsZiggy edited #198
  • Jun 25 15:48
    LetsZiggy opened #198
  • Jun 20 01:37
    bigopon commented #182
  • Jun 16 21:41

    bigopon on 4.0.3


  • Jun 16 18:33
    josundt commented #341
  • Jun 15 22:09
    bigopon commented #341
  • Jun 15 22:07

    bigopon on master

    chore(release): prepare releaseā€¦ (compare)

  • Jun 15 17:10
    josundt commented #341
  • Jun 15 17:10
    josundt commented #341
  • Jun 15 17:09
    josundt commented #341
  • Jun 15 17:07
    josundt commented #341
  • Jun 15 17:01
    josundt commented #341
  • Jun 15 17:01
    josundt commented #341
  • Jun 15 17:01
    josundt commented #341
  • Jun 15 11:13
    bigopon commented #341
  • Jun 15 11:10

    bigopon on 4.0.2


  • Jun 15 11:10

    bigopon on master

    chore(release): prepare releaseā€¦ (compare)

  • Jun 15 10:06
    josundt commented #341
  • Jun 15 09:47
    josundt commented #341
Monica Zhang
I am trying to use aurelia-web-components to export a simple custom element into web component in order to use by other framework. My project just has one component under src/resource/elements folder and I followed the instructions under https://www.npmjs.com/package/aurelia-web-components. After running "npm run build", the dist folder just contains a bunch of app and vendors chunk js files. Where are the "You will find the compiled code in the dist folder, available in module formats: UMD, AMD, CommonJS and ES6."? How do I distribute the exported web components to other framework?
Here is my main.js file:
import * as environment from "../config/environment.json";
import { PLATFORM } from "aurelia-pal";
import { CustomElementRegistry } from "aurelia-web-components";

export function configure(aurelia) {
  // .feature(PLATFORM.moduleName('resources/index'));

  aurelia.use.developmentLogging(environment.debug ? "debug" : "warn");

  if (environment.testing) {

    .then(() => {
      const registry = aurelia.container.get(CustomElementRegistry);
    .then(() => aurelia.setRoot(PLATFORM.moduleName("app")));

I am trying to upgrade aurelia-templating-resources from 1.6.0 -> 1.13.1 to get the fix for the race condition when composing a UI (PR: aurelia/templating-resources#345) - it is throwing an exception when it calls configure.globalResources (Invalid resource path [function Compose(element, container, compositionEngine, viewSlot, viewResources, taskQueue)). I am wondering if I need to upgrade other dependencies along with the aurelia-templating-resources upgrade.

This is the aurelia section of my package.json:

"aurelia-animator-css": "1.0.4",
"aurelia-bootstrapper-webpack": "1.1.0",
"aurelia-configuration": "1.0.17",
"aurelia-event-aggregator": "1.0.1",
"aurelia-fetch-client": "1.1.3",
"aurelia-framework": "1.3.1",
"aurelia-history-browser": "1.1.1",
"aurelia-http-client": "1.2.1",
"aurelia-i18n": "1.6.2",
"aurelia-loader-webpack": "2.1.0",
"aurelia-logging-console": "1.0.0",
"aurelia-pal-browser": "1.8.0",
"aurelia-polyfills": "1.3.4",
"aurelia-route-recognizer": "1.1.1",
"aurelia-router": "1.5.0",
"aurelia-templating-binding": "1.4.1",
"aurelia-templating-resources": "1.13.1",
"aurelia-templating-router": "1.3.1",

thank you

Philip Peitsch
@bigopon hello! :wave:
Just wanted to ask, is there a plan on the horizon to release the changes in the aurelia-web-components module on to NPM any time soon? I'd like to get use of the forcePrefix setting that's there :sweat_smile:
Mark Roeling
Quick question, there used to be a jobs.aurelia.io site. Is there an alternative somewhere, and/or is it to be re-set up after au2? Preferably for not just USA ;)
Avraham Essoudry
hi, there is a site that visualize aurelia binding expressions as you type them, but I can't find the link..
anyone here knows where i can find it?
(parsing the expressions into AST, and visualize them.)
Avraham Essoudry
Hello, I need help with a Jasmine unit test for an Aurelia dialog. I recently upgrade the aurelia dialog package and I had to replace the dialog.open.then() to dialog.open.whenClosed. Now there are about 6 unit test failing because dialog.whenClosed is not a function. This is the implementation:
and this is how is set up in the unit test as of now:
Has anyone encountered any similar problems? If so, how do you go about fixing it?
Paul R. De Buck
Hi guys, I'm trying to animate an img (simple translation) but not on page load, but rather on the moment the element becomes visible in the screen, what would be the most appropriate way to do so with Aurelia Animation plugin ? Thanks
Paul R. De Buck
can I like call a function whenever we reach a certain div ?
Esger Jellema
@Pauldb8 aurelia animator will add the au-enter and au-enter-active classes when your element enters the DOM and when it has finished entering. (For elements with the au-animate class) You just have to write the styling you want to happen as these classes are applied. See:
Paul R. De Buck
Yes but it this case, the elements are already in the dom, I just want the animation to take place when certain div is reached and show in the view
Paul R. De Buck

In the end I used an eventListener on the scroll of the page, https://ilikekillnerds.com/2016/02/using-event-listeners-in-aurelia/
together with adding a class to the element, whenever
elements[i].getBoundingClientRect().top - windowHeight <= 0

Also I tried using scrolltop.bind="scrolltop" but that never worked so.

Esger Jellema
@Pauldb8 I did not understand 'reaching a certain div' because you did not mention scrolling. The intersectionObserver API provides a better approach then a scroll listener. https://developer.mozilla.org/en-US/docs/Web/API/Intersection_Observer_API
Elliot Schep

Hi all, I would like to write agnostic js code for a design system components (e.g. dropdown) that could be used in Aurelia and VueJS. Example agnostic code:

element = document.createElement('div')
element.addEventListener('click', () => console.log('foo'))

Do you guys know if I can somehow use that in Aurelia?

NVM it seems you can use React in Aurelia, so I guess this is not so hard. I will figure it out :)
John Tomaselli
Perhaps use web components. Try using some developed web components before writing one, see https://shoelace.style/
Have multiple text inputs, only one of which is editable at a time. The input is visible only when being edited, otherwise it is replaced with styled text. I seem to be unable to set focus on the text input after it is first created. I have tried several suggestions I have found on the web, but none of them have seemed to work.
Just found https://discourse.aurelia.io/, so moving this there...
heya all! been using Aurelia for a few years now and love it, but we are trying to upgrade it to latest and Web Pack 5. works great until you run it i get No view model found in module "app". nothing in the typescript or html has changed at all, just updating the npm packages. anyone seen this yet?
Newbie question please! Basic DI is giving me "Unexpected character '@'" on inject. "import {inject} from 'aurelia-framework'" (or aurelia-dependency-injection) and then "@inject(ServiceName)" to decorate the class. "You may need an appropriate loader to handle this file type" - what could be wrong here? I used the CLI to create the project (using TS, webpack and Sass)
Dan Pettersson
I just ran into the existance of the "view-cache" attribute. If used on an element with if, is setting view-cache="0" the same thing as setting cache to false in the if attribute?
Hoang Cuong
is there any sample of au2 lifecyclehooks?
Hello, I noticed @EisenbergEffect no longer posts much in Aurelia. Is he official still the leader of the project or who is mostly in lead now? Just curious, thanks for the great product (started using AU 2 today)