Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Apr 05 17:45

    avspeed on master

    add remove screen sharing event (compare)

  • Apr 05 17:45

    avspeed on master

    add remove screen sharing event (compare)

  • Apr 02 20:37

    avspeed on master

    MuteAudio/UnMuteAudio update u… (compare)

  • Apr 02 20:37

    avspeed on master

    MuteAudio/UnMuteAudio update u… (compare)

  • Apr 02 12:18

    avspeed on master

    fixed socket username property (compare)

  • Apr 02 12:18

    avspeed on master

    fixed socket username property (compare)

  • Apr 02 12:13

    avspeed on master

    added JoinWebMeeting - returns… (compare)

  • Apr 02 12:13

    avspeed on master

    added JoinWebMeeting - returns… (compare)

  • Mar 31 02:01

    avspeed on master

    added GetParticipants function (compare)

  • Mar 31 02:01

    avspeed on master

    added GetParticipants function (compare)

  • Mar 30 15:33

    avspeed on master

    trying out acknowledgements (compare)

  • Mar 30 15:33

    avspeed on master

    trying out acknowledgements (compare)

  • Mar 30 13:48

    avspeed on master

    added custom function call (compare)

  • Mar 30 13:48

    avspeed on master

    added custom function call (compare)

  • Mar 30 02:34

    avspeed on master

    Added function to get list of p… (compare)

  • Mar 30 02:34

    avspeed on master

    Added function to get list of p… (compare)

  • Mar 21 02:58

    avspeed on master

    remove unecessary code (compare)

  • Mar 21 02:58

    avspeed on master

    remove unecessary code (compare)

  • Mar 21 01:26

    avspeed on master

    use websockets (compare)

  • Mar 21 01:26

    avspeed on master

    use websockets (compare)

abelm688
@abelm688
@StonePaleAle @avspeed I'm having the same issue. I haven't been able to get the newest licensed library to connect to the new signalling server. I also pulled the new WinForms demo app, and haven't been able to connect to signalling with it either. The signalling server will run locally, but never accepts a connection.
Team@AVSPEED
@avspeed
@abelm688 can you paste your <add key="SignalingUrl" key here ?
@abelm688 is your signaling server listening ?
abelm688
@abelm688
<add key="SignalingUrl" value="https://10.0.0.9:9000/" />
Netstat -q shows that the port is open and listening.
I sent an email to support@avspeed with some more details if that helps
Team@AVSPEED
@avspeed
can you switch to just 10.0.0.9:9000/
@abelm688 can you switch to just 10.0.0.9:9000/
abelm688
@abelm688
Changing to <add key="SignalingUrl" value="10.0.0.9:9000/" /> has the same result.
Team@AVSPEED
@avspeed
@abelm688 I am going to clone the signaling server that is on github and run a quick test. brb
abelm688
@abelm688
Ok. Thanks!
Team@AVSPEED
@avspeed
@b
@abelm688 can you try <add key="SignalingUrl" value="http://10.0.0.9:9000/" />
Team@AVSPEED
@avspeed
@abelm688 I just ran a quick test by cloning the repo, npm install the socket.io dependency and started listening on port 9000. I then chgange the config in the WEBRTCWinformTest demo to point to <add key="SignalingUrl" value="http://10.0.0.3:9000/" /> and I was able to join the meeting
StonePaleAle
@StonePaleAle
@avspeed Running with http allows it to attempt, but I am seeing this: info - unhandled socket.io url repeated every second or so.
abelm688
@abelm688
@avspeed Same here. The signalling server begins showing info - unhandled socket.io url, but the app never joins the conference. It stays on the join screen as before.
StonePaleAle
@StonePaleAle
@avspeed @abelm688 I was able to get it to work. I removed the extra folders from node_modules, and only included socket.io (from npm install). Connected right up.
abelm688
@abelm688
@StonePaleAle @avspeed Deleting the node_modules folder and re-running npm install socket.io worked for me. The demo app is now connecting properly. Thanks StonePaleAle!
Team@AVSPEED
@avspeed
@abelm688 @StonePaleAle glad that this is resolved. I just realized that the npm install step is missing from the github page. I will add it.
@abelm688 I saw your email about the licensed version. I appreciate the heads up about that.
abelm688
@abelm688
@avspeed Thanks for looking into the problem. I just finished more extensive testing and everything is working perfectly with this library version except for the device selection. Unfortunately the project I am working requires the use of a document camera that shows up as a webcam device, and the iConf control always uses the document camera instead of the actual webcam. I will send an email with the code I am using for device selection in case it is just something I am doing wrong.
@avspeed And no problem on the licensed email. It just seemed odd so I wanted to let you know.
StonePaleAle
@StonePaleAle
@abelm688 @avspeed Any update on the device selection issue? I haven't been able to get it to work with the latest version. No matter which IDs I pass in, it always selects the same camera. The old version worked fine, but the latest libraries do not. Thanks
abelm688
@abelm688
@StonePaleAle They released a new build, 1.0.1.36, yesterday that fixed the problem for me.
Team@AVSPEED
@avspeed
Thanks @abelm688 , @StonePaleAle yes. A new build was relased yesterday. The updated license version is also available for download that shodul fix the issue.
@StonePaleAle the demos are also up to date
@StonePaleAle iconfRTC.SelectDevice("HD Pro Webcam C920 (046d:082d)", DeviceType.Video);
A few things about the SelectDevice function
First we added a new parameter for the Device Type ( DeviceType.Video or DeviceType.Audio )
Second, we found out that with some cameras device ids randomly change , so the device "label" is more reliable to use for the device selection.
Thanks
StonePaleAle
@StonePaleAle
@avspeed @abelm688 Thank you both! It's working perfectly.
StonePaleAle
@StonePaleAle

@avspeed What is the secret to getting a signaling server running on heroku? I followed the instructions, and have it running :2019-02-26T23:52:12.797610+00:00 app[web.1]: AVSPEED RTC Signaling Server listening at 0.0.0.0:43867
Yet I can't connect to it. I can still connect to the provided test server process at https://rtc-signaling-service.herokuapp.com:443/

Is there something special I need to do on Heroku?
Thanks!

Team@AVSPEED
@avspeed
image.png
@StonePaleAle no secret, really .. our heroku instance of the signaling server is deployed directly from the github repo https://github.com/avspeed/RTCSignaling.io
Ultimately it does not matter which port you are listening on, you should connect to port :443
https://[yourherokuappurl]:443/
image.png
StonePaleAle
@StonePaleAle
@avspeed That was it. I had been checking the log to see which port it was listening on, and using that. 443 hooked me right up.
Thank you!
Team@AVSPEED
@avspeed
@StonePaleAle anytime! We :heart: heroku ..
StonePaleAle
@StonePaleAle
@avspeed Would it be possible to add a method to the control to query the server for current meeting-ids?
Or possibly expose the socket so we could call custom methods on the server, and catch custom events? I would like to add a lobby-like list, with different attributes. Pwd Required, Max Users, Private, etc
StonePaleAle
@StonePaleAle
I was able to get around the possible duplicate meeting id issue. I am also passing data through the message method/receive event using jsonconvert.
It would still be nice to have a generic method and event we could use for custom server stuff. Using SendMessageToMeeting/MeetingMessageReceived for all of it (text messages, images, classes, files) is kind of a nightmare to maintain. If this is not possible, I will continue.
Thanks!
Team@AVSPEED
@avspeed
@StonePaleAle understood. Let me see what we can come up with.
Ikus
@ikus
Hello, is possible integrete whit openvidu.io?
Ikus
@ikus
@aleh4d Also I wnat to use Kurento. dis you solved?
Team@AVSPEED
@avspeed
@ikus hello, we do not support media server at this time
LucioJunqueiraSimoes
@LucioJunqueiraSimoes
Hi, I want use SIGNALR to connect users, there is a example of SIGNALR server implementation for iConf? Thanks
Team@AVSPEED
@avspeed
@LucioJunqueiraSimoes let me see what we have for SignalR, initially we had added support for SignalR ad we even had a sample SignalR example but we have not updated the SignalR support with the newer versions, just because user interest has not been there, so I cannot guarantee that it will still work. We will get back to you on that
LucioJunqueiraSimoes
@LucioJunqueiraSimoes
Hi, thanks for response. Le try another way, my solution is very simple, I need connect two machines in a closed network and I want make this without any signaling IO.
I found this funcitons
iconfRTC.AcceptCall()
iconfRTC.PlaceCall()
iconfRTC.RejectCall()
iconfRTC.IncomingCallDelegate()
but, there is no documentation what this work. Is possible to make connections without signaling?
Thanks.
SmiriOtmane
@SmiriOtmane
@avspeed hi , i am a devlopper and i use your SDK for WPF "IconfRTC.WPF"
i have a problem in the sound , it's become noisy when i start a meeting .
i think my rtc Control receive my sound and it resend to me and a loop of sound start , i think this is the reason .
@avspeed how can i fix that ?