These are chat archives for aws/aws-sdk-php

7th
Apr 2015
Mario de Frutos
@ethervoid
Apr 07 2015 05:50
Hello @jeremeamia, is there any easy form to use a more recent version of Guzzle instead of the 3.7 that is in the composer.json? What if i want to use a new version of Guzzle in my app? thx
Jeremy Lindblom
@jeremeamia
Apr 07 2015 05:54
Hey @ethervoid, Version 2 of the SDK requires Guzzle 3, but since Guzzle 4+ is a different namespace and package than Guzzle 3, you can use the SDK within a project that uses a later version of Guzzle. Version 3 of the SDK (coming in about a month) is built to work with either Guzzle 5 or 6 (also coming soon).
Mario de Frutos
@ethervoid
Apr 07 2015 05:59
Great news about the new version of the SDK :). I'll use it in a different namespace until the new version of the SDK. Thank you for you reply :)
Jeremy Lindblom
@jeremeamia
Apr 07 2015 06:00
No problem. You can find us here whenever you want to discuss anything or have quick questions.
Mario de Frutos
@ethervoid
Apr 07 2015 06:01
I didn't know about this tool. It's really useful
Jeremy Lindblom
@jeremeamia
Apr 07 2015 06:02

Gitter is really cool. Project-based chat rooms that you can

use Markdown in.

Mario de Frutos
@ethervoid
Apr 07 2015 06:02
I've discovered that the people of Influxdb is using it too :_)
Jeremy Lindblom
@jeremeamia
Apr 07 2015 06:03
We're pretty excited about our V3 though. We'll be on the latest version of Guzzle, and we'll be standardizing on the PSR7 HTTP interfaces and making all of the code async-compatible
Not too mention a lot of other little goodies and improved perf. :smile:
Mario de Frutos
@ethervoid
Apr 07 2015 06:05
Sounds pretty neat. You're doing a great job with this library, really easy to use: we are eager put the hands on it hehehe
Jeremy Lindblom
@jeremeamia
Apr 07 2015 06:05
:blush: