by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Eunchan Lee
@ckcks12
I'm very newbie in Ruby area, so I couldn't narrow down about the error, but in golang sdk they seem not to call sts:AssumeRoleWithWebIdentity when setting up crendential via WEB TOKEN (OCID based)
for more detail, this is dockerized ruby app with aws-sdk-ecs v1.15.7 on kubernetes with service account providing irsa
Gareth Griffiths
@GriffG84_twitter

Hello,

I am having issues configuring an event notification to trigger a lambda function,

I remove all notifications in a before hook in my tests, then set the event back up after I have uploaded all my files to the bucket. (Code below )

Enable Event
@s3_client.put_bucket_notification_configuration( bucket: S3_BUCKET_NAME, notification_configuration: { lambda_function_configurations: [ { id: "Unique Name", lambda_function_arn: LAMBDA_ARN, events: ["s3:ObjectCreated:*"], filter: { key: { filter_rules: [ { name: "prefix", value: "#{prefix}" }, { name: "suffix", value: "#{suffix}" } ] } } } ] } )
Disable Event
@s3_client.put_bucket_notification_configuration( bucket: S3_BUCKET_NAME, notification_configuration: {} )

This Disables and enables the notification however it doesn't seem to fire off when the event is set up. It sometimes processes some files but is really flakey. Have I missed something ?

When I query the event, it shows as active but doesn't do what is is supposed to do ?

jeffalexs
@jeffalexs
Hi, there need help here
with cognito, integration on RoR
Trying to do a AWS Cognito Authentication with Multiple Devices???
jeffalexs
@jeffalexs
Basically what I need is to see, if the user is already authenticated and pass the same token
How do we know if the user is already authenticated, The aws-sdk-ruby had some kind of method to know that?
Eric Lackore
@elackoreopscompass
Is there a limit to the quantity of rooms a single AWS admin account can create via the SDK
NoorulainK
@Annie_Khaliq_twitter
how to do i stub list_object_versions?
NoorulainK
@Annie_Khaliq_twitter
    resp = client.list_object_versions({
      bucket: "xxx",
      prefix: image_key
    }).to_h
response shows this:
resp = client.list_object_versions({
  bucket: "BucketName", # required
  delimiter: "Delimiter",
  encoding_type: "url", # accepts url
  key_marker: "KeyMarker",
  max_keys: 1,
  prefix: "Prefix",
  version_id_marker: "VersionIdMarker",
  use_accelerate_endpoint: false,
})
Fernando Baz
@bazfer
Hello! We're having some issues with getting CodeBuild to fetch the ENV variables for our S3 buckets, specifically getting Aws::Sigv4::Errors::MissingCredentialsError errors. The Rails proj is loading them correctly locally in two different machines, but when we deploy to our staging environment, it fails. The env vars are correctly set in the CodeBuild settings and we have also tried exposing them via Aws.config.update with no luck. We are using Shrine as our uploader library. Any pointers are greatly appreciated!
Fernando Baz
@bazfer
(hardcoding the keys works! still we are dumbfounded as to why the SDK is not retrieving the env vars from the CodeBuild settings)
Tatum
@tatums

Hello! I'm getting odd results when trying to upload and hoping ya'll can help. Notice the etag is nil. When successful I notice it's present. Any idea what would cause this?

I'm using v3 of the sdk

obj = Aws::S3::Resource.new(region: 'us-east-1').bucket("test.scholastica").object("article/1/1-bats-are-interesting.xml")
=> #<Aws::S3::Object:0x000055ebd5f68a58 @bucket_name="test.scholastica", @key="article/1/1-bats-are-interesting.xml", @data=nil, @client=#<Aws::S3::Client>, @waiter_block_warned=false>

obj.put({body: "testing"})
=> #<#<Class:0x000055ebcf6a6948>:Aws::S3::Types::PutObjectOutput:0x55ebd5e63cc0
    etag = nil,
    expiration = nil,
    request_charged = nil,
    server_side_encryption = nil,
    sse_customer_algorithm = nil,
    sse_customer_key_md5 = nil,
    ssekms_encryption_context = nil,
    ssekms_key_id = nil,
    version_id = nil
>
Also, is there an easy way to know if it's success or fail? Something like status == 200?
sumanreddyk
@sumanreddyk
Hello All , I need help on sts.get_session_token() api call, It's throwing 'Failed to open TCP connection to : (getaddrinfo: No such host is known. )' exception . AWS CLI get-session-token is working fine. Note:- I am running behind corporate proxy.
Andrew Cao
@dreamsoftech
Hi All, I have embedded quick sight dashboard to my web app. But it loads very slowly. Since it is loaded in iframe and url is changed every time, it is very slow.
Is there any better solution to make it faster?
siassaj
@siassaj
i cant see it
your link working?
Cami Meneses
@CamiMeneses
Hello All. Please help me!! Somebody knows how to get a private file using Ruby on Rails. At this moment I can get files only if they are public but I need get the private ones
Aliaksandr Rahalevich
@saks
hey everyone! I'm getting NameError: uninitialized constant Aws::Structure when require 'aws-sdk-secretsmanager'. This started happening after upgrade of aws-sdk-core from 3.91.1 -> 3.92.0. Anybody else having this issue?
Helmut Reiterer
@helmutrs
hello, I'm using ruby sdk v.2 , is there any example out there to send background notification to iOS 13 devices, please?
ruby aws sns v.2
chaitanyasabale
@chaitanyasabale
@proffalken Did you manage to resolve the issue of IPAddr::InvalidAddressError: invalid address ?
Aaditya Sharma
@lordozb
Hello guys! Is there any way to connect using IAM Role instead of access and secret keys?
I am trying to connect to AWS GLUE using Ruby SDK
Jessie Chen
@jessie00chen
Hello! I am trying to use this API: https://docs.aws.amazon.com/sdk-for-ruby/v3/api/Aws/IAM/Types/RoleLastUsed.html however the #last_used_date is nil even though the last used date is today. Is the API working as expected?
dave
@davedega
can i get AWSCredentials for a specific role ?
nvadakoppula
@nvadakoppula
def lambda_handler(response, context):

instance = 0

status = 0

response = client.list_resource_compliance_summaries(
    Filters=[
        {
            'Key': 'ComplianceType',
            'Values': [
                'Patch',
            ],
            'Type': 'EQUAL'
        },
    ],
instance = response.list_resource_compliance_summaries[resource_id],
status = response.list_resource_compliance_summaries[status]
but i see below error in lambda
"errorMessage": "'dict' object has no attribute 'list_resource_compliance_summaries'"
can someone help me here?
anhnguyen1tomosia
@anhnguyen1tomosia
Hi awser
i want to ask how can i use paginate with query in aws dynamodb client?
Colleen
@leenyburger

So, has anyone else seen this - when I create a bucket w/in my application using

 s3.create_bucket({
      bucket: bucket_name,
      acl: "private", # accepts private, public-read, public-read-write, authenticated-read
    })

And then log in to aws console via the web, the bucket permissions say that the bucket is publicly available.

I also tried a public access block

s3.put_public_access_block({bucket: bucket_name,
                                public_access_block_configuration:
                                { block_public_acls: true,
                                  block_public_policy: true
                                }
                              })

But still it says the bucket is public

Colleen
@leenyburger
Oh nevermind, if I add ignore_public_acls and restrict_public_buckets it works as intended
benebrice
@benebrice
Did you set de env variable with your AWS credentials ? @leenyburger
Is your bucket is the same region that what you’re requesting ?
Colleen
@leenyburger
@benebrice I figure it out. I had to see all 4 of the public_access_block_configuration parameters to achieve what I was going for.
Luke Becker
@lbecker34
On GetItemOutput in the DynmaoDB SDK, what is the value of "item" if nothing is found? Undefined?
lethunder
@lethunder
hello
i'm trying to use aws s3 with my active storage on rails app
i keep having Aws::S3::Errors::AccessDenied
eventhough i'm using the right credentials
benebrice
@benebrice
Are you using the correct region ?
lethunder
@lethunder
i just figure out that
the IT guys did a mistake
the gave me the bad region
now it's working fine