These are chat archives for azukiapp/azk

17th
Sep 2015
Slobodan Mišković
@slobo
Sep 17 2015 04:32
hey folks, has semantics of docker_extra options changed?
i have docker_extra: { create: { User: 'root' } }
but seems that provision commands are now running under user specified in the docker image?
worked fine with 0.14.6, upgraded to 0.15 and my provisioning broke.
I can't downgrade from apt-get however, cause it seems that repository only has the latest package available?
Slobodan Mišković
@slobo
Sep 17 2015 04:40
i see, docker_extra.create has been deprecated
it would be good to either have v14 warn about future deprecation, or at least for v15 to tell me that my Azkfile is invalid / that it's going to ignore some options
Gullit Miranda
@gullitmiranda
Sep 17 2015 12:41
@slobo, you're right. Ideally have a deprecated message, and usually we put. This particular case should have been excluded due to the change to the docker 1.8. I'll talk to staff if it is worth generating a release with this message.
Gullit Miranda
@gullitmiranda
Sep 17 2015 12:55
you could open a issue a request to be added instructions on how to proceed?
Gullit Miranda
@gullitmiranda
Sep 17 2015 17:22
ignore old msg
Gullit Miranda
@gullitmiranda
Sep 17 2015 17:30

I talked to the rest of the team. The reason we have not added the deprecated is that this functionality is actually a backdoor, and if possible will no longer exists. Of course, we could have added the message. But features of backdoor can have their behavior changed without much information.

How do you think we should proceed on this?