These are chat archives for azukiapp/azk

11th
Nov 2015
Patrik Patie Gmitter
@patie
Nov 11 2015 19:00
i have still problem with run node
php/mysql/redis etc works like a charm, but node have still problem :)
Gullit Miranda
@gullitmiranda
Nov 11 2015 19:07
what problem are you having, @patie ?
Patrik Patie Gmitter
@patie
Nov 11 2015 19:07
azk: Run system `node` return: (0), for command: /bin/bash -c npm start:
azk: [timeout] `azk` has timed out on `node` system.
azk: [timeout] Failure to reach port `32861` from `http://node.dev.azk.io` after 10000 milliseconds.
azk: [timeout] Make sure the start command binds `port` to the `0.0.0.0` interface, not only to the `localhost` interface.
still the same i dont know what i missing
Gullit Miranda
@gullitmiranda
Nov 11 2015 19:09
The error message displays a link?
Patrik Patie Gmitter
@patie
Nov 11 2015 19:10
Gullit Miranda
@gullitmiranda
Nov 11 2015 19:10
yes
Patrik Patie Gmitter
@patie
Nov 11 2015 19:10
yes
your application reads the env $HTTP_PORT?
Patrik Patie Gmitter
@patie
Nov 11 2015 19:12
javascript file for node contains only console log for test
Gullit Miranda
@gullitmiranda
Nov 11 2015 19:14
I can see this file?
Patrik Patie Gmitter
@patie
Nov 11 2015 19:18
of course pm
Gullit Miranda
@gullitmiranda
Nov 11 2015 23:14
@patie, sorry for the delay, just saw your repository now.
The problem you're having is simple:
the command npm start is nodemon index.js

but as you use the env NODE_ENV: "production", the nodemon is not installed.

I recommend you change your npm start to node index.js