These are chat archives for azukiapp/azk

24th
Nov 2015
Vytenis
@FDiskas
Nov 24 2015 08:11
$ azk shell --image=azukiapp/dig -- dig dev.azk.io

; <<>> DiG 9.10.2 <<>> dev.azk.io
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 62039
;; flags: qr aa rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;dev.azk.io.            IN    A

;; ANSWER SECTION:
dev.azk.io.        0    IN    A    172.17.0.1

;; Query time: 0 msec
;; SERVER: 172.17.0.1#53(172.17.0.1)
;; WHEN: Tue Nov 24 08:11:16 UTC 2015
;; MSG SIZE  rcvd: 44
$ azk start
azk: ↑ starting `mysql` system, 1 new instances...
azk: ✓ checking `azukiapp/mysql:5.7` image...
azk: Error: HTTP code is 500 which indicates error: server error - Cannot start container 9b39a21e4af4a1152dc2f41054dfde20d44207ed7c33c7410b176e05c9f533e4: failed to create endpoint dev.azk.io_type.daemon_mid.2d791d9fa1_sys.mysql_seq.1_uid.059881c092 on network bridge: iptables failed: iptables --wait -t nat -A DOCKER -p tcp -d 172.17.0.1 --dport 32779 -j DNAT --to-destination 172.17.0.9:3306 ! -i docker0: iptables: No chain/target/match by that name.
azk:  (exit status 1)

azk:     at /usr/lib/azk/node_modules/dockerode/node_modules/docker-modem/lib/modem.js:218:17
azk:     at getCause (/usr/lib/azk/node_modules/dockerode/node_modules/docker-modem/lib/modem.js:246:7)
azk:     at [object Object].Modem.buildPayload (/usr/lib/azk/node_modules/dockerode/node_modules/docker-modem/lib/modem.js:217:5)
azk:     at IncomingMessage.<anonymous> (/usr/lib/azk/node_modules/dockerode/node_modules/docker-modem/lib/modem.js:193:14)
azk:     at IncomingMessage.emit (events.js:117:20)
azk:     at _stream_readable.js:944:16
azk:     at process._tickCallback (node.js:448:13)
azk: Due to the above error azk will stop all instances already running.

azk: System `web` not running
azk: Skip stoping, system `phpmyadmin` does not scale.
azk: System `mysql` not running

┌───┬────────────┬───────────┬───────────────────────┬─────────────────┬─────────────┐
│   │ System     │ Instances │ Hostname/url          │ Instances-Ports │ Provisioned │
├───┼────────────┼───────────┼───────────────────────┼─────────────────┼─────────────┤
│ ↓ │ web        │ 0         │ web.dev.azk.io        │ -               │ -           │
├───┼────────────┼───────────┼───────────────────────┼─────────────────┼─────────────┤
│ − │ phpmyadmin │ 0         │ phpmyadmin.dev.azk.io │ -               │ -           │
├───┼────────────┼───────────┼───────────────────────┼─────────────────┼─────────────┤
│ ↓ │ mysql      │ 0         │ dev.azk.io            │ -               │ -           │
└───┴────────────┴───────────┴───────────────────────┴─────────────────┴─────────────┘
Vytenis
@FDiskas
Nov 24 2015 08:18
I'm using this settings https://gist.github.com/FDiskas/a0e8af35bae47c2d4802
$ azk doctor

      Version : 0.16.2
      Agent   : up
      Docker  : 1.9.1
      Use vm  : no
$ azk info
manifest_id:    2d791d9fa1
manifest:       /home/***/Projects/Translate/Azkfile.js
cache_dir:      /home/***/Projects/Translate/.azk/Azkfile.js
default_system: web
systems: 
  web: 
    depends: 
      - mysql
    image: 
      docker: azukiapp/php-fpm:latest
    command:  
    hostname: http://web.dev.azk.io
    ports: 
      http: 80/tcp
      data: 3306/tcp
    scalable: 
      default: 1
      limit:   -1
    mounts: 
      /var/www: /home/***/Projects/Translate
    envs: 
      ENV: dev
  phpmyadmin: 
    depends: 
      - mysql
    image: 
      docker: reduto/phpmyadmin:latest
    command:  
    hostname: http://phpmyadmin.dev.azk.io
    ports: 
      http: 80/tcp
    scalable: 
      default: 0
      limit:   1
    mounts: 

    envs: 

  mysql: 
    depends:  no dependencies
    image: 
      docker: azukiapp/mysql:5.7
    command:  
    hostname: http://dev.azk.io
    ports: 
      data: 3306/tcp
    scalable: 
      limit:   1
      default: 1
    mounts: 
      /var/lib/mysql: /home/***/.azk/data/persistent_folders/2d791d9fa1/Translate/xmysql
    envs: 
      MYSQL_ROOT_PASSWORD: root
      MYSQL_USER:          translate
      MYSQL_PASS:          translate
      MYSQL_DATABASE:      Translate_dev
Vytenis
@FDiskas
Nov 24 2015 09:28
After that any container can't ping any host
azk agent start
azk: Please wait, this process may take several minutes
azk: Loading settings and checking dependencies.
azk: Checking version...
azk: azk 0.16.2 detected
azk: Cleaning 0 lost containers
azk: Settings loaded successfully.
azk: Agent is being started...
azk: Trying to connect to docker (unix:///var/run/docker.sock) (timeout: 20s)...
azk: Starting azk dns service...
azk: Error: HTTP code is 500 which indicates error: server error - Cannot start container 81a0d6ad8aa259463dc4e1a68538995cbd4bf387f5d447347476816617285357: failed to create endpoint dev.azk.io_type.daemon_mid.ce833fc9c9_sys.dns_seq.1_uid.02782df092 on network bridge: COMMAND_FAILED: '/sbin/iptables -w -t nat -A DOCKER -p udp -d 172.17.0.1 --dport 53 -j DNAT --to-destination 172.17.0.5:53 ! -i docker0' failed: iptables: No chain/target/match by that name.

azk: Agent is being stopped...
azk: Agent has been successfully stopped.
Gullit Miranda
@gullitmiranda
Nov 24 2015 10:33
hi @FDiskas
run:
$ iptables -t nat -L -n -v | grep ‘something’
Vytenis
@FDiskas
Nov 24 2015 11:19
hi @gullitmiranda what you mean "something"?
$ sudo iptables -t nat -L -n -v
Chain PREROUTING (policy ACCEPT 11036 packets, 583K bytes)
 pkts bytes target     prot opt in     out     source               destination         
11042 584K PREROUTING_direct  all  --  *      *       0.0.0.0/0            0.0.0.0/0           
11042 584K PREROUTING_ZONES_SOURCE  all  --  *      *       0.0.0.0/0            0.0.0.0/0           
11042 584K PREROUTING_ZONES  all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain INPUT (policy ACCEPT 9749 packets, 297K bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain OUTPUT (policy ACCEPT 3985 packets, 11K bytes)
 pkts bytes target     prot opt in     out     source               destination         
 3985  11K OUTPUT_direct  all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain POSTROUTING (policy ACCEPT 4098 packets, 94K bytes)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 RETURN     all  --  *      *       192.168.124.0/24     224.0.0.0/24        
    0     0 RETURN     all  --  *      *       192.168.124.0/24     255.255.255.255     
    0     0 MASQUERADE  tcp  --  *      *       192.168.124.0/24    !192.168.124.0/24     masq ports: 1024-65535
    0     0 MASQUERADE  udp  --  *      *       192.168.124.0/24    !192.168.124.0/24     masq ports: 1024-65535
    0     0 MASQUERADE  all  --  *      *       192.168.124.0/24    !192.168.124.0/24    
  426 49288 MASQUERADE  all  --  *      !docker0  172.17.0.0/16        0.0.0.0/0           
 4098  94K POSTROUTING_direct  all  --  *      *       0.0.0.0/0            0.0.0.0/0           
 4098  94K POSTROUTING_ZONES_SOURCE  all  --  *      *       0.0.0.0/0            0.0.0.0/0           
 4098  94K POSTROUTING_ZONES  all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain OUTPUT_direct (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain POSTROUTING_ZONES (1 references)
 pkts bytes target     prot opt in     out     source               destination         
 3674  45K POST_FedoraWorkstation  all  --  *      enp0s25  0.0.0.0/0            0.0.0.0/0           [goto] 
  424 48649 POST_FedoraWorkstation  all  --  *      +       0.0.0.0/0            0.0.0.0/0           [goto] 

Chain POSTROUTING_ZONES_SOURCE (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain POSTROUTING_direct (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain POST_FedoraWorkstation (2 references)
 pkts bytes target     prot opt in     out     source               destination         
 4098  94K POST_FedoraWorkstation_log  all  --  *      *       0.0.0.0/0            0.0.0.0/0           
 4098  94K POST_FedoraWorkstation_deny  all  --  *      *       0.0.0.0/0            0.0.0.0/0           
 4098  94K POST_FedoraWorkstation_allow  all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain POST_FedoraWorkstation_allow (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain POST_FedoraWorkstation_deny (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain POST_FedoraWorkstation_log (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain PREROUTING_ZONES (1 references)
 pkts bytes target     prot opt in     out     source               destination         
10503 552K PRE_FedoraWorkstation  all  --  enp0s25 *       0.0.0.0/0            0.0.0.0/0           [goto] 
  539 32704 PRE_FedoraWorkstation  all  --  +      *       0.0.0.0/0            0.0.0.0/0           [goto] 

Chain PREROUTING_ZONES_SOURCE (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain PREROUTING_direct (1 references)
 pkts bytes target     prot opt in     out     source
Gullit Miranda
@gullitmiranda
Nov 24 2015 11:37
sorry. the right would be azk. But this response is sufficient.
pls, run:
$ docker info
Vytenis
@FDiskas
Nov 24 2015 11:41
$ docker info
Containers: 35
Images: 516
Server Version: 1.9.1
Storage Driver: devicemapper
 Pool Name: docker-253:0-2243491-pool
 Pool Blocksize: 65.54 kB
 Base Device Size: 107.4 GB
 Backing Filesystem: 
 Data file: /dev/loop0
 Metadata file: /dev/loop1
 Data Space Used: 13.57 GB
 Data Space Total: 107.4 GB
 Data Space Available: 18.73 GB
 Metadata Space Used: 24.24 MB
 Metadata Space Total: 2.147 GB
 Metadata Space Available: 2.123 GB
 Udev Sync Supported: true
 Deferred Removal Enabled: false
 Deferred Deletion Enabled: false
 Deferred Deleted Device Count: 0
 Data loop file: /var/lib/docker/devicemapper/devicemapper/data
 Metadata loop file: /var/lib/docker/devicemapper/devicemapper/metadata
 Library Version: 1.02.107 (2015-09-05)
Execution Driver: native-0.2
Logging Driver: json-file
Kernel Version: 4.2.6-300.fc23.x86_64
Operating System: Fedora 23 (Workstation Edition)
CPUs: 4
Total Memory: 15.4 GiB
Name: 191.v14.nfq.lt
ID: UG65:2SRE:OYCY:YZZC:KIOJ:QXN5:CANQ:QN25:X7PQ:TOLX:36BJ:7OAY
Gullit Miranda
@gullitmiranda
Nov 24 2015 11:46
looks good. So try this:
$ sudo rm -rf /etc/resolver/dev.azk.io
$ azk agent start
Vytenis
@FDiskas
Nov 24 2015 11:46
azk: Error: HTTP code is 500 which indicates error: server error - Cannot start container 6be662aecbb8da5444bedb1a8fb0b661d90323990171f534c738b6b63fb18545: failed to create endpoint dev.azk.io_type.daemon_mid.ce833fc9c9_sys.dns_seq.1_uid.02ba6c7092 on network bridge: COMMAND_FAILED: '/sbin/iptables -w -t nat -A DOCKER -p udp -d 172.17.0.1 --dport 53 -j DNAT --to-destination 172.17.0.5:53 ! -i docker0' failed: iptables: No chain/target/match by that name.

azk: Agent is being stopped...
azk: Agent has been successfully stopped.
Gullit Miranda
@gullitmiranda
Nov 24 2015 11:55
try:
sudo service docker stop
sudo service docker start
azk agent start
Vytenis
@FDiskas
Nov 24 2015 11:57
success
azk: Agent has been successfully started.
Gullit Miranda
@gullitmiranda
Nov 24 2015 11:58
the docker was stopped or started?
Vytenis
@FDiskas
Nov 24 2015 11:58
$ sudo service docker stop
Redirecting to /bin/systemctl stop  docker.service
Warning: Stopping docker.service, but it can still be activated by:
  docker.socket
$ sudo service docker start
Redirecting to /bin/systemctl start  docker.service
$ azk agent start
docker is stopped
This message was deleted
$ docker ps
CONTAINER ID        IMAGE                   COMMAND                  CREATED             STATUS              PORTS                           NAMES
f702ea0f4936        azukiapp/azktcl:0.0.2   "/bin/sh -c 'env; soc"   2 minutes ago       Up 2 minutes        53/udp, 172.17.0.1:80->80/tcp   dev.azk.io_type.daemon_mid.ce833fc9c9_sys.balancer-redirect_seq.1_uid.8f53f6f092
2f3c7883c412        azukiapp/azktcl:0.0.2   "/bin/sh -c 'dnsmasq "   2 minutes ago       Up 2 minutes        172.17.0.1:53->53/udp, 80/tcp   dev.azk.io_type.daemon_mid.ce833fc9c9_sys.dns_seq.1_uid.8ee5a4c092
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:01

I believe that after stopping the firewall, you must restart the docker service so he recreated the NAT.

now, in project folder, run:

$ azk shell mysql -c “ping dev.azk.io
Vytenis
@FDiskas
Nov 24 2015 12:05
$ azk shell mysql -c "ping dev.azk.io"
PING dev.azk.io (172.17.0.1): 56 data bytes
64 bytes from 172.17.0.1: icmp_seq=0 ttl=64 time=0.029 ms
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:06
cool =D
now try:
$ azk start mysql
$ azk shell mysql
# mysql -u${MYSQL_USER} -p${MYSQL_PASSWORD} -hdev.azk.io -P <PORT> -B ${MYSQL_DATABASE} -e “status”
Vytenis
@FDiskas
Nov 24 2015 12:08
one more problem :) I cant access the url
┌───┬────────────┬───────────┬───────────────────────┬────────────────────────────┬─────────────┐
│   │ System     │ Instances │ Hostname/url          │ Instances-Ports            │ Provisioned │
├───┼────────────┼───────────┼───────────────────────┼────────────────────────────┼─────────────┤
│ ↑ │ web        │ 1http://web.dev.azk.io │ 1-http:32770, 1-data:32769 │ -           │
Then I trying to access I always moved to http://nfq.lt
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:09
run:
curl -v http://web.dev.azk.io
Vytenis
@FDiskas
Nov 24 2015 12:12
Looks like its ok, so browser cash? I tryed the incognito mode but still redirected
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:13
I believe that your application is redirecting automatically. What was the response from the curl?
Vytenis
@FDiskas
Nov 24 2015 12:14
Response was the project page , not the nfq.lt
Not helped chrome://net-internals/#dns
tryed different browser - and WALIA

Still can't connect to database
Connect failed: Can't connect to MySQL server on 'dev.azk.io' (111) System status:
index.php

<?php
$mysqli = new mysqli("dev.azk.io", "translate", "translate", "translate_dev");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
}

printf ("System status: %s\n", $mysqli->stat());

$mysqli->close();
?>

Azkfile.js https://gist.github.com/FDiskas/a0e8af35bae47c2d4802

Vytenis
@FDiskas
Nov 24 2015 12:19
And can't access phpmyadmin page
$ azk status
┌───┬────────────┬───────────┬───────────────────────┬────────────────────────────┬─────────────┐
│   │ System     │ Instances │ Hostname/url          │ Instances-Ports            │ Provisioned │
├───┼────────────┼───────────┼───────────────────────┼────────────────────────────┼─────────────┤
│ ↑ │ mysql      │ 1         │ dev.azk.io1-data:32768               │ -           │
├───┼────────────┼───────────┼───────────────────────┼────────────────────────────┼─────────────┤
│ − │ phpmyadmin │ 0         │ phpmyadmin.dev.azk.io │ -                          │ -           │
├───┼────────────┼───────────┼───────────────────────┼────────────────────────────┼─────────────┤
│ ↑ │ web        │ 1         │ http://web.dev.azk.io │ 1-http:32770, 1-data:32769 │ -           │
│   │            │           │                       │                            │             │
└───┴────────────┴───────────┴───────────────────────┴────────────────────────────┴─────────────┘
$ azk shell web -c "ping dev.azk.io"
PING dev.azk.io (172.17.0.1) 56(84) bytes of data.
64 bytes from 172.17.0.1: icmp_seq=1 ttl=64 time=0.025 ms
$ azk shell mysql
root@2eb3a7331d94:/# mysql
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:23
run:
azk shell -c "env | grep MYSQL"
Vytenis
@FDiskas
Nov 24 2015 12:24
$ azk shell -c "env | grep MYSQL"
MYSQL_3306_PORT=32768
MYSQL_DATABASE=Translate_dev
MYSQL_DATA_HOST=dev.azk.io
MYSQL_DATA_PORT=32768
MYSQL_PASS=translate
MYSQL_3306_HOST=dev.azk.io
MYSQL_USER=translate
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:24
note the value of the variable MYSQL_DATABASE
Vytenis
@FDiskas
Nov 24 2015 12:24
hm My directory name is Translate first letter uppercase
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:26
You must use environment variables in mysql configuration: http://php.net/manual/pt_BR/function.getenv.php
Vytenis
@FDiskas
Nov 24 2015 12:26
hm, works, I changed port
$mysqli = new mysqli("dev.azk.io", "translate", "translate", "Translate_dev", 32768);
random port?
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:27
Else, you must export the environment variables: MYSQL_HOST and MYSQL_PORT
Vytenis
@FDiskas
Nov 24 2015 12:28
And miss that about export
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:29
Sorry, it is that still the PR with the improvements in the documentation has not yet been merged.
Vytenis
@FDiskas
Nov 24 2015 12:29
SO the problem there was only that I missed that export setting?
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:31
you are referring to previous problems with dev.azk.io?
Vytenis
@FDiskas
Nov 24 2015 12:31
yes
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:31
nope
Vytenis
@FDiskas
Nov 24 2015 12:31
sorry I don't get it
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:32
The previous problem was that the firewall is preventing the azk dns service.
Vytenis
@FDiskas
Nov 24 2015 12:33
The main problem was azukiapp/docker-mysql#2
Now you solved that some how. But I have more than one PC with fedora and the same version. How I could repeat that fix? :)
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:37
I will add the list commands in the issue, you can test in other machines to make sure it is correct?
Vytenis
@FDiskas
Nov 24 2015 12:38
thanks
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:39
the recommended would open an issue in azk, since the problem with him.
Because we need to add more tests in azk for fedora and, if possible, make a correction in the installation process so that this problem does not occur with other users.
Can you do me the favor of opening the issue in https://github.com/azukiapp/azk/issues/new ?
Vytenis
@FDiskas
Nov 24 2015 12:42
azukiapp/azk#569 ?
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:43
we need to describe the problem, but I put the list of commands now
Vytenis
@FDiskas
Nov 24 2015 12:43
I will add step by step procedure in that issue. I will try to reproduce the process then I got a different pc with fedora 23
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:44
good
Vytenis
@FDiskas
Nov 24 2015 12:44
clean pc only with docker installed
http://phpmyadmin.dev.azk.io/ that url I cant access - got a message
No Application Configured
This domain is not associated with an application.
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:47
the azk agent statement is running?
Vytenis
@FDiskas
Nov 24 2015 12:47
Agent is running...
$ azk status
┌───┬────────────┬───────────┬───────────────────────┬────────────────────────────┬─────────────┐
│   │ System     │ Instances │ Hostname/url          │ Instances-Ports            │ Provisioned │
├───┼────────────┼───────────┼───────────────────────┼────────────────────────────┼─────────────┤
│ ↑ │ mysql      │ 1         │ dev.azk.io1-data:32768               │ -           │
├───┼────────────┼───────────┼───────────────────────┼────────────────────────────┼─────────────┤
│ − │ phpmyadmin │ 0         │ phpmyadmin.dev.azk.io │ -                          │ -           │
├───┼────────────┼───────────┼───────────────────────┼────────────────────────────┼─────────────┤
│ ↑ │ web        │ 1         │ http://web.dev.azk.io │ 1-http:32770, 1-data:32769 │ -           │
│   │            │           │                       │                            │             │
└───┴────────────┴───────────┴───────────────────────┴────────────────────────────┴─────────────┘
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:48
phpmyadmin │ 0
phpmyadmin is not started
Vytenis
@FDiskas
Nov 24 2015 12:49
how to check the problems?
$ azk start phpmyadmin
azk: ↑ starting `phpmyadmin` system, 1 new instances...
azk: ✓ checking `reduto/phpmyadmin:latest` image...
azk: ◴ waiting for `phpmyadmin` system to start, trying connection to port http/tcp...

┌───┬────────────┬───────────┬──────────────────────────────┬─────────────────┬─────────────┐
│   │ System     │ Instances │ Hostname/url                 │ Instances-Ports │ Provisioned │
├───┼────────────┼───────────┼──────────────────────────────┼─────────────────┼─────────────┤
│ ↑ │ mysql      │ 1         │ dev.azk.io                   │ 1-data:32768    │ -           │
├───┼────────────┼───────────┼──────────────────────────────┼─────────────────┼─────────────┤
│ ↑ │ phpmyadmin │ 1         │ http://phpmyadmin.dev.azk.io │ 1-http:32771    │ -           │
└───┴────────────┴───────────┴──────────────────────────────┴─────────────────┴─────────────┘
[vytenis@191 Translate] $ azk start
azk: System `mysql` already started
azk: ↓ stopping `phpmyadmin` system, 1 instances...
azk: System `web` already started

┌───┬────────────┬───────────┬───────────────────────┬────────────────────────────┬─────────────┐
│   │ System     │ Instances │ Hostname/url          │ Instances-Ports            │ Provisioned │
├───┼────────────┼───────────┼───────────────────────┼────────────────────────────┼─────────────┤
│ ↑ │ web        │ 1         │ http://web.dev.azk.io │ 1-http:32770, 1-data:32769 │ -           │
│   │            │           │                       │                            │             │
├───┼────────────┼───────────┼───────────────────────┼────────────────────────────┼─────────────┤
│ − │ phpmyadmin │ 0         │ phpmyadmin.dev.azk.io │ -                          │ -           │
├───┼────────────┼───────────┼───────────────────────┼────────────────────────────┼─────────────┤
│ ↑ │ mysql      │ 1         │ dev.azk.io            │ 1-data:32768               │ -           │
└───┴────────────┴───────────┴───────────────────────┴────────────────────────────┴─────────────┘
If I start only the phpmyadmin - it works
And the phpmyadmin page works
Gullit Miranda
@gullitmiranda
Nov 24 2015 12:55
In your Azkfile, phpmyadmin is set to not scalable by default. So if you run only azk start it will not start.
you can run:
azk start web,phpmyadmin
Vytenis
@FDiskas
Nov 24 2015 12:57
whanks for the tip
Gullit Miranda
@gullitmiranda
Nov 24 2015 13:00
I finished the workaround. you can check if it's right?
https://github.com/azukiapp/azk/issues/569#issuecomment-159260217
Vytenis
@FDiskas
Nov 24 2015 20:42
Hi, got totaly different laptop with fedora and still some problems.
$ azk agent start
azk: Please wait, this process may take several minutes
azk: Loading settings and checking dependencies.
azk: Checking version...
azk: azk 0.16.2 detected
azk: Could not connect to the docker service.
azk: Check if docker service is running.
azk: Also check if you have write permission to socket: '/var/run/docker.sock'
```
$ azk doctor
azk: Error: Config docker:host to be set by configure
azk:     at Object.get (/azk:0.16.2/src/config.js:246:11)
azk:     at Object.module.exports.Object.defineProperties.default.get [as default] (/azk:0.16.2/src/docker/index.js:1:10)
azk:     at Doctor._createClass.get (/azk:0.16.2/src/cmds/doctor.js:13:33)
azk:     at Doctor.callee$2$0$ (/azk:0.16.2/src/cmds/doctor.js:30:82)
azk:     at tryCatch (/usr/lib/azk/node_modules/babel-runtime/regenerator/runtime.js:65:40)
azk:     at GeneratorFunctionPrototype.invoke [as _invoke] (/usr/lib/azk/node_modules/babel-runtime/regenerator/runtime.js:229:22)
azk:     at GeneratorFunctionPrototype.Gp.(anonymous function) [as next] (/usr/lib/azk/node_modules/babel-runtime/regenerator/runtime.js:262:19)
azk:     at GeneratorFunctionPrototype.tryCatcher (/usr/lib/azk/node_modules/bluebird/js/main/util.js:24:31)
azk:     at PromiseSpawn._next (/usr/lib/azk/node_modules/bluebird/js/main/generators.js:100:49)
azk:     at Promise._settlePromiseAt (/usr/lib/azk/node_modules/bluebird/js/main/promise.js:528:21)
azk:     at Promise._settlePromiseAtPostResolution (/usr/lib/azk/node_modules/bluebird/js/main/promise.js:224:10)
azk:     at Async._drainQueue (/usr/lib/azk/node_modules/bluebird/js/main/async.js:182:12)
azk:     at Async._drainQueues (/usr/lib/azk/node_modules/bluebird/js/main/async.js:187:10)
azk:     at Async.drainQueues (/usr/lib/azk/node_modules/bluebird/js/main/async.js:15:14)
azk:     at process._tickCallback (node.js:448:13)
azk:     at Function.Module.runMain (module.js:499:11)
Felipe Arenales Santos
@fearenales
Nov 24 2015 20:44
@FDiskas may you run docker version, please?
Vytenis
@FDiskas
Nov 24 2015 20:45
$ docker version
Client:
 Version:      1.9.1
 API version:  1.21
 Go version:   go1.4.2
 Git commit:   a34a1d5
 Built:        Fri Nov 20 13:34:39 UTC 2015
 OS/Arch:      linux/amd64
Cannot connect to the Docker daemon. Is the docker daemon running on this host?
Felipe Arenales Santos
@fearenales
Nov 24 2015 20:45
did you just installed azk? It's a good idea logout and login back in order to make group settings to take effect..
Vytenis
@FDiskas
Nov 24 2015 20:46
ok
Vytenis
@FDiskas
Nov 24 2015 20:51
looks like works
thanks again
Felipe Arenales Santos
@fearenales
Nov 24 2015 20:51
great! :)
you're welcome!
Vytenis
@FDiskas
Nov 24 2015 20:52
SELinux is preventing esmtp from read access on the file /.esmtp_queue/haNhWsor/mail. and so on. Is this your script is trying to access some sensitive data or functionality?
azk: ✓ completed download of `azukiapp/mysql:5.7`

azk: ◴ waiting for `mysql` system to start, trying connection to port data/tcp...
azk: Run system `mysql` return: (0), for command: ["/azk-entrypoint.sh","mysqld"]:
azk: [timeout] `azk` has timed out on `mysql` system.
azk: [timeout] Failure to reach port `32768` from `http://dev.azk.io` after 25000 milliseconds.
azk: [timeout] Make sure the start command binds `port` to the `0.0.0.0` interface, not only to the `localhost` interface.
azk: [timeout] You might want to edit your `Azkfile.js` in order to increase the maximum timeout.

azk: Look for azk start troubleshooting documentation for more info at: http://bit.ly/azk_start_troubleshooting

azk: Due to the above error azk will stop all instances already running.

azk: System `web` not running
azk: System `phpmyadmin` not running
azk: ↓ stopping `mysql` system, 1 instances...
Felipe Arenales Santos
@fearenales
Nov 24 2015 21:04
@FDiskas this is weird... give me some minutes, please.
Vytenis
@FDiskas
Nov 24 2015 21:41
strange started it again and its working
Felipe Arenales Santos
@fearenales
Nov 24 2015 21:42
didn't that message pop up again?
Vytenis
@FDiskas
Nov 24 2015 21:45
nope
maybe some sort of timeout?
Felipe Arenales Santos
@fearenales
Nov 24 2015 21:53
not sure, 25000 ms sounds like a lot of time to mysql startup
Vytenis
@FDiskas
Nov 24 2015 21:54
again can't connect to mysql
Trying do exactly the same as previews solution
Installed "Fedy" and traying to set "SELinux to permisssive mode.