These are chat archives for azukiapp/azk

10th
Mar 2016
Failed to load resource: the server responded with a status of 403 (Forbidden)
for all the readme files
Marcus Gadbem
@marcusgadbem
Mar 10 2016 13:02
Hi @cj. Imagens site runs relying completely on GitHub's API which has a very low requests rate for unauthtenticated requests. Unfortunatly you need to wait a bit. :/ We are looking forward to make this better.
CJ Lazell
@cj
Mar 10 2016 16:55
doh :(
question, I'm getting this while running bundler /usr/local/lib/ruby/gems/2.2.0/gems/bundler-1.11.2/lib/bundler/ui/shell.rb:98:in `[]': invalid byte sequence in US-ASCII (ArgumentError)
you can set the ENV vars directly to change it to UTF8
dang, can't find the article... there was a way with docker settings to force it to UTF8, but I wasn't sure how to do that with azk
CJ Lazell
@cj
Mar 10 2016 17:12
nice setting it to C.UTF-8 fixes it... man that's random it's not that by default
Julio Makdisse Saito
@saitodisse
Mar 10 2016 18:04
Very good @cj. Are you saying that LANG : '' and LC_ALL should be set by default on ruby:2.2.4 docker image?
CJ Lazell
@cj
Mar 10 2016 18:15
yee, to C.UTF-8
Julio Makdisse Saito
@saitodisse
Mar 10 2016 18:40
indeed, this should be default.
Julio Makdisse Saito
@saitodisse
Mar 10 2016 18:57
@cj, if you use our image you get this ENVs by default: https://github.com/azukiapp/docker-ubuntu/blob/master/trusty/Dockerfile#L19-L23
azukiapp/ruby
CJ Lazell
@cj
Mar 10 2016 19:34
@saitodisse I would, but I needed ruby 2.2.4 :)
I'm going to be making my own images anyway... I just found it strange that the official ruby ones didn't do this
Julio Makdisse Saito
@saitodisse
Mar 10 2016 20:18
@cj :+1:
Gullit Miranda
@gullitmiranda
Mar 10 2016 20:36
@cj you can also use Dockerfilein Azkfile
CJ Lazell
@cj
Mar 10 2016 20:40
thank you. good to know. I'll probably just use docker to host the image so it's a quicker install
Gullit Miranda
@gullitmiranda
Mar 10 2016 20:42
yep
CJ Lazell
@cj
Mar 10 2016 20:42
we have about 3 different apps, 2 ruby, 1 php using mysql, redis and memcache. my goal is to use ack and ngrok so with a single command you can have the whole stack running locally
I have that using compose, using nginix. the only issue is you have to setup the vhosts etc..
Gullit Miranda
@gullitmiranda
Mar 10 2016 20:43
I understand
will be beautiful to run everything with a single command =D
CJ Lazell
@cj
Mar 10 2016 20:46
yee, I'm trying to get everyone using the same dev enviorment and make it easier for new hires to get up and running
Gullit Miranda
@gullitmiranda
Mar 10 2016 20:47
:clap:
Slobodan Mišković
@slobo
Mar 10 2016 21:08
hey folks, trying to get sync running, since it seems that on OSX my file change notifications aren't propagating to the container. But sync seems to be hanging when after first agent start. So i Ctrl+C, and tried azk restart for system in question and then sync went trough, but seems to be stuck with stale copy of data
    mounts: {
      '/azk/react-ui': sync("./react-ui", {}),
      '/azk/react-ui/node_modules': persistent("./react-ui/node_modules"),
    },
so i restarted agent again, tried system start, and... it seems stuck again
Felipe Arenales Santos
@fearenales
Mar 10 2016 21:12
@slobo can you restart agent using: azk agent start --no-daemon --log=debug, please?
Slobodan Mišković
@slobo
Mar 10 2016 21:13
sure thing, just a sec
ok, last line is hipache..., should i try azk start again?
i did azk start and it's stuck again, here's the agent log:
https://gist.github.com/slobo/509256dd40c1e99fbd88
Felipe Arenales Santos
@fearenales
Mar 10 2016 21:26
@slobo : ps -ef | grep sync
Slobodan Mišković
@slobo
Mar 10 2016 21:27
on the host or in the vm?
Felipe Arenales Santos
@fearenales
Mar 10 2016 21:27
this is the origin folder, right? /Users/slobo/Documents/project/project-ng/react-ui
on the host
Slobodan Mišković
@slobo
Mar 10 2016 21:28
Azkfile is in /Users/slobo/Documents/project/project-ng
and i want to sync .../react-ui
  501 23567 23442   0  1:28pm ttys006    0:00.34 azk sync worker /Users/slobo/Documents/project/project-ng/react-ui /mnt/sda1/azk/sync_folders/d3a450 AZK_AGENT_CONF_FILE=/Users/slobo/.azk/data/run/agent.json
Felipe Arenales Santos
@fearenales
Mar 10 2016 21:30
ok, change one file from this dir (.../react-ui) and check the agent logs, please
Slobodan Mišković
@slobo
Mar 10 2016 21:30
(btw, "project/project-ng" is actually anonymized, so hash might not match what's the real thing)
Felipe Arenales Santos
@fearenales
Mar 10 2016 21:31
no worries
Slobodan Mišković
@slobo
Mar 10 2016 21:32
nothing in agent, just the memory monitor stuff
i tried: touch new-file, echo > existing-file, saving a small change from editor
btw, azk start react-ui is still stuck on syncing
Felipe Arenales Santos
@fearenales
Mar 10 2016 21:33
is react-ui a different git repository with its own .gitignore file?
Slobodan Mišković
@slobo
Mar 10 2016 21:34
no .gitignore in there
it's in the master repo
i mean repo base is same where Azkfile is
Felipe Arenales Santos
@fearenales
Mar 10 2016 21:35
ok
Slobodan Mišković
@slobo
Mar 10 2016 21:35
do you source .gitignore,
Felipe Arenales Santos
@fearenales
Mar 10 2016 21:35
give me a minute, please?
Slobodan Mišković
@slobo
Mar 10 2016 21:35
sure, thanks for your help!
Felipe Arenales Santos
@fearenales
Mar 10 2016 21:36
how is your .gitignore? Ignored files in .gitignore (or .syncignore if it exists) aren't synced (just to be sure you know that)
Slobodan Mišković
@slobo
Mar 10 2016 21:40
i have react-ui/node_modules in .gitignore
in the project root
but i think it's not normal for sync to still be stuck, and system doesn't even start?
Felipe Arenales Santos
@fearenales
Mar 10 2016 21:40
yes, that's odd
may you run azk shell -c "env | grep MID" ?
then azk vm ssh
cd /mnt/sda1/azk/data/sync_folders/<MID>
Slobodan Mišković
@slobo
Mar 10 2016 21:51
no such folder, but there is: /mnt/sda1/azk/sync_folders/d3a4508ee4
Felipe Arenales Santos
@fearenales
Mar 10 2016 21:51
ops, my bad
Slobodan Mišković
@slobo
Mar 10 2016 21:51
(there is no data in the path)
Felipe Arenales Santos
@fearenales
Mar 10 2016 21:51
which files are in this folder?
Slobodan Mišković
@slobo
Mar 10 2016 21:52
files start in /mnt/sda1/azk/sync_folders/d3a4508ee4/react-ui/Users/slobo/Documents/project/project-ng/react-ui
Felipe Arenales Santos
@fearenales
Mar 10 2016 21:52
yes, that's right
and those files are correct?
Slobodan Mišković
@slobo
Mar 10 2016 21:53
looks to be the one's from real folder, but i think they may be stale
like, it's missing the edits i tried to make
Felipe Arenales Santos
@fearenales
Mar 10 2016 21:56
hmm.. one moment
Felipe Arenales Santos
@fearenales
Mar 10 2016 22:07
looks like the first sync is being concluded but the watcher is failing to be spawned...
Slobodan Mišković
@slobo
Mar 10 2016 22:08
btw, i think i tried similar thing last year with another folder, i still see the leftover dir in /mnt/sda1/azk/sync_folders/d3a4508ee4