These are chat archives for azukiapp/azk

28th
Mar 2016
Dr Kim Foale
@kimadactyl
Mar 28 2016 11:03
ook about to get going on this
hmm. i think im not quite clear how i should develop on this and what environment goes where. should i be doing my dev within the azk shell now? feel like idprefer to stick with my existing toolkit and just use azk for deploy
ssh key shouldn't have a password. i followed the instructions on the digital ocean tutorial using an API key. it used to work, now doesn't.hmm
the mount thing im shaky on tho, do you mean the ssh agent?
Dr Kim Foale
@kimadactyl
Mar 28 2016 11:45
and weird.im now getting this after a restart. cant figure out whats changed for the life of me. tried a bunch of old branches, no luck
azk: ↓ stopping `postgres` system, 1 instances...
azk: Run system `taichi-school` return: (1), for command: ["bundle","exec","rails","server","--pid","/tmp/rails.pid","--port=3000","--binding=0.0.0.0"]:
azk:  .taichi-school [log] >  => Booting Puma
azk:  .taichi-school [log] >  => Rails 4.2.6 application starting in development on http://0.0.0.0:3000
azk:  .taichi-school [log] >  => Run `rails server -h` for more startup options
azk:  .taichi-school [log] >  => Ctrl-C to shutdown server
azk:  .taichi-school [log] >  Exiting
azk:  .taichi-school [log] >  /azk/bundler/ruby/2.3.0/gems/railties-4.2.6/lib/rails/application/configuration.rb:115:in `rescue in database_configuration': YAML syntax error occurred while parsing /azk/taichi_rails/config/database.yml. Please note that YAML must be consistently indented using spaces. Tabs are not allowed. Error: (<unknown>): could not find expected ':' while scanning a simple key at line 11 column 1 (RuntimeError)
grrrrrrrrrrrrrrr
not changed that database file, not sure whats going on
Dr Kim Foale
@kimadactyl
Mar 28 2016 11:59
pretty sure for some reason its not executing the erb now
Dr Kim Foale
@kimadactyl
Mar 28 2016 12:10
yup im totally bewildered. gonna make lunch will check back soon. current azkfile https://gist.github.com/kimadactyl/098d87c0a8abedf1bfa1
Dr Kim Foale
@kimadactyl
Mar 28 2016 12:30
yeah idk whats going on, gone back a fair way and same problem
uffff
Dr Kim Foale
@kimadactyl
Mar 28 2016 13:20
you around today @gullitmiranda ? :)
Lucas Gertel
@lgertel
Mar 28 2016 13:25
Possible to use azk with private repos on Github?
Dr Kim Foale
@kimadactyl
Mar 28 2016 13:31
what do you mean?azk doesnt really care about where you store things :)
Dr Kim Foale
@kimadactyl
Mar 28 2016 14:32
oh man i tried a purge as this makes zero sense and now everything messing up :( ill wiat for you to be back
Gullit Miranda
@gullitmiranda
Mar 28 2016 15:21
hi @kimadactyl. I'm back =D
I'm going to review everything that you sent.
Gullit Miranda
@gullitmiranda
Mar 28 2016 15:29
@kimadactyl I need to see your file config/database.yml
about the JS. you are having doubt about the flow of development?
if yes, tell me how you do today so that I can better target
Gullit Miranda
@gullitmiranda
Mar 28 2016 15:35
sorry for delay. I spent the weekend to give attention to the my mistress (girlfriend), it was time that he did not have this. :(
@lgertel as @kimadactyl spoke, for the azk does not matter much where you save your files. You are referring to the run project (http://run.azk.io)?
if yes, we do not work on top of this, but from the initial tests, if you have authenticated it will work, after all the azk uses git to do the pull.
Dr Kim Foale
@kimadactyl
Mar 28 2016 17:13
dont worry at all :) my database.yml is exactly the same as the linked one. i wasnt paying attention (started a game of civ, oops :D ) back in like 2-3 hours if you are still up, if not here tomorrow. thanks :)
Lucas Gertel
@lgertel
Mar 28 2016 17:26

azk: ⎘ syncing files for 3599-jones system...
azk: ◴ waiting for 3599-jones system to start, trying connection to port http/tcp...
azk: An error occurred. It will stop all instances already running. See details below.

azk: System 3599-jones not running
azk: Run system 3599-jones return: (1), for command: ["bundle","exec","rackup","config.ru","--pid","/tmp/ruby.pid","--port","$HTTP_PORT","--host","0.0.0.0"]:
azk: .3599-jones [log] > [2016-03-28 17:17:50] INFO WEBrick 1.3.1
azk: .3599-jones [log] > [2016-03-28 17:17:50] INFO ruby 2.3.0 (2015-12-25) [x86_64-linux]
azk: .3599-jones [log] > /usr/local/lib/ruby/2.3.0/socket.rb:231:in `getaddrinfo': getaddrinfo: Servname not supported for ai_socktype (SocketError)

It’s a rails stack without db

Nothing too much complicated
Gullit Miranda
@gullitmiranda
Mar 28 2016 18:05
should I be here when you get back @kimadactyl. but I recommend taking a look if your editor converted the space by tab
if note, trye debug values in https://gist.github.com/gullitmiranda/62082f2e47c364ef9617#file-database-yml-L16
like this:
def attribute(name, value, force_string = false)
  puts "#{name}=#{value}"
  # ...
end
Gullit Miranda
@gullitmiranda
Mar 28 2016 18:11
@lgertel see this:
:point_up: 25 de Março de 2016 11:39