These are chat archives for azukiapp/azk

31st
Mar 2016
Slobodan Mišković
@slobo
Mar 31 2016 01:42
hey folks, is there --color for when I want to force azk to print pretty colors even on non-interactive sessions? I made my jenkins logs prettier when it used to do that :)
Gullit Miranda
@gullitmiranda
Mar 31 2016 01:45
no @slobo
you need use --tty and/or check TERM env
Slobodan Mišković
@slobo
Mar 31 2016 02:26
which TERM is supported?
Gullit Miranda
@gullitmiranda
Mar 31 2016 02:30
i use TERM=xterm-256color
Slobodan Mišković
@slobo
Mar 31 2016 02:30
ok, I'll try that and see if colours come back :)
Slobodan Mišković
@slobo
Mar 31 2016 02:44
just setting TERM didn't work, and azk restart dosen't take --tty
Gullit Miranda
@gullitmiranda
Mar 31 2016 03:31
you add in section envs in your Azkfile systems?
Slobodan Mišković
@slobo
Mar 31 2016 03:36
sorry, didn't make myself clear:
i like how azk outputs colours when run interactively, say azk status shows green vs red vs yellow based on system status. But if I run it inside jenkins, with 0.17 (and maybe earlier) it no longer outputs those colors.
Gullit Miranda
@gullitmiranda
Mar 31 2016 03:47
hm
try add env FORCE_COLOR to jenkins
https://github.com/chalk/supports-color#info
Slobodan Mišković
@slobo
Mar 31 2016 04:04
that's what i'm looking for, thanks!
Dr Kim Foale
@kimadactyl
Mar 31 2016 10:15
allow_ssl_in_production is for earlier versions of spree and errors out: I have force_ssl=false in my production.rb. Maybe that's not getting read properly though? Hmmmm
Re the port thing @lgertel, it's a problem with the agent itself clashing with apache, not the individual worker. Its fine tho I can just disable apache :)
yes I think that's what's going on.my live server keepsloading in development mode. hmmmmm.
Vytenis
@FDiskas
Mar 31 2016 10:27
hello,
any news about wrong permissions?
#100
Vytenis
@FDiskas
Mar 31 2016 11:17
azk shell
then I install something like gulp and later enter azk shell again then there is no gulp any more
Dr Kim Foale
@kimadactyl
Mar 31 2016 11:26
yeah i mean azk shell syncs from your local setup no?
Vytenis
@FDiskas
Mar 31 2016 11:28
I think that there is mirror created
docker ps -a increased size of containers
Dr Kim Foale
@kimadactyl
Mar 31 2016 11:34

OK yeah there's a problem with exporting env variables unless i have something wrong. Getting this in the azk deploy full log

TASK [envs : Adding env vars into $HOME/.env] **********************************
ok: [default] => (item={u'key': u'HOST_IP', u'value': u'188.166.147.183'})
ok: [default] => (item={u'key': u'HOST_DOMAIN', u'value': u'beta.taichi.school'})
ok: [default] => (item={u'key': u'AZK_AGENT_START_COMMAND', u'value': u'azk agent start'})
ok: [default] => (item={u'key': u'AZK_RESTART_COMMAND', u'value': u'azk restart -Rvv'})
ok: [default] => (item={u'key': u'GIT_REF', u'value': u'add-azk'})

But my config...

  deploy: {
    image: { docker: 'azukiapp/deploy-digitalocean' },
    mounts: {
     '/azk/deploy/src':     path('.'),
     '/azk/deploy/.ssh':    path('#{env.HOME}/.ssh'), // Required to connect with the remote server
     '/azk/deploy/.config': persistent('deploy-config')
    },

    // This is not a server. Just run it with `azk deploy`
    scalable: { default: 0, limit: 0 },

    envs: {
     // List with all available deployment settings:
     // https://github.com/azukiapp/docker-deploy-digitalocean/blob/master/README.md
     GIT_REF: 'add-azk',
     AZK_RESTART_COMMAND: 'azk restart -Rvv',
     BOX_REGION: 'lon1',
     BOX_NAME: 'taichi-school-azk',
     HOST_DOMAIN: 'beta.taichi.school',
     RAILS_ENV: "production",
     RACK_ENV: "production",
   },

   export_envs: {
     RAILS_ENV: "production",
     RACK_ENV: "production",
   },
so presumably there's whitelisted variables somewhere?
Dr Kim Foale
@kimadactyl
Mar 31 2016 11:43
Oh.my god. I had it set to development in my .env file :fire:
All that time, oh man
why is there no :facepalm: lol
Vytenis
@FDiskas
Mar 31 2016 14:22
Please check this azukiapp/azk#100
I have a solution for the mermission issue. Could someone integrate this to azk?
Gullit Miranda
@gullitmiranda
Mar 31 2016 20:43
@FDiskas the development of the azk is a little stalled at the moment because we took a break to review all the backlog. As soon as that is finalized we will announce in some way.
the solution that you proposed is a workaround. In the new versions of docker they have a feature in the test phase that promises to solve this problem.
in Azkfile you can use the option docker_extra to set the User, like docker exec -u 1000. Including the @slobo already commented on this another time.
Gullit Miranda
@gullitmiranda
Mar 31 2016 20:52
about gulp in azk shell, if you run the npm install gulp in the project folder, it should have been persisted within the folder node_modules.
i can see your Azkfile?