Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Gullit Miranda
    @gullitmiranda
    this is another feature: shee azukiapp/azk#568
    =D
    mimafogeus2
    @mimafogeus2

    Hi

    I'm working with azk v. 0.16.3.
    When I'm starting/reprovisioning, when it tries to sync, this happens:
    azk: ⎘ syncing files for `backoffice` system...
    azk: TypeError: Object #<Object> has no method 'join'
    azk:     at I18n._resolveKey (/i18n-cli:0.0.2/src/index.js:88:60)
    azk:     at I18n.translate (/i18n-cli:0.0.2/src/index.js:44:39)
    azk:     at I18n.t (/i18n-cli:0.0.2/src/index.js:23:28)
    azk:     at Object._status (/azk:0.16.3/src/cli/ui.js:1:14)
    azk:     at Object.fail (/azk:0.16.3/src/cli/ui.js:61:36)
    azk:     at /azk:0.16.3/src/cmds/start.js:103:15
    azk:     at tryCatcher (/usr/local/Cellar/azk/0.16.3/node_modules/bluebird/js/main/util.js:24:31)
    azk:     at Promise._settlePromiseFromHandler (/usr/local/Cellar/azk/0.16.3/node_modules/bluebird/js/main/promise.js:454:31)
    azk:     at Promise._settlePromiseAt (/usr/local/Cellar/azk/0.16.3/node_modules/bluebird/js/main/promise.js:530:18)
    azk:     at Promise._settlePromises (/usr/local/Cellar/azk/0.16.3/node_modules/bluebird/js/main/promise.js:646:14)
    azk:     at Async._drainQueue (/usr/local/Cellar/azk/0.16.3/node_modules/bluebird/js/main/async.js:177:16)
    azk:     at Async._drainQueues (/usr/local/Cellar/azk/0.16.3/node_modules/bluebird/js/main/async.js:187:10)
    azk:     at Async.drainQueues (/usr/local/Cellar/azk/0.16.3/node_modules/bluebird/js/main/async.js:15:14)
    azk:     at process._tickCallback (node.js:448:13)

    What am I missing?
    Thanks!

    Gullit Miranda
    @gullitmiranda
    hi @mimafogeus2 I can see your Azkfile?
    Saito
    @saitodisse
    @fearenales @Bartekus has a problem configuring his meatier deploy. Could you help him?
    Bartek Kus
    @bartekus
    Are you thinking of adding lifecycles to azk, the reason what I’m asking is that I find that I can trigger a postinstall npm script during provisioning which is grand, as it hydrates database and compiles basic structure… However once I stop azk, my database state is currently purged and so when I restart azk that system is already provisioned yet the db state is lost so the app will be in limbo. It would perhaps be good to either add bootup command to db, or to the system or to both. What do you guys think… alternativly this functionality could be provided by third-party modules, but given that npm community has not yet comme up with solid standard, or perhaps I’m ignorant of one, that leave you guys to potentially innovate in that aspect. I’m not sure what you guys think of it, but perhaps maybe having provisioning being simply triggered on every bootup would solve the issue, I dont know, I have’t though it thru enough to propose that as a solution but something along this lines would be very welcome addition.
    Saito
    @saitodisse
    I believe you can @Bartekus, just copy/paste this question to an Issue. @nuxlli have a plan about this for the future os azk and they will be able to make a proper response. :)
    Bartek Kus
    @bartekus
    ok, awesome, thank you @saitodisse :D
    Slobodan Mišković
    @slobo

    hey folks. we are having issues on Arch linux with

          Version : 0.17.0
          Docker  : 1.10.1
          Kernel   : 4.4.1
          Systemd: 229

    We have a 23 systems in this one Azkfile, and while the host system and ulimit don't show anything that indicates we should be running out of resources, we invariably get failures before all systems are up. Messages differ at times (depending on order we try to start systems), but they all have in common that either a thread or process couldn't be started, sometimes "out of memory", sometimes just "resource temporarily unavailable". Nothing in journalctl shows any clue as to a potential limit or resource we are exhausting.
    Tried downgrading kernel back to 4.3, docker to 1.9 and 1.8, and basically the same behaviour.
    All this worked about a month or so ago, when systemd was 228. I'm about to try downgrading that too, but was wondering if you guys had any tips or tricks how to debug exactly what is failing.

    (also, tried with azk 16.3, same thing)
    Slobodan Mišković
    @slobo
    I just checked and going down to systemd 228 same problem, but going down to 227 it seemed to have worked. Now, on systemd 227 it wouldn't start my graphics for whatever reason, so perhaps not having those drivers loaded made a difference, but seems unlikely.
    Slobodan Mišković
    @slobo
    ok, i think i'm onto something, seems systemd has DefaultTasksMax=512, and looking at systemd-cgtop i'm at 512 with docker service when it starts failing
    Slobodan Mišković
    @slobo
    for anyone else running into this problem I did sudo systemctl edit docker and put this in there:
    [Service]
    TasksMax=infinity
    Gullit Miranda
    @gullitmiranda
    hi @slobo, sorry for delay.
    that's good that you found the solution. I believe it is very important to have an issue for this and even a PR with troubleshooting. Could you help us with this?
    Danni Friedland
    @BlueHotDog
    hi guys
    i'm keep getting server error - Driver aufs failed to remove root filesystem
    azk: Error: HTTP code is 500 which indicates error: server error - Driver aufs failed to remove root filesystem 93a1416bcffd4e1e3d6cb00e32b62775a6a4939a4cb46860dcb3a0102fab4e23: rename /mnt/sda1/aufs/mnt/93a1416bcffd4e1e3d6cb00e32b62775a6a4939a4cb46860dcb3a0102fab4e23 /mnt/sda1/aufs/mnt/93a1416bcffd4e1e3d6cb00e32b62775a6a4939a4cb46860dcb3a0102fab4e23-removing: device or resource busy
    Danni Friedland
    @BlueHotDog
    :(
    Gullit Miranda
    @gullitmiranda
    what docker version?
    Danni Friedland
    @BlueHotDog
    hmm, i've installed the latest azk
    wait, let me check
    Docker version 1.9.1, build a34a1d5
    Gullit Miranda
    @gullitmiranda
    run adocker ps -a
    and you use linux or mac?
    Danni Friedland
    @BlueHotDog
    mac
    Felipe Arenales Santos
    @fearenales
    @BlueHotDog which command did you try to run?
    Danni Friedland
    @BlueHotDog
    just a azk start [service]
    but i've run docker cleanup script, and things are beginning to be better
    Felipe Arenales Santos
    @fearenales
    was it working before? and whats happening now?
    Danni Friedland
    @BlueHotDog
    nope, same issue again now
    it was working before the upgrade to 1.7
    now it's back to the same issue :(
    Felipe Arenales Santos
    @fearenales
    ok.. try to restart the azk agent and then start your app:
    azk agent stop
    azk agent start
    azk start [service]
    Danni Friedland
    @BlueHotDog
    did
    also hard restarted the machine
    what is the easiest way to uninstall/reinstall azk?
    Felipe Arenales Santos
    @fearenales
    I don't think this is the best solution.. give me a second, please?
    what's the result of adocker ps -a ?
    Danni Friedland
    @BlueHotDog
    CONTAINER ID        IMAGE                                                                     COMMAND                  CREATED             STATUS                      PORTS                             NAMES
    d58d11308bf5        azukiapp/azktcl:0.0.2                                                     "/bin/bash -c 'mkdir "   9 minutes ago       Dead
    cb1869fa7ed4        azkbuild/92478fbc17-backoffice:d47582d7f4db506e620de0f8993fe5f398431e55   "/bin/sh -c ../node_m"   35 minutes ago      Exited (1) 10 minutes ago                                     dev.azk.io_type.daemon_mid.92478fbc17_sys.backoffice_seq.1_uid.0e4bb800db
    ff015d953781        meltwater/docker-cleanup:latest                                           "/run.sh"                42 minutes ago      Exited (1) 41 minutes ago                                     compassionate_saha
    117ade0f2841        azukiapp/azktcl:0.0.2                                                     "/bin/sh -c 'env; soc"   About an hour ago   Up About an hour            53/udp, 192.168.51.4:80->80/tcp   dev.azk.io_type.daemon_mid.3591b9c247_sys.balancer-redirect_seq.1_uid.a29d4a10db
    4e8f35f083d0        azukiapp/azktcl:0.0.2                                                     "/bin/sh -c 'dnsmasq "   About an hour ago   Up About an hour            192.168.51.4:53->53/udp, 80/tcp   dev.azk.io_type.daemon_mid.3591b9c247_sys.dns_seq.1_uid.a2150740db
    Felipe Arenales Santos
    @fearenales
    please run adocker rm d58d11308bf5 cb1869fa7ed4 ff015d953781
    and then adocker ps -a
    Danni Friedland
    @BlueHotDog
    CONTAINER ID        IMAGE                   COMMAND                  CREATED             STATUS              PORTS                             NAMES
    117ade0f2841        azukiapp/azktcl:0.0.2   "/bin/sh -c 'env; soc"   About an hour ago   Up About an hour    53/udp, 192.168.51.4:80->80/tcp   dev.azk.io_type.daemon_mid.3591b9c247_sys.balancer-redirect_seq.1_uid.a29d4a10db
    4e8f35f083d0        azukiapp/azktcl:0.0.2   "/bin/sh -c 'dnsmasq "   About an hour ago   Up About an hour    192.168.51.4:53->53/udp, 80/tcp   dev.azk.io_type.daemon_mid.3591b9c247_sys.dns_seq.1_uid.a2150740db
    Danni Friedland
    @BlueHotDog
    any idea?
    Felipe Arenales Santos
    @fearenales
    ok, so now restart the agent once again and try to start the service
    Danni Friedland
    @BlueHotDog
    cool
    i've to go to sleep now
    but will do this tomorrow
    Felipe Arenales Santos
    @fearenales
    ok! please let us know if that works!
    Danni Friedland
    @BlueHotDog
    hey
    still the same issue :(