Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Danni Friedland
    @BlueHotDog
    CONTAINER ID        IMAGE                   COMMAND                  CREATED             STATUS              PORTS                             NAMES
    117ade0f2841        azukiapp/azktcl:0.0.2   "/bin/sh -c 'env; soc"   About an hour ago   Up About an hour    53/udp, 192.168.51.4:80->80/tcp   dev.azk.io_type.daemon_mid.3591b9c247_sys.balancer-redirect_seq.1_uid.a29d4a10db
    4e8f35f083d0        azukiapp/azktcl:0.0.2   "/bin/sh -c 'dnsmasq "   About an hour ago   Up About an hour    192.168.51.4:53->53/udp, 80/tcp   dev.azk.io_type.daemon_mid.3591b9c247_sys.dns_seq.1_uid.a2150740db
    Danni Friedland
    @BlueHotDog
    any idea?
    Felipe Arenales Santos
    @fearenales
    ok, so now restart the agent once again and try to start the service
    Danni Friedland
    @BlueHotDog
    cool
    i've to go to sleep now
    but will do this tomorrow
    Felipe Arenales Santos
    @fearenales
    ok! please let us know if that works!
    Danni Friedland
    @BlueHotDog
    hey
    still the same issue :(
    i cannot work and really need to..
    Gullit Miranda
    @gullitmiranda
    hi @BlueHotDog
    strange how through the adocker he is able to remove, and running with azk not.
    run adocker ps -a again
    Willian Fernandes
    @willian
    Does anyone know why I'm getting this error?
    azk: System `mysql` not running
    azk: Run system `mysql` return: (1), for command: ["/azk-entrypoint.sh","mysqld"]:
    azk:  .mysql [log] >  error: database is uninitialized and MYSQL_ROOT_PASSWORD not set
    azk:  .mysql [log] >    Did you forget to add -e MYSQL_ROOT_PASSWORD=... ?
    azk:  .mysql [log] >
    
    azk: Look for azk start troubleshooting documentation for more info at: http://bit.ly/azk_start_troubleshooting
    @gullitmiranda @nuxlli ^
    Gullit Miranda
    @gullitmiranda
    hi @willian. the env MYSQL_ROOT_PASSWORD is present in your Azkfile?
    the mysql image was updated some time
    but I saw that the suggestion is out of date. sorry, my falt :(
    Slobodan Mišković
    @slobo
    hey folks, do you ever experience DNS requests for dev.azk.io failing? It happens to me on both OSX and Linux occasionally.
    failed: could not translate host name "dev.azk.io" to address: Name or service not known
    (error message is from our testsuite, it occasionally pops up in the middle of running, as if dns server fails to respond or something)
    Bartek Kus
    @bartekus
    for me that happens when I don’t have internet connectivity or all my wireless/ethernet adapters are in off state
    Slobodan Mišković
    @slobo
    good point, sometimes on this laptop wifi flakes out... I'll keep an eye out if it's directly correlated
    Willian Fernandes
    @willian
    Thanks @gullitmiranda
    Felipe Arenales Santos
    @fearenales
    hey @slobo ! any news about the issue w/ DNS resolution?
    Everton Ribeiro
    @nuxlli
    @slobo and @Bartekus, we are chasing a solution to this problem, but we could not test enough to have an answer, you can follow more about it in this issue: azukiapp/azk#446
    Slobodan Mišković
    @slobo
    i'll keep an eye on that ticket, thanks
    now, i could have sworn this was working prior to 0.17, but on OSX (i.e. running in a vm), does file change notification not fire with path()?
    Felipe Arenales Santos
    @fearenales
    @slobo Yes, it does. There was no change on it for azk v0.17.0... Maybe you could try restarting the azk agent?
    Ricardo Quintanilha
    @quintanilhar
    This message was deleted
    This message was deleted
    Danni Friedland
    @BlueHotDog
    Hi guys
    i'm experiencing a weird issue with azk+nodejs
    if i do a full rebuild of all my services(about 10) it usually fails(and shutsdown them as well)
    but if i run them 1 by 1, everything goes well(usually)
    Bartek Kus
    @bartekus
    probably your wait time is too short and the whole things timesout
    maybe try like: wait: {"retry": 2, "timeout": 50000},
    Danni Friedland
    @BlueHotDog
    tried.. the actual build fails on npm install
    npm + docker is fragile in my experience
    my question is, how can i run the start/restart --rebuild one by one
    my shell powers are weak
    Bartek Kus
    @bartekus
    you can do azk start <systemName> individualy, and also azk shell <systemName> — npm run <npmScriptName> //or any other cmd line command
    Danni Friedland
    @BlueHotDog
    yeah, but if i've 10 systems it's quite a labor
    Danni Friedland
    @BlueHotDog
    azk status --text | tr -s ' ' | cut -d ' ' -f 2 | tail -n+2 | azk start $1
    is the trick
    Marcus Gadbem
    @marcusgadbem
    Cool :) I was just trying to accomplish that using grep
    Danni Friedland
    @BlueHotDog
    :)
    Felipe Arenales Santos
    @fearenales
    @BlueHotDog that's odd.. It shouldn't be an issue to start all systems with an azk start.
    May I take a look in your Azkfile?
    Slobodan Mišković
    @slobo
    @fearenales: just had a chance to reboot the entire machine, but no luck. To clarify, i'm referring to stuff like inotify in the containers noticing the change on the host os files mounted with path(). Or is this one of the issues with VBOXSF?