Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Dr Kim Foale
    @kimadactyl
    ok
    just take out the port? seems needed
    Gullit Miranda
    @gullitmiranda
    one moment
    Dr Kim Foale
    @kimadactyl
    thanks for the help, no hurry :)
    oh if i just do it with bundle, exec, rails, s it loads but cant seem to access it hmmm
    Gullit Miranda
    @gullitmiranda
    I am installing the rails in a container to catch the correct options. some time ago, that does not program in rails, so I do not remember.
    Dr Kim Foale
    @kimadactyl
    no worries :)
    Gullit Miranda
    @gullitmiranda
    but for that you can better understand. the two required options are:
    port: $HTTP_PORT (defined in Azkfile or auto)
    binding: 0.0.0.0 to allow the application to be accessed outside of the container (apart from `127.0.0.1, tha is default)
    Dr Kim Foale
    @kimadactyl
    hum. if i start it without those settings it greens up and looks like it's loaded but won't let me access it
    but if i add the settings it crashes on the line
    same with this one azk: Run system `taichi-school` return: (1), for command: ["bundle","exec","rackup","config.ru","--pid","/tmp/ruby.pid","--port","$HTTP_PORT","--host","0.0.0.0"]:
    manually setting the port to 3000 greens up to but won't load
    Gullit Miranda
    @gullitmiranda
    this command wont work for new applications. May be that is missing something in the config.ru.
    what is the command that you usually use without the azk?
    Dr Kim Foale
    @kimadactyl
    just rails server
    i don't really think about it ^^
    Gullit Miranda
    @gullitmiranda
    I understand. when I was working with everything on my machine it didn't think of it =D
    Dr Kim Foale
    @kimadactyl
    yeah :D all this puma/rack/unicorn stuff just goes over my head
    Gullit Miranda
    @gullitmiranda
    I created an application with rails, I'm going to pick up the correct command.
    rsrs
    Dr Kim Foale
    @kimadactyl
    im really not sure $HTTP_PORT is working properly. hmmm.
    shall i chuck everything in a gist?
    Gullit Miranda
    @gullitmiranda
          command: ["bundle", "exec", "rails", "server", "--pid", "/tmp/rails.pid", "--port=$HTTP_PORT", "--binding=0.0.0.0"]
          // or
          // command: "bundle exec rails server --pid /tmp/rails.pid --port=$HTTP_PORT --binding=0.0.0.0".split(" ")
    the HTTP_PORT is for you to set on which port the rails server will be available
    Dr Kim Foale
    @kimadactyl
    do i set it manually?
    Gullit Miranda
    @gullitmiranda
    you can use:
    ports: {
      http: '3000/tcp'
      // http: '5000/tcp'
      // http: '8080/tcp'
      // http: '80/tcp'
      // ....
    }
    Dr Kim Foale
    @kimadactyl
    yup i have it set like that, hmm
    Gullit Miranda
    @gullitmiranda
    in Azkfile
    Dr Kim Foale
    @kimadactyl
    check my azk file, i think i have it right but no luck unless i specify a port in the string, and then it doesnt work (altho that could be something else)
    what's the port number for in the "instances-ports" column in the azk status table?
    Gullit Miranda
    @gullitmiranda
    you override the database.yml for the gist (https://gist.github.com/gullitmiranda/62082f2e47c364ef9617)?
    Dr Kim Foale
    @kimadactyl
    oh that completely replaces my database.yml?
    Gullit Miranda
    @gullitmiranda
    as you are not using the env in the name of the DB, you will need to edit this line
    yes
    Dr Kim Foale
    @kimadactyl
    ahhhhh
    Gullit Miranda
    @gullitmiranda
    about the command: a user is preparing the PR (with tests) to correct the rails suggestion.
    Dr Kim Foale
    @kimadactyl
    hmm. completely replaced the file and same problem
    just "site can't be reached"
    Gullit Miranda
    @gullitmiranda
    about database.yml: I need to finish a feature that will facilitate overwritten. (https://github.com/gullitmiranda/azk/tree/feature/mounts_from)
    Dr Kim Foale
    @kimadactyl
    cool :)
    Gullit Miranda
    @gullitmiranda

    run:

    azk logs -f

    and try access

    Dr Kim Foale
    @kimadactyl
    looks like its working
    how do you do codeblocks btw?
    taichi-school1 2016-03-25T14:48:21.140053849Z * Listening on tcp://0.0.0.0:300looks good tho
    Gullit Miranda
    @gullitmiranda
    when you have visited the app did not appear more things in the log?
    Dr Kim Foale
    @kimadactyl
    no im just getting site cannot be reached, should just be https://taichi-school.dev.azk.io/ right?
    (no extra port etc)