Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Everton Ribeiro
    @nuxlli
    let's try both
    Dr Kim Foale
    @kimadactyl
    kim@chips:~/git/taichi/taichi_rails$ dig dev.azk.io
    
    ; <<>> DiG 9.9.5-11ubuntu1.3-Ubuntu <<>> dev.azk.io
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 31138
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 512
    ;; QUESTION SECTION:
    ;dev.azk.io.            IN    A
    
    ;; AUTHORITY SECTION:
    azk.io.            899    IN    SOA    ns-584.awsdns-09.net. awsdns-hostmaster.amazon.com. 1 7200 900 1209600 86400
    
    ;; Query time: 75 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Fri Mar 25 17:16:47 GMT 2016
    ;; MSG SIZE  rcvd: 123
    thats the failed one right?
    Everton Ribeiro
    @nuxlli
    at first my theory is: we are in Brazil and here the dns server 8.8.8.8 and 8.8.4.4 are slow to resolve, so the location dnsmasq responds correctly to dev.azk.io, but you should be in a region where they resolve more quickly than dev.azk.io does not exist :/
    Dr Kim Foale
    @kimadactyl
    if i replcae the file with that dns server completely i get the right respnse but still nothing from the browser
    im in the uk :)
    Everton Ribeiro
    @nuxlli
    which browser you are using?
    Dr Kim Foale
    @kimadactyl
    hah dns just stopped working oops
    chrome and firefox both
    Everton Ribeiro
    @nuxlli
    :/
    Dr Kim Foale
    @kimadactyl
    oh a new error appears
    azk: System `taichi-school` not running
    azk: ↓ stopping `postgres` system, 1 instances...
    azk: Run system `taichi-school` return: (1), for command: ["bundle","exec","rails","server","--pid","/tmp/rails.pid","--port=3000","--binding=0.0.0.0"]:
    azk:  .taichi-school [log] >  => Booting Puma
    azk:  .taichi-school [log] >  => Rails 4.2.6 application starting in production on http://0.0.0.0:3000
    azk:  .taichi-school [log] >  => Run `rails server -h` for more startup options
    azk:  .taichi-school [log] >  => Ctrl-C to shutdown server
    azk:  .taichi-school [log] >  Exiting
    azk:  .taichi-school [log] >  /azk/bundler/ruby/2.3.0/gems/activerecord-4.2.6/lib/active_record/connection_adapters/postgresql_adapter.rb:651:in `initialize': could not translate host name "dev.azk.io" to address: Name or service not known (PG::ConnectionBad)
    probably the same problem
    Dr Kim Foale
    @kimadactyl
    hmm in in wily not sure if it matters
    i already commented out the dnsmasq line
    gotta run to the shop back in 15
    really appreciat this!
    Gullit Miranda
    @gullitmiranda
    @kimadactyl it seems that the problem is more complicated, we will investigate more and give you a return.
    Dr Kim Foale
    @kimadactyl
    wow thanks :) seems there must be Another Way
    you think its an ubuntu problem a 15.10 problem, something else? its a pretty clean install
    Gullit Miranda
    @gullitmiranda
    The @nuxlli was able to reproduce the error. let's look for a solution to this problem.
    Dr Kim Foale
    @kimadactyl
    oh, amazing :D
    well not amazing but you know. makes me feel less stupid :)
    Gullit Miranda
    @gullitmiranda
    :joy: I know =D
    if the azk has not worked "amazing" needs improvement, it's not your fault
    Dr Kim Foale
    @kimadactyl
    :D hahhhh
    Everton Ribeiro
    @nuxlli
    @kimadactyl let me know when you can test something, ok?
    Everton Ribeiro
    @nuxlli
    To test if this will work properly we will return to the normal state of the problem:
    # rollback
    echo "# Generated by NetworkManager" | sudo tee /etc/resolv.conf
    echo "nameserver 8.8.8.8" | sudo tee -a /etc/resolv.conf
    echo "nameserver 8.8.4.4" | sudo tee -a /etc/resolv.conf
    
    # restart azk agent
    azk agent stop
    sudo rm -rf /etc/resolver/dev.azk.io
    azk agent start
    
    # check results
    dig dev.azk.io
    dig dev.azk.io @172.17.0.1
    Dr Kim Foale
    @kimadactyl
    ook gimmie about 30 and ill try :)
    Everton Ribeiro
    @nuxlli
    # Now try this
    getent hosts dev.azk.io
    
    # Fix! It will change
    # this: hosts:          files resolver mdns4_minimal [NOTFOUND=return] dns
    # for : hosts:          files resolver [UNAVAIL=return] mdns4_minimal [NOTFOUND=return] dns
    sed -i -re "s/(hosts:.*\s{1,}resolver)(\s{1,}\[[^]|.]*\]){0,1}($|\s\w)(.*)/\1 [UNAVAIL=return]\3\4/; s/\s*$//;" /etc/nsswitch.conf
    
    # Test
    getent hosts dev.azk.io
    Dr Kim Foale
    @kimadactyl
    kim@chips:~/git/taichi/taichi_rails$ dig dev.azk.io
    
    ; <<>> DiG 9.9.5-11ubuntu1.3-Ubuntu <<>> dev.azk.io
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 41121
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 512
    ;; QUESTION SECTION:
    ;dev.azk.io.            IN    A
    
    ;; AUTHORITY SECTION:
    azk.io.            899    IN    SOA    ns-584.awsdns-09.net. awsdns-hostmaster.amazon.com. 1 7200 900 1209600 86400
    
    ;; Query time: 381 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Fri Mar 25 18:50:46 GMT 2016
    ;; MSG SIZE  rcvd: 123
    
    kim@chips:~/git/taichi/taichi_rails$ dig dev.azk.io @172.18.0.1
    
    ; <<>> DiG 9.9.5-11ubuntu1.3-Ubuntu <<>> dev.azk.io @172.18.0.1
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17972
    ;; flags: qr aa rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;dev.azk.io.            IN    A
    
    ;; ANSWER SECTION:
    dev.azk.io.        0    IN    A    172.18.0.1
    
    ;; Query time: 0 msec
    ;; SERVER: 172.18.0.1#53(172.18.0.1)
    ;; WHEN: Fri Mar 25 18:50:53 GMT 2016
    ;; MSG SIZE  rcvd: 44
    
    kim@chips:~/git/taichi/taichi_rails$ getent hosts dev.azk.io
    172.18.0.1      dev.azk.io
    This message was deleted
    This message was deleted
    This message was deleted
    kim@chips:~/git/taichi/taichi_rails$ getent hosts dev.azk.io
    172.18.0.1      dev.azk.io
    kim@chips:~/git/taichi/taichi_rails$ sed -i -re "s/(hosts:.*\s{1,}resolver)(\s{1,}\[[^]|.]*\]){0,1}($|\s\w)(.*)/\1 [UNAVAIL=return]\3\4/; s/\s*$//;" /etc/nsswitch.conf
    sed: couldn't open temporary file /etc/sedr8H9x3: Permission denied
    kim@chips:~/git/taichi/taichi_rails$ sudo sed -i -re "s/(hosts:.*\s{1,}resolver)(\s{1,}\[[^]|.]*\]){0,1}($|\s\w)(.*)/\1 [UNAVAIL=return]\3\4/; s/\s*$//;" /etc/nsswitch.conf
    kim@chips:~/git/taichi/taichi_rails$ 
    kim@chips:~/git/taichi/taichi_rails$ 
    kim@chips:~/git/taichi/taichi_rails$ getent hosts dev.azk.io
    172.18.0.1      dev.azk.io
    getting "refused to connect"
    Everton Ribeiro
    @nuxlli
    oh god..rsrs
    Dr Kim Foale
    @kimadactyl
    rsrs? :)
    oic :)
    you sure its not something else ive done?
    Everton Ribeiro
    @nuxlli
    I do not really have to say, the dns service on Linux is very complicated, and Ubuntu is even more
    this will sound bad, but you have tried to restart your machine?
    Dr Kim Foale
    @kimadactyl
    yes i just did
    its only network manager working now
    not sure if that made it more complex or not.
    Everton Ribeiro
    @nuxlli
    in theory it was to be made easier
    Dr Kim Foale
    @kimadactyl
    dinnertime biab
    Everton Ribeiro
    @nuxlli
    ok
    when you return: