Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Everton Ribeiro
    @nuxlli
    I do not really have to say, the dns service on Linux is very complicated, and Ubuntu is even more
    this will sound bad, but you have tried to restart your machine?
    Dr Kim Foale
    @kimadactyl
    yes i just did
    its only network manager working now
    not sure if that made it more complex or not.
    Everton Ribeiro
    @nuxlli
    in theory it was to be made easier
    Dr Kim Foale
    @kimadactyl
    dinnertime biab
    Everton Ribeiro
    @nuxlli
    ok
    when you return:
    # Now try this
    # Fix! It will change
    # for : hosts:          files resolver [UNAVAIL=return] mdns4_minimal [NOTFOUND=return] dns
    # this: hosts:          files mdns4_minimal [NOTFOUND=return] dns [SUCCESS=continue] resolver
    sudo sed -i -re "s/(hosts:.*)\s{1,}resolver(\s{1,}\[[^]|.]*\]){0,1}($|\s\w)(.*)/\1\3\4 [SUCCESS=continue] resolver/; s/\s*$//;" /etc/nsswitch.conf
    
    # Test
    getent hosts dev.azk.io
    Dr Kim Foale
    @kimadactyl
    still not working :(
    kim@chips:~/git/taichi/taichi_rails$ getent hosts dev.azk.io
    172.18.0.1      dev.azk.io
    whats it meant to be?
    Everton Ribeiro
    @nuxlli
    ping, browsers, no work?
    Dr Kim Foale
    @kimadactyl
    ooo
    kim@chips:~/git/taichi/taichi_rails$ ping dev.azk.io
    PING dev.azk.io (172.18.0.1) 56(84) bytes of data.
    64 bytes from 172.18.0.1: icmp_seq=1 ttl=64 time=0.040 ms
    64 bytes from 172.18.0.1: icmp_seq=2 ttl=64 time=0.045 ms
    64 bytes from 172.18.0.1: icmp_seq=3 ttl=64 time=0.051 ms
    Everton Ribeiro
    @nuxlli
    nice
    Dr Kim Foale
    @kimadactyl
    hmm
    This message was deleted
    kim@chips:~/git/taichi/taichi_rails$ ping dev.azk.io
    PING dev.azk.io (172.18.0.1) 56(84) bytes of data.
    64 bytes from 172.18.0.1: icmp_seq=1 ttl=64 time=0.040 ms
    64 bytes from 172.18.0.1: icmp_seq=2 ttl=64 time=0.045 ms
    64 bytes from 172.18.0.1: icmp_seq=3 ttl=64 time=0.051 ms
    ^C
    --- dev.azk.io ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2000ms
    rtt min/avg/max/mdev = 0.040/0.045/0.051/0.007 ms
    kim@chips:~/git/taichi/taichi_rails$ 
    kim@chips:~/git/taichi/taichi_rails$ sudo sed -i -re "s/(hosts:.*)\s{1,}resolver(\s{1,}\[[^]|.]*\]){0,1}($|\s\w)(.*)/\1\3\4 [SUCCESS=continue] resolver/; s/\s*$//;" /etc/nsswitch.conf
    kim@chips:~/git/taichi/taichi_rails$ ping dev.azk.io
    ping: unknown host dev.azk.io
    im a bit confused :)
    Everton Ribeiro
    @nuxlli
    me too :P
    Dr Kim Foale
    @kimadactyl
    is there an order i need to do things in, eg, starting azk, running the commands, etc
    Everton Ribeiro
    @nuxlli
    back to the old version of /etc/nsswitch.conf
    Dr Kim Foale
    @kimadactyl
    it currently looks like this
    This message was deleted
    This message was deleted
    kim@chips:~/git/taichi/taichi_rails$ cat /etc/nsswitch.conf 
    # /etc/nsswitch.conf
    #
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.
    
    passwd:         compat
    group:          compat
    shadow:         compat
    
    hosts:          files mdns4_minimal [NOTFOUND=return] dns [SUCCESS=continue] [SUCCESS=continue] resolver
    networks:       files
    
    protocols:      db files
    services:       db files
    ethers:         db files
    rpc:            db files
    
    netgroup:       nis
    Everton Ribeiro
    @nuxlli
    ual
    remove one "[SUCCESS=continue]"
    Dr Kim Foale
    @kimadactyl
    ah ok ran your command twice by accident :smile:
    have a ping again
    Everton Ribeiro
    @nuxlli
    nice
    Dr Kim Foale
    @kimadactyl
    ooo
    "no application configured"
    Everton Ribeiro
    @nuxlli
    nice!
    Dr Kim Foale
    @kimadactyl
    https://taichi-school.dev.azk.io/ unable to connect then
    dev.azk.io giving no application
    Everton Ribeiro
    @nuxlli
    now you can try start your application with azk start
    Dr Kim Foale
    @kimadactyl
    it is started, restart?
    Everton Ribeiro
    @nuxlli
    yes
    cd [app_dir] && azk restart
    Dr Kim Foale
    @kimadactyl
    hmm did azk agent stop && azk start and its not working
    ping to dev.azk.io working, browser not willing to connect
    Everton Ribeiro
    @nuxlli
    you can send me the output?
    Dr Kim Foale
    @kimadactyl
    ping to taichi-school.dev.azk.io working too
    the output of what?
    Everton Ribeiro
    @nuxlli
    for "azk agent stop && azk start" process
    Dr Kim Foale
    @kimadactyl
    kim@chips:~/git/taichi/taichi_rails$ azk agent stop && azk start
    azk: Agent is running...
    azk: Agent is being stopped...
    azk: Agent has been successfully stopped.
    ? The agent is not running, would you like to start it? Yes
    azk: Please wait, this process may take several minutes
    azk: Loading settings and checking dependencies.
    azk: Checking version...
    azk: azk 0.17.0 detected
    azk: Cleaning 2 lost containers
    azk: Settings loaded successfully.
    azk: Agent is being started...
    azk: Trying to connect to docker (unix:///var/run/docker.sock) (timeout: 20s)...
    azk: Starting azk dns service...
    azk: Dns service started.
    azk: Trying to connect to docker (unix:///var/run/docker.sock) (timeout: 20s)...
    azk: Starting azk balancer redirect service...
    azk: Check if balancer redirect service is up (tcp://172.18.0.1:80) (timeout: 10000s)...
    azk: Balancer redirect started.
    azk: Starting memcached service...
    azk: Memcached service started.
    azk: Starting http balancer service...
    azk: Http balancer service started.
    azk: Agent has been successfully started.
    azk: ↑ starting `postgres` system, 1 new instances...
    azk: ✓ checking `azukiapp/postgres:9.4` image...
    azk: ◴ waiting for `postgres` system to start, trying connection to port data/tcp...
    azk: ↑ starting `taichi-school` system, 1 new instances...
    azk: ✓ checking `azukiapp/ruby:2.3.0` image...
    azk: ⎘ syncing files for `taichi-school` system...
    azk: ◴ waiting for `taichi-school` system to start, trying connection to port http/tcp...
    
    ┌───┬───────────────┬───────────┬─────────────────────────────────┬─────────────────┬─────────────┐
    │   │ System        │ Instances │ Hostname/url                    │ Instances-Ports │ Provisioned │
    ├───┼───────────────┼───────────┼─────────────────────────────────┼─────────────────┼─────────────┤
    │ ↑ │ postgres      │ 1         │ dev.azk.io                      │ 1-data:32776    │ -           │
    ├───┼───────────────┼───────────┼─────────────────────────────────┼─────────────────┼─────────────┤
    │ ↑ │ taichi-school │ 1http://taichi-school.dev.azk.io │ 1-http:32777    │ 3 hours ago │
    └───┴───────────────┴───────────┴─────────────────────────────────┴─────────────────┴─────────────┘
    kim@chips:~/git/taichi/taichi_rails$