Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Felipe Arenales Santos
    @fearenales
    @m9dfukc @slobo I must confess we still don't have a defined roadmap for this, since Docker still doesn't have a date for launch it.
    @slobo : that's the idea! any contribution would be sincerely appreciated. If you could point you branch where you have done your tests would be great!
    @m9dfukc I'll send you a DM so that we can schedule an one-o-one support session and I can help you to check what's going on with sync in your box, what do you think?
    Slobodan Mišković
    @slobo
    i got as far as this:
       darwin() {
    -    return this._checksForRequiresVm();
    +    return this.linux();
       }
    but I don't think that's the right approach since then stuff like ip dettection would have to have some nasty conditions to check again if on mac
    Felipe Arenales Santos
    @fearenales
    ah ok, thanks for sharing. As soon as we have a WIPbranch I'll let you know so you can track development and join us on coding if you wish! :D
    Slobodan Mišković
    @slobo
    sure thing, keep me posted!
    Felipe Arenales Santos
    @fearenales
    sure! thanks!
    Wesley Mendes Santiago
    @wesleyvicthor
    hey guys, I cannot figure out why my database connection does not work
    I've tried to azk shell mysql and connect to it but no success
    any guess ?
    Wesley Mendes Santiago
    @wesleyvicthor
    403 :(
    Wesley Mendes Santiago
    @wesleyvicthor
    how to get a nginx server working properly :( i cant configure the host
    files disappear and I just get 403
    Luiz Paulo Camargo
    @luizpcam
    Hi @wesleyvicthor could you show your Azkfile?
    Gullit Miranda
    @gullitmiranda
    @wesleyvicthor the azk shell does not start mysql. you should do the azk start mysql and connect to it.
    Slobodan Mišković
    @slobo

    hey folks, i'm having issues pulling images from docker hub, started couple days ago it seems, not sure if 'them' (dockerhub) or 'us' (azk):

    // Azkfile.js
    {   mail: { image: {"docker": "tophfr/mailcatcher"}, }
    ➤ azk start -RBvv mail
    azk: ↑ starting `mail` system, 1 new instances...
    azk: ✓ checking `tophfr/mailcatcher:latest` image...
    azk: ⇲ downloading `tophfr/mailcatcher:latest` image...
    azk: An error occurred. It will stop all instances already running. See details below.
    
    azk: System `mail` not running
    
    azk: Lost internet connection or error while connecting to docker registry:
    azk:   Error: 404:  >> url: https://registry-1.docker.io/v1/repositories/tophfr/mailcatcher/tags/latest

    But adocker pull tophfr/mailcatcher works fine. I tried this on two different computers (osx and linux) and from two different places in the world. Any idea?

    here is debug output: https://nopaste.me/view/9e6fafb9
    Luiz Paulo Camargo
    @luizpcam
    Hi @slobo , this error is happening with me too. But azk team is fixing it. Here is The issue: The workaround is pull direct from docker like this: adocker
    Try this command and start azk again : adocker pull lop
    Slobodan Mišković
    @slobo
    thanks @luizpcam. Good to know I'm not crazy. Doing the pull and start works, bug unfortunately our CI process needs the -B for other custom images.
    I am probably just going to inline all the images we use into local Dockerfiles, hub is not always reliable it seems
    Luiz Paulo Camargo
    @luizpcam
    Yeah! Me too! only we have to do is wait for new version!
    Slobodan Mišković
    @slobo
    I take it that -B does some sort of lookup before doing a docker pull - maybe a simple fix is to always just issue a docker pull when -B is specified - I mean it will end in no-op anyways if image is up to date - not sure it's an optimization to do any pre-checks (I'm probably naíve about some usecases)...
    Luiz Paulo Camargo
    @luizpcam
    I agree maybe this solution works great
    Slobodan Mišković
    @slobo
    this ugly fix makes it work on my computer at least: azukiapp/azk#676
    (we lose progressbar instead of aborting the entire process)
    Gullit Miranda
    @gullitmiranda
    hi @slobo and @luizpcam. tks for PR @slobo.
    I'm going to work on changing the lib of communication with the docker. it is not a simple task for this has been delayed until the time. But now became an impediment.
    Gullit Miranda
    @gullitmiranda
    @slobo, instead of using console.log we can use the log (like this https://github.com/azukiapp/azk/blob/master/src/cmds/scale.js#L99). would you prefer to do the change or change in the merge?
    Slobodan Mišković
    @slobo
    @gullitmiranda it would be great you bring it up to standard, I won't have time to look at it for a few days. thanks
    Gullit Miranda
    @gullitmiranda
    Nice. I do
    Wesley Mendes Santiago
    @wesleyvicthor
    hey guys, I am using the php-fpm image and I cannot restart nginx properly
    service nginx restart does not output any error. it just stands.
    nginx service start neither.
    Leandro Lugaresi
    @leandro-lugaresi
    hey guys!
    Anyone using php-apache?
    Gullit Miranda
    @gullitmiranda
    @leandro-lugaresi, any questions?
    Andreas Schmelas
    @m9dfukc
    Hello, how is it going?
    Any progress releasing version 0.19.0?
    And how about the progress integrating docker for osx?
    ... I know I'm asking for a lot ;)
    Slobodan Mišković
    @slobo
    seems docker for osx and windows is publicly released: https://blog.docker.com/2016/07/docker-for-mac-and-windows-production-ready/
    Danni Friedland
    @BlueHotDog
    hey guys, trying to install AZK on newest mac, encountering a LOT of errors :(
    Danni Friedland
    @BlueHotDog
    ?
    Gullit Miranda
    @gullitmiranda
    hi @BlueHotDog. we are working to release a version using the docker for mac. After the upgrade we hope not to occur errors in Mac Sierra.
    Danni Friedland
    @BlueHotDog
    Anyway i can make AZK work now?
    my current error is:
    ```
    azk: Lost internet connection or error while connecting to docker registry:
    azk: Error: 404: >> url: https://registry-1.docker.io/v1/repositories/library/rabbitmq/tags/3.6.5-management
    @gullitmiranda
    Gullit Miranda
    @gullitmiranda
    @BlueHotDog this error has been solved in master branch. We need make new release with this (and others) fixes.
    Danni Friedland
    @BlueHotDog
    @gullitmiranda Anyway i can run from master? it's kind of urgent since i'm unable to provision my environment for the past 2 days :(