Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Nov 19 2018 14:18
    quentinguitard reopened #809
  • Nov 19 2018 14:18
    quentinguitard closed #809
  • Nov 19 2018 14:18
    quentinguitard opened #809
  • Jul 02 2018 12:34

    eric-chau on v1.3.12

    (compare)

  • Jul 02 2018 12:27

    eric-chau on master

    [ClassContent] fixed Revision::… Merge pull request #808 from er… (compare)

  • Jul 02 2018 12:27
    eric-chau closed #808
  • Jul 02 2018 12:22
    crouillon commented #808
  • Jul 02 2018 12:19
    eric-chau opened #808
  • Jul 02 2018 12:19

    eric-chau on fix-revision-commit

    (compare)

  • Jul 02 2018 12:19

    eric-chau on fix-revision-commit

    [ClassContent] fixed Revision::… (compare)

  • Jun 06 2018 14:09

    crouillon on v1.3.11

    (compare)

  • Jun 06 2018 14:08

    crouillon on master

    Update to version v1.3.11 (compare)

  • May 24 2018 22:50
    mickaelandrieu closed #805
  • May 24 2018 22:50
    mickaelandrieu commented #805
  • Mar 07 2018 13:28

    crouillon on master

    Update version to v1.3.11-DEV (compare)

  • Mar 07 2018 13:28

    crouillon on v1.3.10

    (compare)

  • Mar 07 2018 13:27

    crouillon on master

    Update version to v1.3.10 (compare)

  • Feb 16 2018 17:43

    crouillon on master

    Insures the name of the altered… Merge pull request #807 from cr… (compare)

  • Feb 16 2018 17:43
    crouillon closed #807
  • Feb 16 2018 17:42
    crouillon commented #807
Alain Tiemblo
@ninsuo
I'll try during the week, I guess my laptop don't want to see me working a sunny Sunday ;)
Gonzalo Vilaseca
@gonzalovilaseca
was just having a look at 1.1 beta, and found this: class brand extends AbstractHelper
but there is no AbstractHelper class anywhere
is that correct?
Quentin Boulard
@quentin-boulard
Nicolas Dufreche
@ndufreche
Is this one
Gonzalo Vilaseca
@gonzalovilaseca
shit, didn't do composer install...thanks!
ima dev
@ob7
api.backbee.com doesn't load anything in the browser. Is that correct?
ima dev
@ob7
I think the api site is down
Mickaël Andrieu
@mickaelandrieu
Hi,
you are right
we just fixed this bug :)
api.backbee.com is now up, thank you for report :)
lordsincrossX
@lordsincrossX
Hello there, i'm new around here so first thing i have to say is that BackBee looks really impressive
However, right now my website is on a shared webhosting plan. which means i don't have neither SSH access nor WHM access...is there anyway to install BackBee like we do with Magento, WordPress and several others??
do the upload and go for yourdomain.com/install and do it?
ima dev
@ob7
To get backbee installed on a webhosting plan, you will need to have the requirements there. So if the webhost will make sure the server you host on has those things available, then all you need is access to mysql and set up the database, as you would wordpress.
Heres the install tutorial
However, if you are serious about web applications, you need to get a vps
lordsincrossX
@lordsincrossX
i'm not a developer. i'm a business owner, a business at it's very beginning and in brazil i face 2 problems: 1 - economy: our currency is at a rate of 4real/1dollar - thats a HUGE setback. 2 - getting a developer here to develop the stuff for me has proven quite expensive.
i wouldn't even know how to start configuring a VPS, thats why i asked for a kind of "prebuilt" version of the thing
lordsincrossX
@lordsincrossX
when i found backbee i was looking for a powerful drag and drop toll that could really develop the page this way. cause all the drag and drop tools i found were "kinda drag and drop"...i think i'm doing very well on my own given my very limited knowledge...checkout the store i've built thus far www.lojarosseto.com
when i found backbee i was looking for a powerful drag and drop toll that could really develop the page this way. cause all the drag and drop tools i found were "kinda drag and drop"...i think i'm doing very well on my own given my very limited knowledge...checkout the store i've built thus far www.lojarosseto.com
ima dev
@ob7
This message was deleted
I'd say BackBee is geared towards developers. But I can still point you in the right direction. You should look at www.concrete5.org, and then theres http://tidycms.com which is almost ready but not quite and you have to pay for it. But its suppose to be very easy to work with.
Concrete5 will also take some set up though... For turn key solution, I think tidycms may be what you need, but they are not quite done with it yet. But I've talked to their developers and I think it would definetly be something your looking for once its ready.
lordsincrossX
@lordsincrossX
been playing around with concrete5 this last night, it's a really good one too. i'll take a look at tidycms. thx :D
ima dev
@ob7
Anytime, we're here to help!
Mickaël Andrieu
@mickaelandrieu
yo
Archiblog
@Archiblog
Hello - is there anybody there?
Quentin Boulard
@quentin-boulard
@Archiblog Hello, yes there is.
Archiblog
@Archiblog
@quentin-boulard Have you created a BackBee site?
Quentin Boulard
@quentin-boulard
@Archiblog yes
Gonzalo Vilaseca
@gonzalovilaseca
I'm migrating the whole BB to symfony framework, it's in a quite advanced state, but if anyone wants to give me a hand, it's more than welcome, I've left many todo's on the way!
cacheman
@cacheman
Hi....I'm new to backbee. I am trying to install on CensOS7. When I use v1.0 I get as far as 'Run Tests' but the test never works. My apache error log says "PHP Fatal error: Uncaught exception 'InvalidArgumentException' with message 'The HTTP status code "0" is not valid". I have also tried downloading and configuring the v1.1-beta from git. I don't get this error, but my browser says "error the security context contains no authentication token". I'm a bit lost at this point. Would be grateful for any help.
cacheman
@cacheman
I have since tried 1.1 again. I still get the 'security context contains....' in the browser, but I hadn't tried ctrl-alt-b to get the login page. I have just tried this and I do get the login page, but when I try to login I get 'Authenticaton failed - public key not provided'......
Charles Rouillon
@crouillon
Hi @cacheman. Looks like installation is not complete. I didn't try BackBee on CentOS, but did you got some errors or warnings during the installation process? The first step, requirements checks (see http://docs.backbee.com/developer-documentation/installation/) was it ok?
Meanwhile, i'm looking for some CentOS image to try it on
cacheman
@cacheman
Hi....thanx for the reply. You were right....I tried a fresh install and I'm in on 1.1-beta right now with the demo Mag site. Apologies for any wasted time.
Charles Rouillon
@crouillon
No problem, glad to read you
Hugo Martinez
@hugomartinez

Je viens de créer une requête pull proposant un début de traduction française de la doc. Alors oui, cela peut paraître bizarre, mais j'ai donc proposé de merger ma branche "French" avec la branche "master" du dépôt, mais c'est juste parce qu'il n'y as pas encore de branch "French" dans le dépôt. Alors il y a deux solutions :

  • soit il faut créer une branche "French" et une branche "English" ce qui ferait donc que pour chaque traduction de la doc, on créerai une nouvelle doc
  • soit dans le dossier doc, on fait un sous dossier pour chaque traduction

A vous de voir,

Pouvez-vous juste me dire si le fait que je traduise la doc en français vous intéresse ou pas ? Histoire que je traduise pas toute la doc pour rien...

J'attends donc votre retour avant de continuer la traduction entière de la doc

Mickael Steinberg
@mickaelsteinberg
Bonjour @hugomartinez ! En effet, le sujet de la traduction de la documentation est dans les tuyaux. La réponse à ta demande se trouve ici : backbee/docs#45
azzisharbel
@azzisharbel
Hi,
someone could point me to a tutorial where i can install Backbee on my windows machine using any of XAMP, Acquia Dev Desktop, Easy PHP… ?
I am not a Linux user and what i found are all about installing Backbee on linux !
Please any help will be appreciated
azzisharbel
@azzisharbel
This message was deleted
azzisharbel
@azzisharbel

INSTALLING BACKBEE ON WINDOWS MACHINE USING ACQUIA DEV DESKTOP WENT SUCCESSFUL...

Hi everybody,
I am a Drupal Developer using Acquia Dev Desktop as my working environment for web development,
and using the following below explanation, i installed BackBee on windows machine using Acquia Dev Desktop.
NOTE: the below explanation assume that you work before with Acquia Dev Desktop software.

1) Open Acquia Dev Desktop.

2) Create a new drupal site using automatic wizard and by choosing Drupal 7.50.
Site Name: "backbee" Database: "backbee"

3) When the site is fully downloaded, don't launch the local site URL.

4) Go to preferences of the software --> Config Tab --> and edit the php.ini file and uncomment the following:

extension=php_mbstring.dll
extension=php_pdo_mysql.dll
extension=php_pdo_sqlite.dll

And restart the Acquia Dev Desktop software.

5) Goto the local code and delete all downloaded file inside the folder "backbee"

6) Open the Drush console. (the one built-in inside the Acquia Dev Desktop software)

7) Navigate to your backbee site path (the folder newly created "backbee")

8) Type the following command:
composer create-project "backbee/backbee-standard" "1.1" -n
This will take arround 10 minutes to finish from downloading all files/folders.

9) Navigate to your Backbee website folder, you should find a new folder named: "1.1"

10) Go inside the folder "1.1" and move all folders/files to outside that folder.

11) Delete the folder :1.1 (Which basically after completing the step 9 the folder should be empty.

12) Go back to the Acquia Dev Desktop software and click on the local site link.

13) In your browser you should change the url from:
http://backbee.dd:8083/install.php to http://backbee.dd:8083/public/install.php
Adding the public folder to the url so the install,php file could be located.

14) Voila, Backbee installation wizard now should available in front of you.

But while follwing the installation wizard and reach the Step 3 - Database configuration
I always got the same error: Failed to connect to database with provided credentials.

so maybe anybody with more experience than me in BackBee could point me on why i am getting such error ?!
What is missing ?!

Thank you for any help and hope i could help somebody with the above.

FahimaGold
@FahimaGold
Hello,I've got a question,how can I migrate my backbee website on the internet?
Sebastián Romero
@bastian-rom
Hi, i'm trying to create a new user but the email ending with edu.co presents a problem when saving the user. How can I modify the CMS to change it? or how could I solve this problem?