Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 02:30
    stpaultim closed #4078
  • 02:30
    stpaultim commented #4078
  • 02:30
    stpaultim commented #4078
  • 02:29
    stpaultim labeled #4078
  • 02:29
    stpaultim unlabeled #4078
  • 02:15
    stpaultim edited #4078
  • 02:10
    stpaultim edited #4078
  • 02:08
    stpaultim edited #4078
  • 02:07
    stpaultim edited #4078
  • 02:04
    stpaultim opened #4078
  • 02:04
    stpaultim labeled #4078
  • 02:00
    hosef labeled #4077
  • 02:00
    hosef opened #4077
  • Sep 22 23:39
    klonos edited #1728
  • Sep 22 10:54
    klonos labeled #2615
  • Sep 22 10:54
    klonos unlabeled #2615
  • Sep 22 10:52
    klonos commented #2615
  • Sep 22 10:51
    klonos commented #2615
  • Sep 22 10:50
    klonos commented #2615
  • Sep 22 06:41
    BWPanda labeled #2615
Gregory Netsas
@klonos
...you did call layout templates (not the flexible ones only) "layouts" a couple of times, but I'm not gonna hold it against you :smile:
...this is something that we should have made clear since 1.0.0 unfortunately :disappointed:
...nevertheless, I'm sure that people will eventually get it.
Gregory Netsas
@klonos
@stpaultim is the plan to be writing a new article like https://backdropcms.org/news/become-advocate-new-feature-backdrop-cms-1150 for each minor release, or should we make that one more generic, and not specific to 1.15?
...like call it Become an advocate for a new feature in the next release of Backdrop CMS
Tim Erickson
@stpaultim
Sure, we could make it more generic. I think tying it to a specific release gives it a little additional immediacy. The short term goal is to get more folks involved as issue advocates in the next release cycle, so why not be specific.
No, I don’t think we should do the same thing each release and having more generic documentation would be helpful.
But, for now I would focus on 1.15 and then come up with more generic content later.
Gregory Netsas
@klonos
...I also see the point in keeping it specific to 1.15 ...I don't mind either editing and re-publishing the same article every 4 months :smile:
Gregory Netsas
@klonos
@quicksketch pick and choose PRs to either disable, or configure trusted_host_patterns for the demo sites: backdrop-ops/backdrop-tugboat#3
Justin Christoffersen
@larsdesigns
ping @serundeputy
Gregory Netsas
@klonos
@BWPanda ++ for #2615 :+1:
Dragon Bot
@dragonbot
@bwpanda +1! (Karma: 98)
Gregory Netsas
@klonos
...I've left a review :slight_smile:
Peter Anderson
@BWPanda
Thanks, will check later.
Geoff St. Pierre
@serundeputy
Hello @larsdesigns
hosef
@hosef
How does one go about creating a second dashboard under the main dashboard. ie. /admin/dashboard/analytics.
When I try to do it through the UI it breaks the first dashboard
Gregory Netsas
@klonos
Hmm ...can you please open an issue for this @hosef ?
Tim Erickson
@stpaultim

@hosef - It took me a minute to figure out what you were trying to do. Yes, trying to add a new layout with the path admin/dashboard/analytics breaks things. We do need to create an issue for that.

A possible work-a-round is the following:
1) Create node for the analytics page
2) Create a layout for that specific node (in my example NID = 11)
3) Manually create a menu link

This works, but it’s not ideal. Specifically, it does not use the admin theme. There must be a solution for this, but I forget what is is. What determines when the admin theme is used?

Analytics___Triplo_co.png
Tim Erickson
@stpaultim
FYI - I’ve done some testing and the problem you described is not specific to creating a page under dashboard. The same problem exists for adding any layout page to admin menu. I will create an issue.
Gregory Netsas
@klonos
@stpaultim while you are testing, can you try to rule out the possibility that things break only if the path of the new layout (or part of its path) is an existing path for another layout?
hosef
@hosef
Yeah, I am trying to create a set of sub dashboards for specific topics, such as analytics, social media, or SEO to have more detailed reports than seemed apropriate on the overview page.
I also ran into another issue with the new Dashboard 'context' because it doesn't have a placholder. I'll add another issue for that.
Gregory Netsas
@klonos
@hosef were you hoping to have these show up as secondary tabs in the dashboard page?
hosef
@hosef
yes
Gregory Netsas
@klonos
:+1:
Makes sense
hosef
@hosef
I know how to do that in code, but I was trying to use the layouts so other people can edit them
Gregory Netsas
@klonos
Yup, we should make it possible to not require writing code where possible/appropriate. This sounds like a very legit use case :+1:
Tim Erickson
@stpaultim
@klonos - Actually, what I found is that if I create a layout and try to link to it in the admin menu, it does not work. Regardless of where I put it. Example: admin/content/testone (I can not put a link “testone” to this anywhere in the admin menu). But, if I create a layout with path admin/content/testone/testtwo and make a menu link that is a child of the testone, the testtwo link will show up in the menu structure, but testone will not. “Testtwo” shows up where “Testone” should have.
Just gathing info to create an issue.
Gregory Netsas
@klonos
@stpaultim ++
Dragon Bot
@dragonbot
@stpaultim gained a level! (Karma: 188)
Tim Erickson
@stpaultim
Also - looking for any existing issues that might cover this.
Gregory Netsas
@klonos
@hosef ++
Dragon Bot
@dragonbot
@hosef leveled up! (Karma: 26)
hosef
@hosef
It might be that you need to implement hook_menu in order for it to show up in the admin menu
Tim Erickson
@stpaultim
But, my child link shows up.
hosef
@hosef
hmm
Tim Erickson
@stpaultim
Just not the parent link
hosef
@hosef
@stpaultim when you tried to make the dashboard layout, did you get an error log entry like Notice: Undefined index: path placeholder in layout_context_required_by_path()?
Tim Erickson
@stpaultim
Ohh, too late to answer that. I just destroyed my Lando instance and am rebuilding.
Also - I am testing in Tugboard instance and am having hard time recreating the problem.
So ???????
Tim Erickson
@stpaultim
OK, I recreated the problem. But did not find any error messages in watchdog.
Tim Erickson
@stpaultim
Can’t consistently recreate the problem.
Tim Erickson
@stpaultim
OK - who fixed this bug, cut a new release and updated Tugboat in the last 20 minutes. That kind of change makes it hard for me to get the results I need.
I swear that it was broken 20 minutes ago and now I can’t recreate it.