These are chat archives for bangorunix/2015

6th
Apr 2015
agwhitaker93
@agwhitaker93
Apr 06 2015 15:13
For some reason cp is copying the templates as is instead of filling in $name and $PWD
Noah
@eeue56
Apr 06 2015 15:14
Paste your command here
agwhitaker93
@agwhitaker93
Apr 06 2015 15:14
It was working fine in Virtualbox, but not on a properly installed distro or my Digital Ocean server
cp templates/project-template $projname/$projname
cp templates/readme-template $projname/README.txt
Noah
@eeue56
Apr 06 2015 15:15
And what's happening now that shouldn't be?
agwhitaker93
@agwhitaker93
Apr 06 2015 15:16
I have $projname and $PWD referenced in both my readme and script templates and it's not filling them in.
Noah
@eeue56
Apr 06 2015 15:17
cp doesn't modify the file, so that's not where the problem is
How are you injecting the values into the templates?
agwhitaker93
@agwhitaker93
Apr 06 2015 15:18
I could've sworn it was doing it in virtualbox :/
Noah
@eeue56
Apr 06 2015 15:21
$projname and $PWD will only be evaluted as bash variables if the file they're in is being run as a bash file
Otherwise they're just text
cp takes a file, as is, and copies it to another location, as is
If however, it does manage to happen in your VB but not your VPS instance, then paste the output of "echo $0" in the terminal into here
agwhitaker93
@agwhitaker93
Apr 06 2015 15:25
I get -bash from the server. Can't check on virtualbox until tomorrow
Noah
@eeue56
Apr 06 2015 15:26
Check there and make sure that it was working as you thought
agwhitaker93
@agwhitaker93
Apr 06 2015 15:26
will do
Noah
@eeue56
Apr 06 2015 15:27
If was, then PM me a http://gist.github.com of your code