Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Andrew Hankinson
    @ahankinson
    I'm guessing it printed BC-W.B1
    what happens if you change the SOLR_SERVER to just 'http://localhost:8983/'
    Luca Guariento
    @lguariento
    no that's the print("Creating source " + row['source_id']) in the import_metadata
    oh
    you're right
    (y)
    still 404
    Andrew Hankinson
    @ahankinson
    and what happens if you load 'http://localhost:8983' in your browser?
    Luca Guariento
    @lguariento
    it redirects to /solr
    Andrew Hankinson
    @ahankinson
    are you getting a 'no cores available' on the left?
    in the web interface?
    Luca Guariento
    @lguariento
    no, I have my HMS core loaded
    if I hardcode the address of solr, it connects...
    buh
    Andrew Hankinson
    @ahankinson
    what, exactly, do you put?
    what do you mean it 'connects'?
    as in, it works?
    Luca Guariento
    @lguariento
    si = scorched.SolrInterface("localhost:8983/solr/")
    Andrew Hankinson
    @ahankinson
    but that's not the same address
    Luca Guariento
    @lguariento
    well, it gives me another error (the 'no network adapters' one)
    Andrew Hankinson
    @ahankinson
    yes
    because you're omitting the 'http'
    Luca Guariento
    @lguariento
    true
    Andrew Hankinson
    @ahankinson
    if you add that you will get the exact same error
    Luca Guariento
    @lguariento
    ok, that's solved - true
    I've put the localhost:8983/solr in the SOLR_SERVER
    and now it's fine
    I mean, the module gets it from settings.
    Andrew Hankinson
    @ahankinson
    define "fine"?
    I don't understand
    do you mean that it works and imports the data?
    Luca Guariento
    @lguariento
    the module gets the setting
    Andrew Hankinson
    @ahankinson
    or do you mean you're getting another error?
    Luca Guariento
    @lguariento
    and when I run the import_metadata it connects to solr
    Andrew Hankinson
    @ahankinson
    how do you know?
    Luca Guariento
    @lguariento
    I'm getting the 'no adapters' error
    Andrew Hankinson
    @ahankinson
    then that's not 'fine'
    Luca Guariento
    @lguariento
    my wild wild guess is that if I'd have a 'remote' address with a 'nice' http it would connect.... am I wrong?
    (fine: I meant: one problem solved)
    Andrew Hankinson
    @ahankinson
    it's connecting when it gets the 404 too
    Luca Guariento
    @lguariento
    ok
    Andrew Hankinson
    @ahankinson
    in fact, it's probably getting further
    404 comes from the server
    Luca Guariento
    @lguariento
    I see
    Andrew Hankinson
    @ahankinson
    so it's actually a step backwards to omit the http
    I have to go now...
    Luca Guariento
    @lguariento
    ok
    I'll let you know if/how it proceeds...
    Andrew Hankinson
    @ahankinson
    ok... ttyl!