These are chat archives for bchavez/Bogus

25th
Oct 2017
Brian Chavez
@bchavez
Oct 25 2017 04:54
Hi @gregsdennis , we previously supported netstandard 1.x back in Bogus v16.0.3: https://www.nuget.org/packages/Bogus/16.0.3
Brian Chavez
@bchavez
Oct 25 2017 05:22
The biggest issue was some of the missing reflection APIs. With netstandard 2, it's no longer a problem. Also, Bogus, for some reason when tied to netstandard 1.x didn't work on Xamarin. But now, with netstandard 2, it works on Xamarin.
Greg Dennis
@gregsdennis
Oct 25 2017 09:37
okay. Looks like a cool lib, and I’d like to use it, but we are running 1.6.
Brian Chavez
@bchavez
Oct 25 2017 18:06
@gregsdennis Cool. Maybe give v16.0.3 a try for netstandard 1.x compatibility.. let me know how it goes.
Greg Dennis
@gregsdennis
Oct 25 2017 20:24
Will do. Thanks.
Greg Dennis
@gregsdennis
Oct 25 2017 20:41
well it seems I have a conflict. I have another package which requires Newtonsoft.Json >=9 & <10, but v16.0.3 requires >=10.0.3.
looks like v11.0.4 is supported...
Brian Chavez
@bchavez
Oct 25 2017 22:58
@gregsdennis I've been working on trying to remove Newtonsoft as a dependency to remove issues like that. IIRC, issue #89 is the same kind of issue. Eliminating Newtonsoft completely is still a work in progress.