These are chat archives for beniz/deepdetect

13th
May 2016
Ajinkya Kale
@ajkl
May 13 2016 17:46
@beniz we can discuss the custom model here if thats more convenient for you
Emmanuel Benazera
@beniz
May 13 2016 17:47
Hi @ajkl this is indeed better :)
Ajinkya Kale
@ajkl
May 13 2016 18:28
sorry got into something else
btw what time zone are you in ?
Emmanuel Benazera
@beniz
May 13 2016 18:34
CET with a newborn, which basically means being on a plane around the world ;)
Ajinkya Kale
@ajkl
May 13 2016 18:34
:D
so i will take your suggestion and try to get the predict service working on the custom model first
i will search for documentation on that
Emmanuel Benazera
@beniz
May 13 2016 18:35
Best thing to do indeed
Ajinkya Kale
@ajkl
May 13 2016 18:36
new to caffe, so sorry for all the stupid questions
btw congratulation on the newborn : )
tmeroniown
@tmeroniown
May 13 2016 18:52
I was able to get Resnet152 to work with the predict call - if thats what you guys are talking about :-)
Ajinkya Kale
@ajkl
May 13 2016 19:14
@tmeroniown was it a fined tuned one or a pretrained model ?
Emmanuel Benazera
@beniz
May 13 2016 19:38
This shouldn't matter.
tmeroniown
@tmeroniown
May 13 2016 20:17
whats the problem you are facing?
give me some more context and maybe I can help you
Ajinkya Kale
@ajkl
May 13 2016 20:57
@tmeroniown i was trying to get a imgsearch working with a custom-resnet.caffemodel
This message was deleted
This message was deleted
tmeroniown
@tmeroniown
May 13 2016 20:59
and what issue are you facing?
Ajinkya Kale
@ajkl
May 13 2016 21:00
i am not able to get the right setup for the custom model .. is there a tutorial explaining that ?
do i need anything other than the caffemodel and the deploy prototxt
the service creation fails
tmeroniown
@tmeroniown
May 13 2016 21:02
whats the error message
Ajinkya Kale
@ajkl
May 13 2016 21:02
{"status":{"code":500,"msg":"InternalError","dd_code":1007,"dd_msg":"/deepdetect/build/caffe_dd/src/caffe_dd/include/caffe/llogging.h:153 / Fatal Caffe error"}
tmeroniown
@tmeroniown
May 13 2016 21:02
what machine are you running on?
Ajinkya Kale
@ajkl
May 13 2016 21:02
ubuntu 14.04
tmeroniown
@tmeroniown
May 13 2016 21:03
hardware? gpu?
Ajinkya Kale
@ajkl
May 13 2016 21:03
curl -X PUT "http://localhost:8080/services/imageserv" -d "{\"mllib\":\"caffe\",\"description\":\"image classification service\",\"type\":\"supervised\",\"parameters\":{\"input\":{\"connector\":\"image\"},\"mllib\":{\"nclasses\":2000}},\"model\":{\"templates\":\"../templates/caffe/\",\"repository\":\"/deepdetect/demo/imgsearch/model\"}}"
my model file is in the "repository" path
i have 2000 classes
tmeroniown
@tmeroniown
May 13 2016 21:04
whats the batch in the deploy.txt
sorry meant deply.prototxt
Ajinkya Kale
@ajkl
May 13 2016 21:05
there is no batch specified ... i can add it same as the resnet-50 to make the batch_size=1
(the model is based on resnet-50)
tmeroniown
@tmeroniown
May 13 2016 21:05
under memory_data_parm in the deploy.prototxt
what type of GPU do you have? are you running on AWS?
try to add batch_size=4 under memory_data_parm
make sure to kill and restart the dede process after you do that
Ajinkya Kale
@ajkl
May 13 2016 21:13
sure
let me try that
yes i kill dede everytime
tmeroniown
@tmeroniown
May 13 2016 21:14
are you running on AWS?
Ajinkya Kale
@ajkl
May 13 2016 21:14
no
my own machine
tmeroniown
@tmeroniown
May 13 2016 21:14
and you were able to instantiate other/simpler models?
Ajinkya Kale
@ajkl
May 13 2016 21:14
i have nvidia titan black
yes i am
i got the pretrained resnet-50 working
with the search script with some help from @beniz
beniz/deepdetect#118
Ajinkya Kale
@ajkl
May 13 2016 21:20
i tried setting the batch_size=1 but i get the same error
This message was deleted
^ this is what i see on the server
0513 14:18:40.145424 9722 caffelib.cc:1202] Using pre-trained weights from /home/ajinkya/deepdetect/demo/imgsearch/model/custom-resnet-50.caffemodel
INFO - 14:18:40 - Network initialization done.
INFO - 14:18:40 - Ignoring source layer data
ERROR - 14:18:40 - service creation call failed
tmeroniown
@tmeroniown
May 13 2016 21:28
where did you get the deploy file from?
Ajinkya Kale
@ajkl
May 13 2016 21:28
someone built it for me
tmeroniown
@tmeroniown
May 13 2016 21:29
how do you know its correctly representing the network architecture?
Ajinkya Kale
@ajkl
May 13 2016 21:30
he uses in one of his deployments
so pretty confident its represents the network architecture correctly
tmeroniown
@tmeroniown
May 13 2016 21:35
did you put the deploy file in the same directory as the caffemodel file? did you try to run on CPU only first?
Ajinkya Kale
@ajkl
May 13 2016 21:36
yes both are together .. i am going to try cpu only now
quick question - how do i add cpu in the curl command for imgserv
tmeroniown
@tmeroniown
May 13 2016 21:43
you probably need to add this element to the JSON parameters_mllib = {'gpu':False}
Ajinkya Kale
@ajkl
May 13 2016 21:44
oh you are referring to imgsearch
i was advised to get the imgserv running first
but i get the point .. will figure the param
tmeroniown
@tmeroniown
May 13 2016 21:44
sorry I have to run now