These are chat archives for beniz/deepdetect

31st
May 2016
Isaacpm
@Isaacpm
May 31 2016 18:47
@beniz, issue opened, hopefully with enough info. But will provide whatever info you need or the models, etc...
It feels like an endless test, lol
I was expecting my decision tree with ensembles of models at each point to work much better than just a model or an ensemble of models without the decision tree, but it's not the case
also expected xgboost to work better than the others and it didn't
it feels that it's all very relative to your case
(to my case, in this case, lol)
Emmanuel Benazera
@beniz
May 31 2016 19:00
first you need something that works OK, then you will be able to tweak in order to refine the results
most importantly look at cmdiag and cmfull matrix
and try to balance the categories of your dataset
maybe you've done all that already
@Isaacpm regarding #138, give me your PUT /service call please
Isaacpm
@Isaacpm
May 31 2016 19:07
I tried to balance the categories, but not succesfully by what I've seen
let me get you that put service call
updated the issue
Emmanuel Benazera
@beniz
May 31 2016 19:14
not sure I see the PUT call in a clear format, but I can guess values. Your repository as reported in the error by the server looks weird: /models/accp/department./ADAM_1000-550_5d28d92_0-05_mlp_relu_2_2_200_200
the department./ADAM is not a good sign
Isaacpm
@Isaacpm
May 31 2016 19:14
sorry, it's like the python put
not the REST put
Emmanuel Benazera
@beniz
May 31 2016 19:15
that's OK
Isaacpm
@Isaacpm
May 31 2016 19:15
yes, it has a . in the name, is that a problem?
OS doesn't seem to have any problems with that
Emmanuel Benazera
@beniz
May 31 2016 19:15
can you ls the repository fine ?
Isaacpm
@Isaacpm
May 31 2016 19:15
sure
sorry, yes
I can copy files, chmod, do anything I want in it
Emmanuel Benazera
@beniz
May 31 2016 19:16
and a deploy.prototxt file is in it ?
Isaacpm
@Isaacpm
May 31 2016 19:16
yep
I can ls -l that file
Emmanuel Benazera
@beniz
May 31 2016 19:16
OK, check the repository permissions then
Isaacpm
@Isaacpm
May 31 2016 19:16
no problem
Emmanuel Benazera
@beniz
May 31 2016 19:16
compare to the owner of /opt/deepdetect
Isaacpm
@Isaacpm
May 31 2016 19:16
I gave 777, I know, awesome practice
ok, will compare the owners, just in case
Emmanuel Benazera
@beniz
May 31 2016 19:18
but man, I keep thinking your directory is weird: /models/accp/department.home_and_garden.furniture/ADAM_400-200_home_and_garden_furniture_0-05_mlp_relu_2_2_50_200 vs /models/accp/department./ADAM_1000-550_5d28d92_0-05_mlp_relu_2_2_200_200 in the error ?
Isaacpm
@Isaacpm
May 31 2016 19:18
ups, that's my bad
let me check, I wanted to make it all consistent with the error, and I missed something
Emmanuel Benazera
@beniz
May 31 2016 19:19
just making sure
Isaacpm
@Isaacpm
May 31 2016 19:20
done, it errors for all of them, I got mixed the error with the service creation, sorry
now all consistent in the issue
I've checked the owner, that's going to be a tough one
let me see if I create a dd user in the host and that makes a difference
Emmanuel Benazera
@beniz
May 31 2016 19:21
juste chown it from the inside of the container and test again
Isaacpm
@Isaacpm
May 31 2016 19:21
what's the password?
inside the container, need to sudo to do that
Emmanuel Benazera
@beniz
May 31 2016 19:22
there's no pwd
Isaacpm
@Isaacpm
May 31 2016 19:22
when I sudo it asks me for one
Emmanuel Benazera
@beniz
May 31 2016 19:23
it's a docker ubuntu image and a user is created, see https://github.com/beniz/deepdetect/blob/master/docker/cpu/Dockerfile#L11
Isaacpm
@Isaacpm
May 31 2016 19:24
ok, good, let me try that
same thing, it has 777 as the permissions so the user shouldn't matter
and it seems it doesn't
Emmanuel Benazera
@beniz
May 31 2016 19:26
log in as user dd and try to read from it, just for the sake of ruling this out
Isaacpm
@Isaacpm
May 31 2016 19:27
sure, let me try again, I've restart the container after changing the permission
Emmanuel Benazera
@beniz
May 31 2016 19:27
and next try to remove the . from the path, it may confuse the breaking of files, when looking from prototxt files
Isaacpm
@Isaacpm
May 31 2016 19:28
ok, will see how, it breaks up my decision tree
just did a cat on the deploy file with the dd user
will try removing the . from the path and let you know
Emmanuel Benazera
@beniz
May 31 2016 20:09
verdict ?
Isaacpm
@Isaacpm
May 31 2016 20:10
sorry, was doing something else....
won't have time to do this now, need to change the logic a bit
Emmanuel Benazera
@beniz
May 31 2016 20:24
don't, just change the repository name in your docker container, and update your PUT / POST calls
Isaacpm
@Isaacpm
May 31 2016 20:43
ah, good point
just one thing, it does work like that when I don't use docker
Isaacpm
@Isaacpm
May 31 2016 20:53
same thing
service adam_1000-550_5d28d92_0-05_mlp_relu_2_2_300_200 mllib bad param: no deploy file in /models/accp/department/ADAM_1000-550_5d28d92_0-05_mlp_relu_2_2_300_200 for initializing the net
removed the . in the folder name
but as said those names work when not using dede from a docker container, so should be something else
Emmanuel Benazera
@beniz
May 31 2016 21:21
OK, I'll try stuff tomorrow
Isaacpm
@Isaacpm
May 31 2016 21:48
cool, thanks :-)