Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Björn Grüning
@bgruening
That one should work 🙂
Vesselin Baev
@vebaev
Hi, we are using 19.01 Docker but now on every instance, we cannot install/update tools anymore; we got - "Repository installation is not possible due to an invalid Galaxy URL: <b>None</b>. You may need to enable third-party cookies in your browser"
Bert Droesbeke
@bedroesb

Hello everyone,
I would like to change the middle panel of the galaxy Galaxy docker instance in the "flavor" I am working on and is provided through quay.io. I was wondering what the best way is to do this, since I would like to do this without the /export directory. The things I tried are:

  • manipulating the /galaxy-central/static/welcome.html file
  • changing the welcome_url in /etc/galaxy/galaxy.yml
    Both things did not affect the middle panel ....

Thank you in advance

I just came across the personalize your galaxy section in the documentation, will try that first ;)
Bert Droesbeke
@bedroesb
adding a welcome.html to /home/user/galaxy_storage/ also didn't affect the outcome
Bert Droesbeke
@bedroesb
Ok I solved the problem: deleting the cash of my browser. Changing the html of the container did not have an effect because of it...
Bert Droesbeke
@bedroesb
Hello everyone,
Are there people with experience using the galaxy docker image on MacOS? It seems that cvmfs is not working if the --privileged tag is used, while the same containers works perfectly on linux/windows. Are there additional steps that have to be taken to make this work on MacOS?
Thank you in advance
Romain Dallet
@RomainDallet

Hi everyone,
I want to propose a docker galaxy stable with some tools available on the toolshed for a project. I had a working version in September but when I added a new tool in December an error appeared.

py35 inst: /home/galaxy/bioblend-master/.tox/.tmp/package/1/bioblend-0.14.0.zip
ERROR: invocation failed (exit code 1), logfile: /home/galaxy/bioblend-master/.tox/py35/log/py35-2.log
================================== log start ===================================
DEPRECATION: Python 3.5 reached the end of its life on September 13th, 2020. Please upgrade your Python as Python 3.5 is no longer maintained. pip 21.0 will drop support for Python 3.5 in January 2021. pip 21.0 will remove support for this functionality.
Processing ./.tox/.tmp/package/1/bioblend-0.14.0.zip
ERROR: Package 'bioblend' requires a different Python: 3.5.2 not in '>=3.6'
=================================== log end ====================================
___________________________________ summary ____________________________________
ERROR:   py35: InvocationError for command /home/galaxy/bioblend-master/.tox/py35/bin/python -m pip install --exists-action w .tox/.tmp/package/1/bioblend-0.14.0.zip (exited with code 1)

So I upgraded the version of python to 3.6 in my .travis.yml file :

python: 3.6
env:
  - TOX_ENV=py36

But now I have this error:

py36 create: /home/galaxy/bioblend-master/.tox/py36
ERROR: InterpreterNotFound: python3.6
___________________________________ summary ____________________________________
ERROR:  py36: InterpreterNotFound: python3.6
Makefile:63: recipe for target 'test_bioblend' failed
make: *** [test_bioblend] Error 1
The command "make test_bioblend" exited with 2.

I also tried with python 3.7. I don't understand why he can't find the interpreter anymore. Any ideas ?
Thank you in advance

Alper Yilmaz
@alperyilmaz
Hi there. Testing the bgruening/galaxy-stable image and it works fine in my local machine.. I can install a tool from toolshed and use it. However, when I installed it in a server and run it with docker, tool installation is not complete, I get "Conda dependency seemingly installed but failed to build job environment." error. I did everything same in both computers but couldn't figure out the problem. I guess it's permission issue at server but don't know how to debug it.
ifubar (ross lazarus)
@ifubar:matrix.org
[m]
Is it just me or does the current galaxy/Dockerfile build for anyone else? Line 91 has postgres commented out and it fails with -su: /usr/lib/postgresql/11/bin/initdb: No such file or directory
sed: can't read /etc/postgresql/11/main/postgresql.conf: No such file or directory
postgresql: unrecognized service
-su: psql: command not found
-su: createdb: command not found
postgresql: unrecognized service
postgresql: unrecognized service
`
ifubar (ross lazarus)
@ifubar:matrix.org
[m]
:point_up: Edit: Is it just me or does the current galaxy/Dockerfile build for anyone else? Line 91 has postgres commented out and it fails with
-su: /usr/lib/postgresql/11/bin/initdb: No such file or directory sed: can't read /etc/postgresql/11/main/postgresql.conf: No such file or directory postgresql: unrecognized service -su: psql: command not found -su: createdb: command not found postgresql: unrecognized service postgresql: unrecognized service
ifubar (ross lazarus)
@ifubar:matrix.org
[m]
Well. Guess who didn't do git submodule update --init --recursive. Sorry for the noise.
mtruglio
@mtruglio

hello, I have a question about galaxy+docker. I'm building an image on top of bgruening. I successfully added my some public (devteam) tools, plus my own tools. In the dockerfile I execute RUN install_tool_deps -v -u $GALAXY_DEFAULT_ADMIN_USER -p $GALAXY_DEFAULT_ADMIN_PASSWORD -g http://localhost:8080 -t /data/local_tool_conf.xml, it seems to be working. It shows progress while installing all dependencies in mulled conda environments.

Then, I start a container. Log in as admin, under Dependencies I see that all my tools have the green flag, dependencies are met. The mulled environments are physically there. When I try to launch a tool, though, it returns an error, saying "Not a conda environment", and showing me the path of the mulled environment. Observations:

the path shown in the error is correct
if I bash inside the container, I can activate the environment, and the tool works ok if launched from the command line.
docker file: https://pastebin.com/5SD4AJ1B

Björn Grüning
@bgruening
can you do an ls -l in the mulled-env?
what do you see?
mtruglio
@mtruglio
image.png

some more interesting elements:

  • all the tools installed from the standard toolshed work fine. No problems there, their environments are recognized as such.
  • if I exclude the install_tool_deps instruction from the dockerfile, and I run it in a container afterwards, it complains about permissions, and suggests to chown -R 1450:1450 /tool_deps/_conda/pkgs/cache
  • If I actually execute chown -R 1450:1450 /tool_deps/_conda/pkgs/cache then install_tool_deps starts working fine, and the environments it creates (identical to the non-working ones from before), work fine.

I would say this is a permissions issue. Somehow the mulled environments -which are installed after the startup-lite instruction, are not available to the galaxy user 'admin' for activation.

Björn Grüning
@bgruening
But than you can change the user in your dockerfile before executing RUN install_tool_deps -
the easiest way would be probably to upload your tools to the ToolShed again
mtruglio
@mtruglio
hmm ok. What should I write in my Dockerfile to change user?
Björn Grüning
@bgruening
USER galaxy
mtruglio
@mtruglio
ok let me try this. Thanks a lot, much appreciated
image.png
meanwhile: changing owner to the already installed - and not working - mulled environment folder, makes it work again. So yes, it's just a matter of installing dependencies as 'galaxy' and not root.
mtruglio
@mtruglio
so, the problem with USER galaxy is that if I insert it before startup-lite, it gets stuck on "Waiting for database" forever.
but install_tool_deps needs a running server in order to work. Ideas?
ifubar (ross lazarus)
@ifubar:matrix.org
[m]
perhaps add USER root where you need docker to switch back to acting as root?
mtruglio
@mtruglio
yeah, but the issue here seems to be this:
  • install_tool_deps needs to be run as galaxy user in order to create the envs with the correct ownership
  • install_tool_deps also needs a running startup_lite in order to work, a galaxy server at localhost:8080 must be alive somehow.
  • Unfortunately, startup_lite needs to be launched while acting as root, otherwise it gets stuck on 'waiting for database'
so I cannot find a way to launch install_tool_deps while a galaxy server is alive
(as non-root)
Björn Grüning
@bgruening
@mtruglio you can also just add your chmod/chuser to the Dockerfile after you have installed your tools
mtruglio
@mtruglio
yep, that's what I'm trying now :)
mtruglio
@mtruglio
Ok so it seems that the smartest way to solve this is to run chgrp -R galaxy /tool_deps/_conda/envs && chmod g+s -R /tool_deps/_conda/envs just after startup_lite. This way, all the envs that will be placed in that folder will inherit the galaxy group ownership. Running chmod/chuser after the installation of all the dependencies would have worked as well, but it would be excruciatingly long.
Björn Grüning
@bgruening
:+1:
Jennifer Hillman-Jackson
@jennaj
Question at the lobby. The build is older and there are some similar existing issue tickets plus the chat above seems to be related. I'll point them back here. https://gitter.im/galaxyproject/Lobby?at=61527e14a41fd20699b24c1a includes a link to an issue ticket bgruening/docker-galaxy-stable#587
Steven Shum
@shenweiyan
I have tried to install docker-galaxy-stable, however, there is a problem that doesn't work correctly, it seems docker galaxy cannot start normally, does anyone know how to solve this problem? Thank you. bgruening/docker-galaxy-stable#587
Kenzo52YZ
@Kenzo52YZ
@shenweiyan tried to answer you
by the way it seems like this issue has been encountered by many before trying to use different systems to run the docker image
Steven Shum
@shenweiyan
@Kenzo52YZ Thank you for your reminder.
Edgar F
@gad83
the package https://wheels.galaxyproject.org/simple/futures/futures-3.1.1.tar.gz
seems to be causing an issue : bgruening/docker-galaxy-stable#588
is it possible we are supposed to use the other one: https://wheels.galaxyproject.org/simple/futures/futures-3.1.1-py2-none-any.whl
can we add a condition in the file requirements.txt to determine when to use eachpackage?
Steven Shum
@shenweiyan
Hi everyone,
I have developed some tools locally and packaged them in my docker. Does anyone know how to run my own docker on galaxy-docker?
Thank you in advance.
Jennifer Hillman-Jackson
@jennaj
1 reply
Jennifer Hillman-Jackson
@jennaj
Another Galaxy Help question. The person is trying to implement expanded login authentication methods. https://help.galaxyproject.org/t/unable-to-activate-google-oidc-login/7910