Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 06:14
    BiocondaBot labeled #28491
  • 06:14
    BiocondaBot labeled #28491
  • 06:14
    BiocondaBot opened #28491
  • 05:59
    BiocondaBot commented #28489
  • 04:12
    BiocondaBot labeled #28490
  • 04:12
    BiocondaBot labeled #28490
  • 04:12
    BiocondaBot opened #28490
  • 04:10
    BiocondaBot labeled #28489
  • 04:10
    BiocondaBot labeled #28489
  • 04:10
    BiocondaBot opened #28489
  • 00:43
    BiocondaBot commented #27768
  • May 13 22:52
    leoisl synchronize #27768
  • May 13 20:50
    heuermh commented #28486
  • May 13 20:50
    heuermh commented #28487
  • May 13 20:11
    BiocondaBot labeled #28488
  • May 13 20:11
    BiocondaBot labeled #28488
  • May 13 20:11
    BiocondaBot opened #28488
  • May 13 19:53
    BiocondaBot closed #28486
  • May 13 19:51
    BiocondaBot commented #28486
  • May 13 19:51
    dpryan79 commented #28486
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#27968
Pierre Morisse
@morispi
Hi. I'm attempting to release one of my tools on conda for the first time, and I'm encountering linking issues that do not appear when compiling the sources (undefined reference to « VTT for std::__cxx11::basic_stringstream<char, std::char_traits<char>, std::allocator<char> >@GLIBCXX_3.4.21 » and such things). I'm not exactly sure what's wrong? My meta.yaml does mention zlib in build, host, and run (although I'm not sure of the differences between the three), and I also found a link (https://bioconda.github.io/contributor/troubleshooting.html#zlib-errors) with a fix that did not work. I guess I'm overlooking something here, but I'm a bit lost.
6 replies
Oh, forgot to mention. I'm using conda-build to make sure everything works before going any further
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#27980
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#27827
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#27988
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#27990
Oliver Schwengers
@oschwengers
Hello, does anyone know, if (and how) it is possible to define an environment variable within a conda package (per meta.yml or build.sh?) which is automatically set within a conda environment if this package is installed? A 3rd party tool (deepsig) requires an environment variable pointing to a dir containing some binary data files.
Devon Ryan
@dpryan79
@oschwengers The standard way is to add an activation script: https://docs.conda.io/projects/conda-build/en/latest/resources/activate-scripts.html
We have a few recipes with those, though I don't recall any of them off-hand
Oliver Schwengers
@oschwengers
ahh ok I'll have a look at this. thanks @dpryan79
ifubar (ross lazarus)
@ifubar:matrix.org
[m]
Does anyone with review permission have a moment to review this galaxyxml PR please? Tests are good; approved by @hexylena. bioconda/bioconda-recipes#27983
Björn Grüning
@bgruening
done
ifubar (ross lazarus)
@ifubar:matrix.org
[m]
Thanks, @bgruening!
Jacques Dainat
@Juke34
@dpryan79 auto bump didn't work again for AGAT https://github.com/NBISweden/AGAT/releases/tag/v0.6.1
Devon Ryan
@dpryan79
@Juke34 It's currently blacklisted, so it won't be bumped. I'm slowly making my way through things that weren't buildable during the last migration, but it'll take me a while to go through all 100+ of them.
Jacques Dainat
@Juke34
Ok thanks
Pierre Morisse
@morispi
Hi. I'm still facing issues with my PR (bioconda/bioconda-recipes#27989). Apparently it fails to find three functions from bamtools when compiling the binary. Library compilation does appear to work fine, and the said functions do not raise issue. I'm at a loss here, does anyone have any suggestion?
Devon Ryan
@dpryan79
Is the link order correct?
Pierre Morisse
@morispi
It seems so? I don't encounter issues when cloning the repo and making outside of conda
Devon Ryan
@dpryan79
It may be that cmake is using CXXFLAGS, which uses -std=c++17, which I imagine could be causing the issue, but I'm not a C++ person.
Pierre Morisse
@morispi
Oh, that could be it indeed. I tried adding -std=c++11 to the CXXFLAGS in my build.sh, but it didn't work out. Is there a special way I should constraint cmake to use c++11?
Devon Ryan
@dpryan79
You'd need to override the flags. They're set by the compiler activation packages. Presumably a simple export CXXFLAGS="-std=c++11 ..."would work.
Pierre Morisse
@morispi
Yeah, I did that already, but it did not seem to fix the issue. Apparently cmake / compilation of bamtools overrides the -std=c++11. I'm trying to compile bamtools using make CC="-std=c++11" atm. Thanks for your help
Devon Ryan
@dpryan79
Good luck, I hate dealing with cmake because of things like this
Pierre Morisse
@morispi
Nope, still didn't work. If anyone else has any experience with this, it'd be greatly appreciated :)
12 replies
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#28006
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#28005
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#28012
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#28011
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#28007
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#28019
M Bernt
@bernt-matthias

What is meant by Needs the TBB repodata patch so it doesn't pull in a broken bowtie2

https://github.com/bioconda/bioconda-recipes/blob/a8ea307c5edc14a180138a4adbb9600eb5cf1af6/build-fail-blacklist#L198

?

Devon Ryan
@dpryan79
At the moment it tends to pull in an old build that incorrectly permits using a newer TBB
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#28020
PR ready for review: bioconda/bioconda-recipes#28023
M Bernt
@bernt-matthias

Just trying to bump bowtie2 bioconda/bioconda-recipes#28021 .. the build uses a 2020 version of tbb (which is not the latest) and contains loads of:

TBB Warning: tbb.h contains deprecated functionality. For details, please see Deprecated Features appendix in the TBB reference manual

wondering if the solution is to pin tbb and tbb-devel? And if so, then to which version <2021?

Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#28002
PR ready for review: bioconda/bioconda-recipes#28010
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#28023
Devon Ryan
@dpryan79
@bernt-matthias I've already rebuilt bowtie2 for the corrected TBB pinning. We and conda-forge are building against TBB 2020.
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#28004
M Bernt
@bernt-matthias
@dpryan79 OK. Then I guess we only need to rebuild metaphlan. Thanks.
Ed Harry
@EdHarry
Anyone know why bioconda/bioconda-recipes#28011 fails to merge?
Devon Ryan
@dpryan79
@EdHarry I'll have a look
OK, it's a small error in the bot, I'll merge it in for now so the standard uploader can run.
Bioconda Bot
@BiocondaBot
PR ready for review: bioconda/bioconda-recipes#28018
Björn Grüning
@bgruening
@dpryan79 it seems this problem also occurs here: bioconda/bioconda-recipes#28031
so it seems a general one?
Ed Harry
@EdHarry
Thanks @dpryan79