These are chat archives for biom262/biom262-2016

15th
Feb 2016
thewilmergency
@thewilmergency
Feb 15 2016 00:33
I'm not exactly sure. I went back a few cells and ran those again and then it worked
Olga, I'm getting an assertion for Exercise 7 but I think it's right...
Screenshot 2016-02-14 16.34.32.png
Olga Botvinnik
@olgabot
Feb 15 2016 01:31
Can you show what the output of that cell is?
Without the assert
As in, the data frame.loc of the gene
thewilmergency
@thewilmergency
Feb 15 2016 01:34
oh ok
Screenshot 2016-02-14 17.34.15.png
It's just slightly different...
I get the same issue when I made my tpm column...
Screenshot 2016-02-14 17.36.26.png
thewilmergency
@thewilmergency
Feb 15 2016 01:43
But when I made the log2_tpm column it was okay...
LElmen
@LElmen
Feb 15 2016 06:23
Hi, I can't find the info on what to do when login to tscc prompts a password. Anyone?
ericsan119
@ericsan119
Feb 15 2016 10:17
@olgabot Hi Olga, for the exercise 13, I think it's correct, but my output is slightly different with yours... Could you give me a hint where I did mistake?
Screen Shot 2016-02-15 at 2.10.55 AM.png
ecpierce
@ecpierce
Feb 15 2016 18:05
@LElmen try opening a new terminal window, entering this: ssh-add ~/.ssh/biom262_rsa and then try logging in to tscc again
LElmen
@LElmen
Feb 15 2016 21:37
@ecpierce Worked like a charm! Thank you
Pedro Torres
@pjtorres
Feb 15 2016 21:58
Hey Olga,

I have been having a similar error to

thewilmergency. I'm on exercise 6 and I'm having before Everything was working the other day and I tried running sns.distplot(s10_featurecounts['/home/ucsd-train20/projects/shalek2013/processed_data/S10.Aligned.out.sorted.bam']) and it wont read my file even though it is in my folder.

Pedro Torres
@pjtorres
Feb 15 2016 22:12
Figured it out, my output file was going to the wrong place.
vwfu
@vwfu
Feb 15 2016 22:44

@olgabot I am getting the following error message in exercise 16 when i try to split the GENCODE IDs: ---------------------------------------------------------------------------
AttributeError Traceback (most recent call last)

<ipython-input-311-1af4887c03b8> in <module>()
11
12
---> 13 featurecounts_s13_specific_genes_ensembl.head()

AttributeError: 'numpy.ndarray' object has no attribute 'head'

@ericsan119 did you add one to the TPM before logging it?
@pjtorres that sounds like you may not have created the variable s10_featurecounts yet
even though the file /home/ucsd-train20/projects/shalek2013/processed_data/S10.Aligned.out.sorted.bam exists, that’s not what that command is doing
that command is looking for a variable called s10_featurecounts
oh you figured it out got it..
@vwfu can you show the full code that’s producing the error?
vwfu
@vwfu
Feb 15 2016 22:56

@olgabot featurecounts_s10_specific_genes = featurecounts_s10_specific_genes.copy()
featurecounts_s13_specific_genes = featurecounts_s13_specific_genes.copy()

featurecounts_s10_specific_genes.index.map(lambda x: x.split('.')0)
featurecounts_s13_specific_genes.index.map(lambda x: x.split('.')0)

featurecounts_s10_specific_genes_ensembl = featurecounts_s10_specific_genes.index.map(lambda x: x.split('.')0)
featurecounts_s13_specific_genes_ensembl = featurecounts_s13_specific_genes.index.map(lambda x: x.split('.')0)

featurecounts_s13_specific_genes_ensembl.head()

Olga Botvinnik
@olgabot
Feb 15 2016 22:57
You need to add the pd.Series() code around it
Only DataFrames and Series can do.head()
I believe earlier it says to do:
pd.Series(featurecounts_s13_specific_genes.index.map(lambda x: x.split(‘.')[0]))
ack
ugh it formatted the quotes
those are supposed to be quotes
ericsan119
@ericsan119
Feb 15 2016 23:01
@olgabot Yes I did...
Screen Shot 2016-02-15 at 3.00.51 PM.png
Olga Botvinnik
@olgabot
Feb 15 2016 23:01
@ericsan119 was your TPM calculation correct?
did you have errors there?
someone ran into a problem where their TPM calculation was off in the 12th significant figure or something
Olga Botvinnik
@olgabot
Feb 15 2016 23:24
if you’re getting errors that far into the value, don’t worry about it - I will acount for it
ericsan119
@ericsan119
Feb 15 2016 23:25
@olgabot I check my calculation again, I didn't errors in exercise 8. So I think my TPM calculation is correct.
Olga Botvinnik
@olgabot
Feb 15 2016 23:25
hmm the only thing I can think of is if you ddin’t add one
ericsan119
@ericsan119
Feb 15 2016 23:26
Screen Shot 2016-02-15 at 3.24.19 PM.png
Olga Botvinnik
@olgabot
Feb 15 2016 23:30
Yeah I’m checking with my answer now
Yeah what you have is correct - since the difference is in the .000000001 range I’ll adjust to ignore it
ericsan119
@ericsan119
Feb 15 2016 23:35
Thank you @olgabot