Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Gregg Roemhildt
    @roemhildtg
    Chasen Le Hara
    @chasenlehara
    I’m looking at your project right now…
    Right now, Travis is running your tests with Node 6 and npm 3, so your package-lock is being ignored
    When I ignore the package-lock and install the dependencies, I see errors in Firefox’s console
    Chasen Le Hara
    @chasenlehara
    So I would probably just change your Travis config to use more recent versions of Node and npm (to match your dev environment)
    Let me know if that does the trick @roemhildtg
    Gregg Roemhildt
    @roemhildtg
    Ok! will do Thanks
    Gregg Roemhildt
    @roemhildtg
    I think the errors you have seen though are from the master branch, right? They should be fixed in the "reogranize" branch
    I'm getting all tests passing in firefox
    Chasen Le Hara
    @chasenlehara
    Yeah, I just checked out master
    Paul Tichonczuk
    @tracer99
    Had unit tests working using headless chrome. Several updates of chrome later, and I now get errors like Unable to locate service manifest for metrics and Failed to resolve service name: metrics
    eventually I get the 120ms timeout
    If I try running it not headless, I see the browser open with the right URL, but nothing happens and it fails with the same timeout (but without those above errors)
    Paul Tichonczuk
    @tracer99
    UGH!. It was the delay. Increased it to 2000 from the default 1000 and it works now
    Ivo Pinheiro
    @ivospinheiro
    Hi guys is anyone has any sample project about how to have code coverage with testee? I've tried to put it working but it is always hanging while instrumenting the code.
    Kevin Phillips
    @phillipskevin
    @ivospinheiro can you run it with DEBUG=testee:*? You should be able to see what file it is hanging on.
    Ivo Pinheiro
    @ivospinheiro
    I've created a sample project using donejs create app
    made some changes and published on my github https://github.com/ivospinheiro/donejs-testee-coverage
    npm run check-coverage
    Kevin Phillips
    @phillipskevin
    what does testee-coverage-config.json look like?
    make sure you do something like
        "coverage": {
          "ignore": [ "node_modules" ]
        }
    Ivo Pinheiro
    @ivospinheiro
    sorry I've forgot to push the missing file
    already on the repo
    Kevin Phillips
    @phillipskevin
    ok, I'll try it out
    Ivo Pinheiro
    @ivospinheiro
    It hangs after:
      testee:coverage should instrument /node_modules/funcunit/browser/adapters/mocha.js +1ms
      testee:coverage should instrument /node_modules/steal-css/css.js +6ms
      testee:coverage should instrument /node_modules/syn/src/mouse.js +1ms
      testee:coverage should instrument /node_modules/syn/src/key.js +0ms
      testee:coverage should instrument /node_modules/steal-qunit/add-dom.js +7ms
      testee:coverage should instrument /node_modules/syn/src/typeable.js +16ms
      testee:coverage should instrument /node_modules/jquery/dist/jquery.js +2ms
    Kevin Phillips
    @phillipskevin
    remove the --coverage from the command
    if you use that, it ignores the coverage option from your config file
    with --coverage:
    image.png
    without it
    image.png
    that's why it is still trying to "instrument" your node_modules folder
    Ivo Pinheiro
    @ivospinheiro
    ok
    I should paid attention to the console output
    Thanks @phillipskevin
    Kevin Phillips
    @phillipskevin
    there's a lot of messages
    Ivo Pinheiro
    @ivospinheiro
    Yes indeed
    Kevin Phillips
    @phillipskevin
    hard to know what to look for exactly
    Ivo Pinheiro
    @ivospinheiro
    Just a suggestion maybe it makes sense to improve the documentation about code coverage
    Kevin Phillips
    @phillipskevin
    yeah, absolutely
    Ivo Pinheiro
    @ivospinheiro
    If you want I can open a issue for it
    Kevin Phillips
    @phillipskevin
    yeah, that would be great
    Ivo Pinheiro
    @ivospinheiro
    Ok, I'll do that
    Kevin Phillips
    @phillipskevin
    thanks
    I submitted bitovi/testee#169 also
    Ivo Pinheiro
    @ivospinheiro
    Hi!
    In the project that I'm currently working we have lots of Unit/Functional tests using QUnit+FuncUnit, and these tests are taking a significative time to run, about 30 minutes.
    Is it possible to configure testee to run tests in parallel?
    The tests are running on chrome headless and testee is configured to use xunit-file as reporter.
    Also, it seems that on xunit-file we can't configure the reporter output file without using XUNIT_FILE environment variable.
    Justin Meyer
    @justinbmeyer
    I've only every done it by starting testee 3 times with different config
    by parallel, you mean different browsers in parallel